Community
Showing results for 
Search instead for 
Do you mean 
Reply

ACT 2009 quites with .NET Runtime errors

New Member
Posts: 7
Country: United States

ACT 2009 quites with .NET Runtime errors

On one PC ACT 2009 displays the familiar "ACT has encountered a problem and must close..." message.  In the application event log you see Event ID 1023, source is .NET Runtime, .NET Runtime version 2.050727.789 - Fatal Execution Engine Error (7A058611) (80131506).  ACT has been uninstalled and the ACT uninstall cleanup utility run plus the registry gone through and purged of any ACT reference.  Everyone else can open the database just fine.  Tried the MachineConfigUpdater.exe without success.  Service pack 1 for dotnet 2.0 was also unsuccessfull.  Have not tried dotnet 3.5.

 

Any help is appreciated.

 

John.

Copper Elite Contributor
Posts: 108
Country: United States

Re: ACT 2009 quites with .NET Runtime errors

johnfds,

 

Surprising, in all that you did, which was very thorough, you may have missed the obvious step.  You must uninstall Act!, reboot, then Uninstall .Net 2.0, reboot, then install .Net 2.0, reboot, then install Act!.  I know, it sucks, and is a lengthly process, but it should resolve your problem.

 

I believe this Answer ID is related: Error: "ACT! Has Encountered an Error and Needs to Close" After Applying Microsoft® Updates.  Good luck.

 

MrWright

New Member
Posts: 7
Country: United States

Re: ACT 2009 quites with .NET Runtime errors

Did the whole uninstall, reboot, install and now have ACT 2009 working.  Turns out it is the 4Advisors addon that causes the error.  With it installed ACT errors out.  Uninstall it and ACT is fine.

John

 

Nickel Super Contributor
Posts: 492
Country: United States

Re: ACT 2009 quites with .NET Runtime errors

4Advisors plugin will only give this error if it is not registered or licensed properly.  Should have contacted the company.