Community
Showing results for 
Search instead for 
Do you mean 
Reply

ACT 2009 problem deleting My Record history and slow database

Copper Contributor
Posts: 13
Country: United Kingdom

ACT 2009 problem deleting My Record history and slow database

Background:

 

We have upgraded our ACT! from 2000 to 2009, and have converted the 2000 database to 2009 format.

 

The 2000 database contained numerous custom fields, and these caused huge problems with the conversion to 2009 - it was not smooth/easy/simple/without huge problems. We now seem to have the database in 2009, but it is very slow.

 

We are also currently using the contact layout from 2000 as an interim measure.

 

The database currently contains around 60,000 contacts, of which there are around 8,000 which are genuinely needed.

 

Problem 1:

 

What we're doing is using ACT lookups to find the contacts we want to delete, and then deleting them. What this also does is adds a line to the My Record history showing that the contacts were deleted. As you can imagine, after deleting a few thousand contacts the My Record history is huge.

 

Efforts to delete the history cause a "parameter not valid" message from ACT, sometimes followed by a program crash but not always. If it doesn't crash, the entire area where History is displayed is replaced by a white box with a red border and red cross through it.

 

Is there any way to switch off My Record history updates (temporarily?) whilst the database clean up is in progress? Or some other way to fix/circumvent this history deletion problem?

 

Problem 2:

 

ACT 2009 is much slower than ACT 2000, despite having upgraded the hardware to a 2.8 GHz P4 from a 1.3GHz P4, and significantly more RAM (1.5GB compared to 512MB). I don't know if this is expected, due to the overhead of the SQL server, or whether we have a problem with the database? Any advice appreciated! I've run maintenance operations on the database from the Tools menu and all is being reported back as OK.

 

Thanks very much,

 

Martin

Platinum Elite Contributor
Posts: 6,652
Country: USA

Re: ACT 2009 problem deleting My Record history and slow database

Problem 1. No you can't turn off the creation of the history entry. However, there is an easier way to do what you want. Save and empty copy of the database then export the user records to the new database, In the new database create the user account for all the users. Finally, in your present database, lookup the contacts you want to keep and export them to the new database..

 

Problem 2. You didn't list the hard drive speed in RPM or the swap file settings. The recommended speed for the hard drive is 7200 RPM or faster. Also max out the swap file settings and exclude the ACT! program from you antivirus autoscan. 

Roy Laudenslager
ACT! Certified Consultant
ACT! Report Expert
Durkin Impact Report Designer
www.techbenders.com
royel@techbenders.com
541-343-8129