Community
Showing results for 
Search instead for 
Do you mean 
Reply

ACT 2009 - Email Attachments not found

New Member
Posts: 3
Country: United States

ACT 2009 - Email Attachments not found

I just upgraded from ACT 2006 to ACT 2009.

None of the email attachments (emails attached to contacts in 2006) work. For new emails sent and attached in ACT 2009, it partially works. Specifically....

For both emails attached in the prior version, as well as emails attached in outlook 2007 to the new version:
When I click on the history item to open it (double click) I get an error:

"Object reference not set to an instance of an object"

 

For emails attached in the prior version:

When I click on the attachment icon (paperclip) directly then I get an error:

"There was an error opening the attachment. It may have been deleted by another user or been created on a database that does not synchronize attachments."

 

(for emails attached in ACT 2009 it does open up the email message when I click direclty on the paperclip)

 

Any suggestions? It is critical for our business to be able to access email attachments to contacts.
Thank you!!

 

TH

 

Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: ACT 2009 - Email Attachments not found

New Member
Posts: 3
Country: United States

Re: ACT 2009 - Email Attachments not found

Thanks Mike,

Two of the articles do not apply since we are not using a synchronized DB and this is not a permission issue either.

Also, the Object not found  error happens for both records/histories created in ACT 2006 prior to the conversoin (and it is working just fine in the ACT 2006 DB), as well as in the new ACT 2009 DB.

 

What I am doing right  now is  testing ACT 2009.

We are running ACT 2006 Premium for work groups with 18,000 records and 10 users.

I saved the file to an ACT 2006 standard file, then backed up and restored using the 'restore as' function the file on a separate box with ACT 2009 standard installed. I then opened/upgraded the file to ACT 2009.

 

The errors described are happening only in the 2009 instance.


Obviously we cannot upgrade to ACT 2009 if we lose our email attachments. In our business we must be able to access past email messages frequently, so this truly is a critical MUST.

 

Thanks for the time.


TH

Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: ACT 2009 - Email Attachments not found

The first 2 articles can still apply... try the damaged preferences fix in ACTDIAG from the first and check the permissions and file associations in the 2nd.
Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: ACT 2009 - Email Attachments not found

Does it work if you click on the attachment icon. IE don't try to open the entire history.
New Member
Posts: 3
Country: United States

Re: ACT 2009 - Email Attachments not found

>>> Does it work if you click on the attachment icon. IE don't try to open the entire history

 

Mike, in ACT 2009, when I click on the icon/paper clip then the email message for messages created in ACT 2009 works. If I try to open the entire history then I get the error.

 

For messages created in ACT 2006 I get an error message either way, i.e. clicking on the icon or opening the history. The errors are two distinct different errors though. I'll try to two suggestions above later today and will post update/whether it worked or not.

Thanks!!

TH

Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: ACT 2009 - Email Attachments not found