Community
Showing results for 
Search instead for 
Do you mean 
Reply

ACT 2009 E-mail error object reference...

New Member
Posts: 2
Country: United States

ACT 2009 E-mail error object reference...

When opening ACT 2009 e-mail or trying to email from ACT, I get "object reference not set to an instance of an object".  Using Outlook 2003 and the add-in links seem to work fine on the Outlook side.  (I recently uninstalled the trial version of Outlook 2007 and have uninstalled and reinstalled ACT since then).
Moderator
Posts: 4,395
Country: USA

Re: ACT 2009 E-mail error object reference...

Try the following steps:

  1. Close ACT! and any Office applications
  2. Open the Add or Remove Programs control panel (Click Start, Control Panel, Add or Remove Programs).
  3. Uninstall Microsoft Office 2007 Primary Interop Assemblies
  4. Launch ACT! and test.

 

New Member
Posts: 2
Country: United States

Re: ACT 2009 E-mail error object reference...

< Uninstall Microsoft Office 2007 Primary Interop Assemblies >

 

Thanks for the suggestion but Office 2007 PIA was previously uninstalled.

 

Any other suggestions?

 

Thanks.

Tuned Listener
Posts: 41
Country: United States

Re: ACT 2009 E-mail error object reference...

You mentioned Outlook 2003, so the problem may be that outlook.exe does not close when an Act address book is installed in Outlook 2003. As a result multiple outlook.exe processes can be running and can cause errors in Act and Outlook. 

 

See http://community.act.com/sage/board/message?board.id=ACT&message.id=18406#M18406 for details.

 

To decide whether this is what's happening: generate the error, close Act and Outlook, and examine the process list in Windows Task Manager (use CTRL ALT Delete to launch task manager). If outlook.exe is on the list, then that likely to be the problem.

 

Sage is aware of the problem and working on a fix. Until then, as a workaround, I'm using an addin that shuts down outlook.exe . See

 

www.daveswebsite.com

 

for more information about the addin.