Community
Showing results for 
Search instead for 
Do you mean 
Reply

ACT!2008 - Sync to Tungsten E2 - can't do under Vista

Accepted Solution Solved
New Member
Posts: 4
Country: Canada
Accepted Solution

ACT!2008 - Sync to Tungsten E2 - can't do under Vista

[ Edited ]

I'm in the middle of a series of upgrades leading to eventually sync'ing ACT to a smart phone.

 

Was using Companionlink Express under WinXP with ACT!2000 on old laptop and loving it - it has worked very well the past 3 years.  With my new laptop, Vista Home Premium (32bit), I've upgraded to ACT!2008 and I cannot sync.  ACT!2008 itself works great (a bit slower than expected), it looks to me that I was able to transition all records successfully.  My only other complaint is that my Logitech mouse buttons cannot be programmed to work within the ACT window.

 

Have installed Palm Desktop 6.2 with the updated HotSync Manager 7.0.2 .  Have uninstalled ACT! Link for Palm per CompanionLink FAQ.  Applied the Palm ACT DBfix patch for the ver 10 database issue where new contacts don't sync, hoping it would help (it didn't).  Can see the Companionlink Conduit names in the HotSync applications fields.  Am attempting to purge all old records but it does not seem to work.

What happens is that I see the sync move quickly through 11 of 13 steps and then it pauses for about 30 seconds and completes... "successfully" it claims but it does not.

I get an error message for the conduits - Companionlink Calender, Contacts, Tasks, & Memos.  

Error: Unknown error. (65535)


Other info:  I'm sync'ing about 10,500 records (was able to do it under WinXP & ACT!2000).  I've checked the Category field and ensured that there are no more than 15 definitions inclusive of "Business", "Personal", and "Unfiled".   One thing I'm doing different is that with ACT!2008 I can assign group members dynamically and am using that function to build groups which are then selected for synchronization.

 

 

Can anyone provide some insight as to where I may have missed an oh so critical enable/disable????

 

.

Message Edited by Carl_L on 05-26-2009 02:43 PM

Accepted Solutions
Solution
Accepted by topic author Carl_L
‎09-25-2015 03:20 AM
New Member
Posts: 4
Country: Canada

Re: ACT!2008 - Sync to Tungsten E2 - can't do under Vista

[ Edited ]

I've solved the issue.

 

A local reseller had ACT!2009 on sale for half price so, out of frustration/desperation and a hunch, I bought and installed it.

 

It was a bit messy getting it installed.  I still had a version of ACT!2006 on the laptop that I had used to convert the ACT!2000 database. When I used the Unistaller that was in the ACT!@006 folder, it also too out the Start menu folder for ACT!2008.  ACT!2008 still ran but ACT!2009 would not install until I removed everything (slightly contrary to the online instructions).  I used the new ACT Uninstaller from the web site to clean up the system.  ACT!2009 then installed.

 

At this point I was able to sync contacts and calendars.  

 

I noticed something odd though.  Every "Don" in the database had "Don" not assigned to the First Name field - Donald's were OK.  There were also a handful of names (no more than 10) where there was only an initial for a first name, and the intial was always "M",  where these exhibited the same behavior as the "Don's".  I picked it up when the sync'd contacts count did not match from ACT to the Palm Desktop.  Noticed a few duplicate entries in Palm Desktop where both entries had no first name. Manually scanned through 12000+ records and assigned the Don's to first name.  After that the sync's were perfectly clean and consistent.

 

What is disturbing to me is that while I was trying to sort these issues out a week ago, I ran ACTDiag and found nothing in the ACT!2008 database.  With the few sync's that I was lucky to complete, I had no issues with duplicate record.  So it looks like in converting from ACT!2008 to ACT!2009, something went wrong.

 

I want to mention that CompanionLink tech support was very patient through this process.  Learned a few things from them that was beneficial to understanding the conduit process. Thank you Nathan V. and Rebecca S..

 

.

Message Edited by Carl_L on 06-11-2009 11:24 PM

View solution in original post


All Replies
Copper Contributor
Posts: 78
Country: United States

Re: ACT!2008 - Sync to Tungsten E2 - can't do under Vista

Have you tried calling CompanionLink tech support at 503-243-5200? 
New Member
Posts: 4
Country: Canada

Re: ACT!2008 - Sync to Tungsten E2 - can't do under Vista

[ Edited ]

Yes, I'm involved with them as well.  So far their suggestions have not worked but I now believe this to be related to Vista.

 

Had some progress last evening/night.  Trying to reproduce it today.  It may be related to Vista's security policies.

 

I have yet to understand what it is that gets blocked by Vista at startup but there is always something for ACT! in Blocked Startup Programs, right from the first day of install.  I bet there is a note on that here somewhere that I have yet to find (but which I will be searching for).

 

Last night I took the steps of enabling "Run as Administrator" for ACT, HotSync Manager, and CompanionLink and actually managed to sync ALL the records that I normally would want to sync (~11,000) but at the time, I had only selected a small portion of the records (~2000) for a test sync.  The sync progress took forever and I came to realize it had hung - after a couple of hours I had to manually terminate both the Companionlink and HotSync applications and also reset my Palm E2.   Although it looks like the contacts have sync'd the calender has not.

 

I cold booted the laptop this morning and it appears there are now TWO HotSync Managers in Blocked Startup programs when there has never been any before.  While sync'ing last night, I noticed in the details of HotSync Manager that there were two instances of Contacts, Calender, Memo, and Tasks in the list that the Sync process stepped through  - am thinking one instance was the Purge & Reload I'd requested and the other is the actual sync of records.

 

So immediately in front of me there are some tasks I want to do:

 

- eliminate this Vista nonsence of a warning that pops up that ACT! is an unrecognized program from an "unidentified publisher" (really Sage.... isn't this something you should have addressed or is it just that my brand new system is pooched from the beginning?)

 

- determine why there are now two HotSync managers being blocked.

 

- why do I have to enable "Run as Administrator" when I AM the Administrator  (I've checked that point even though I knew that I am).

 

.

Message Edited by Carl_L on 05-27-2009 09:31 AM
Message Edited by Carl_L on 05-27-2009 09:32 AM
Copper Super Contributor
Posts: 74
Country: Canada

Re: ACT!2008 - Sync to Tungsten E2 - can't do under Vista

Pretty sure that the problem is not with Vista or ACT or Companionlink, but with the stripped down "vista compatible" version of the Palm software.  AFAIK a subcontractor wrote this software for Palm and delivered the bare essentials per the terms of their contract.  I believe certain elements of the Palm hotsync manager that worked under previous operating systems do NOT work under Vista.  I doubt it will work with 3rd party conduits like Companionlink's - but I could be wrong.  I doubt if Palm will update this software further.

 

I have a Vista system at home.  I sync my T3 there via a VMware Windows XP image - I also have ACT 6 installed in that image.

Solution
Accepted by topic author Carl_L
‎09-25-2015 03:20 AM
New Member
Posts: 4
Country: Canada

Re: ACT!2008 - Sync to Tungsten E2 - can't do under Vista

[ Edited ]

I've solved the issue.

 

A local reseller had ACT!2009 on sale for half price so, out of frustration/desperation and a hunch, I bought and installed it.

 

It was a bit messy getting it installed.  I still had a version of ACT!2006 on the laptop that I had used to convert the ACT!2000 database. When I used the Unistaller that was in the ACT!@006 folder, it also too out the Start menu folder for ACT!2008.  ACT!2008 still ran but ACT!2009 would not install until I removed everything (slightly contrary to the online instructions).  I used the new ACT Uninstaller from the web site to clean up the system.  ACT!2009 then installed.

 

At this point I was able to sync contacts and calendars.  

 

I noticed something odd though.  Every "Don" in the database had "Don" not assigned to the First Name field - Donald's were OK.  There were also a handful of names (no more than 10) where there was only an initial for a first name, and the intial was always "M",  where these exhibited the same behavior as the "Don's".  I picked it up when the sync'd contacts count did not match from ACT to the Palm Desktop.  Noticed a few duplicate entries in Palm Desktop where both entries had no first name. Manually scanned through 12000+ records and assigned the Don's to first name.  After that the sync's were perfectly clean and consistent.

 

What is disturbing to me is that while I was trying to sort these issues out a week ago, I ran ACTDiag and found nothing in the ACT!2008 database.  With the few sync's that I was lucky to complete, I had no issues with duplicate record.  So it looks like in converting from ACT!2008 to ACT!2009, something went wrong.

 

I want to mention that CompanionLink tech support was very patient through this process.  Learned a few things from them that was beneficial to understanding the conduit process. Thank you Nathan V. and Rebecca S..

 

.

Message Edited by Carl_L on 06-11-2009 11:24 PM