Community
Showing results for 
Search instead for 
Do you mean 
Reply

Slow backup

Accepted Solution Solved
Copper Contributor
Posts: 13
Country: United Kingdom
Accepted Solution

Slow backup

Act 6.0.3

5,000 records

 

When backing up Act starts “searching” and seems to hang for about 5 minutes then carries on. A normal backup now takes about 10 mins.

 

The destination folder is held on the server.

 

Any ideas what might be slowing it down and what I can do to speed it up?

 

Thanks

 

Peter

Accepted Solutions
Solution
Accepted by topic author PeterFriswell
‎09-25-2015 03:20 AM
Copper Contributor
Posts: 13
Country: United Kingdom

Re: Slow backup

Hi Roy

 

The problem seemed to be because I had changed my own machine from a laptop that held the attachments on a C drive, to a desktop that was saving the attachments on a network drive. As you pointed out, on the backup Act was looking for the attachments in C whereas they were no longer there. I got the old attachments and moved them to a new local folder on C which hopefully will solve the problem.

 

Thanks again

 

Peter

 

View solution in original post


All Replies
Platinum Elite Contributor
Posts: 6,652
Country: USA

Re: Slow backup

That sounds like a system configuration problem with the backup going through several timeouts in a search path. Another possibility is the location of the temp files, I suspect they are at the location where the backup is being made to. Have you tried backing up to a local folder to see if you get the same results?
Roy Laudenslager
ACT! Certified Consultant
ACT! Report Expert
Durkin Impact Report Designer
www.techbenders.com
royel@techbenders.com
541-343-8129
Copper Contributor
Posts: 13
Country: United Kingdom

Re: Slow backup

Hi Roy

 

If I try to backup to a local folder I get the same result. It seems to go through all the files required for backup very quickly (probably about 10 to 15 sec) but then moves onto the “Storing” part and seems to hang with the word “Searching”

 

Can you explain what you mean by:

“Another possibility is the location of the temp files, I suspect they are at the location where the backup is being made to.”

 

All the backups are kept in a separate folder on the server that is reserved just for backups.

 

Cheers

 

Peter

Platinum Elite Contributor
Posts: 6,652
Country: USA

Re: Slow backup

From your description, I go back to the search timeout as the source of you problem. My guess if that you are including emails and documents in your backup. If so, because these are file links rather directly incorporated in your database I am assuming that some of the actual attached files were deleted without removing the attachment link in the ACT! database. This mean that every time it hits a link to a missing file, it does a search and eventually times out if it isn't found. Try doing a test backup excluding email and documents and see what happens.
Roy Laudenslager
ACT! Certified Consultant
ACT! Report Expert
Durkin Impact Report Designer
www.techbenders.com
royel@techbenders.com
541-343-8129
Copper Contributor
Posts: 13
Country: United Kingdom

Re: Slow backup

You were spot on with that one. Thanks very much. Once I excluded all the mail and docs it backed up the db in seconds.

 

Soooooo... the next question is; I use outlook for e-mail so how can I ensure that in the event of a catastrophe I can also access the e-mails that link to a contact's record?

 

Cheers

 

Peter

Platinum Elite Contributor
Posts: 6,652
Country: USA

Re: Slow backup

There isn't an easy answer. The problem you are seeing is caused by the target file of some of the attachments have either been moved or deleted so ACT! is trying to search for those files. If you could locate the specific history entries, you could remove the attachment link to solve the problem. Please send me a private message for some further information.
Roy Laudenslager
ACT! Certified Consultant
ACT! Report Expert
Durkin Impact Report Designer
www.techbenders.com
royel@techbenders.com
541-343-8129
Solution
Accepted by topic author PeterFriswell
‎09-25-2015 03:20 AM
Copper Contributor
Posts: 13
Country: United Kingdom

Re: Slow backup

Hi Roy

 

The problem seemed to be because I had changed my own machine from a laptop that held the attachments on a C drive, to a desktop that was saving the attachments on a network drive. As you pointed out, on the backup Act was looking for the attachments in C whereas they were no longer there. I got the old attachments and moved them to a new local folder on C which hopefully will solve the problem.

 

Thanks again

 

Peter

 

Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: Slow backup

If you need to, you can use Oak!Check! to verify the attachments and even change the location to the server if you want them there