Community
Showing results for 
Search instead for 
Do you mean 
Reply

Act 6.0 fields don't appear in layouts

New Member
Posts: 25
Country: United States

Act 6.0 fields don't appear in layouts

I use several different databases on a server, from several different computers.  When I add a field to a database, I can add it to a layout and have it appear, but when I open a different database, to which I've added the same field, that field won't show up in the layout; I have to "design the layout" again to make it appear. 

 

A (possibly related?) problem I've noticed is that a different field will sometimes appear at the spot where I added a field on the layout; the database seems to arbitrarily choose which fields to put where.  I'll add that most fields seem to stay where they're put; but I can't figure out how Act is choosing what to put where.

 

Can anyone throw some light on this?

 

Thank you,

Deborah

 

Platinum Elite Contributor
Posts: 6,652
Country: USA

Re: Act 6.0 fields don't appear in layouts

Yes but the explanation gets into how the ACT! 6 database works and is long. The reason with out explantion is that the database share the same layout but the field was added separately to the different databases.

Roy Laudenslager
ACT! Certified Consultant
ACT! Report Expert
Durkin Impact Report Designer
www.techbenders.com
royel@techbenders.com
541-343-8129
New Member
Posts: 25
Country: United States

Re: Act 6.0 fields don't appear in layouts

So there's nothing to be done save for what I'm currently doing - changing it each time we open a database?

Platinum Elite Contributor
Posts: 6,652
Country: USA

Re: Act 6.0 fields don't appear in layouts

You can save and make a separate layout for each database.

Roy Laudenslager
ACT! Certified Consultant
ACT! Report Expert
Durkin Impact Report Designer
www.techbenders.com
royel@techbenders.com
541-343-8129
New Member
Posts: 25
Country: United States

Re: Act 6.0 fields don't appear in layouts

What about making one template database with all fields in it, making an empty copy of it, and then importing each database into it, one at a time, and renaming them; they'd all be the same from the get-go and one layout might do?

Platinum Elite Contributor
Posts: 6,652
Country: USA

Re: Act 6.0 fields don't appear in layouts

That would work if the databases are single user. If multi user it's more complex.

Roy Laudenslager
ACT! Certified Consultant
ACT! Report Expert
Durkin Impact Report Designer
www.techbenders.com
royel@techbenders.com
541-343-8129
New Member
Posts: 25
Country: United States

Re: Act 6.0 fields don't appear in layouts

Never multi-user at the same time - one database open on one computer only.

Platinum Elite Contributor
Posts: 6,652
Country: USA

Re: Act 6.0 fields don't appear in layouts

re there more than one user's defined in the database?

Roy Laudenslager
ACT! Certified Consultant
ACT! Report Expert
Durkin Impact Report Designer
www.techbenders.com
royel@techbenders.com
541-343-8129
New Member
Posts: 25
Country: United States

Re: Act 6.0 fields don't appear in layouts

No, there's always only one My Record; only one defined user per database.