Community
Showing results for 
Search instead for 
Do you mean 
Reply

w3wp.exe using 99% CPU and 1gb of RAM

Copper Super Contributor
Posts: 102
Country: USA

w3wp.exe using 99% CPU and 1gb of RAM

[ Edited ]

Hello,

 

I have a customer which recently updated Act! from 21.0 to 21.1 U3.  They are running Act! self-hosted on premise, APFW, and act web API.  The update fixed Act Companion.

 

However there is a process running called w3wp.exe - IIS Worker Process - eating all of the system resources, CPU at 99% and memory over 1GB.  It got so bad that other users time out when logging into Act.  Restarting IIS temporarily resolves the problem for a couple hours until the CPU usage climbs back to maximum.

 

APFW & related processes are the only items being hosted on IIS, under the default web site.  They do not have any sync users with an RDB and do not have Act Internet Sync installed.

 

Specifically, the only running applications in IIS are:

  • act.web.api
  • APFWValidationSync
  • APFW
  • APFWMailMergeSrvc
  • APFWOutlookSrvc
  • (aspnet_client directory)

 

It appears that there was previously a KB article addressing this topic which has been removed: https://help.act.com/hc/en-us/articles/360024414153-W3WP-exe-Process-Consuming-System-Resources

 

SYSTEM DETAILS:

Act! Premium (Web) Version 21.1.187.0, Update 3

Microsoft Windows Server 2008 R2 Foundation Version 6.1.7601 Service Pack 1 Build 7601

Installed Physical Memory (RAM) 8.00 GB

Processor Intel(R) Xeon(R) CPU E3-1220 V2 @ 3.10GHz, 3101 Mhz, 4 Core(s), 4 Logical Processor(s)

Twelve/Three Marketing, Inc.
Act! Certified Consultants
......Stephen Boulden
Twelve/Three Marketing, Inc.
P: 716.837.5727 x104
E: stephen@twelvethree.com
Highlighted
Copper Super Contributor
Posts: 102
Country: USA

Re: w3wp.exe using 99% CPU and 1gb of RAM

Problem still happening.  Disappears every time I restart IIS, but slowly creeps back up.  Got another phone call today that this is running at full capacity.  Any ideas?

 

Can anyone from Swiftpage help me discover what the KB article formerly located here used to say about this:  

https://help.act.com/hc/en-us/articles/360024414153-W3WP-exe-Process-Consuming-System-Resources

Twelve/Three Marketing, Inc.
Act! Certified Consultants
......Stephen Boulden
Twelve/Three Marketing, Inc.
P: 716.837.5727 x104
E: stephen@twelvethree.com
Silver Contributor
Posts: 1,779
Country: United_Kingdom

Re: w3wp.exe using 99% CPU and 1gb of RAM

 

From an IIS site I repeat their suggestions -

 

  1. Just click on your server in the left pane of IIS.
  2. Click on 'Worker Processes' in the main pane. you already see what application pool is taking too much CPU.
  3. Double click on this line (eventually refresh by clicking 'Show All') to see what pages consume too much CPU time ('Time elapsed' column) in this pool
  4. If you identify a page that takes time to load, use SharePoint's Developer Dashboard to see which component takes time.
Copper Elite Contributor
Posts: 131
Country: United_Kingdom

Re: w3wp.exe using 99% CPU and 1gb of RAM

Steve, did you get to the bottom of this (we have a client experiencing exactly the same issue) ?

Will Ingleby
ACT! Certified Product Specialist

Solutions for Accounting & CRM (UK)

Bronze Contributor
Posts: 1,331
Country: USA

Re: w3wp.exe using 99% CPU and 1gb of RAM

I heard Update 4 was going to fix this. Time will tell.

Patricia Egen
Certified ACT! Consultant, Trainer, Developer
www.egenconsulting.com
(423) 875-2652

Follow us on:


Visit our Popular ACT Wizards Page Wizards Here!

Copper Super Contributor
Posts: 102
Country: USA

Re: w3wp.exe using 99% CPU and 1gb of RAM

No, I wish I had a fix. I set up a task in the windows task scheduler to run IISReset.exe every 8 hours.
It's a stupid workaround for now but I've just got to wait for Update 4, I suppose.
Twelve/Three Marketing, Inc.
Act! Certified Consultants
......Stephen Boulden
Twelve/Three Marketing, Inc.
P: 716.837.5727 x104
E: stephen@twelvethree.com
Copper Super Contributor
Posts: 45
Country: Germany

Re: w3wp.exe using 99% CPU and 1gb of RAM

Hi Steve,

 

we also have this problem on one of our web servers with Act Web Api version 1.0.449.0

 

It happens after a reboot of the server. The w3wp.exe process automatically starts and uses 99% of all CPUs.

 

You can kill the process without reseting the whole IIS with the command:

 

WMIC PROCESS WHERE "Name='w3wp.exe' And CommandLine Like '%act.web.api%'" Call Terminate

 

 

After a while the process starts again without 99% CPU usage.

 

Yesterday I accidentally discovered that there is again a new version of the web.api 1.0.460.0. Likely this is better than the 1.0.449.0.
 
 
Best regards
Robert

 

Melville-Schellmann
Consulting and Development for CRM-Software