Community
Showing results for 
Search instead for 
Do you mean 
Reply

v18 for web bugs

Copper Contributor
Posts: 18
Country: USA

v18 for web bugs

This is sort of an FYI to swiftpage and the community.

 

We have found several bugs in v17, most of which were not fixed in v17. Support advised up to try v18.

 

I setup a brand new server08r2, installed a clean copy of v18, then proceeded to test 1) known v17 bugs and 2) poke around a little.

 

v18 confirmed bugs:

 

1. For the first time ever, an upgrade will wipe out your custom layouts. We've had a custom layout for 10 years through 3 versions. Now it's gone and w/ have to be remade by hand.

 

2. Cannot run/cancel an advanced query in chrome/ff. I *did* try and load the patch for this from MS, but apparently a fully patched server does not need and will not load this patch.

 

3. Email setup only works properly in IE. Chrome/FF have to save, exit, re-enter the email area a total of 3 times in order to create the account, make it active, and setup a signature.

 

4. Email signatures setup WHEN CREATING an email account ignore carriage returns. Signatures made AFTER the account is active do not suffer this problem. This may be a chrome/ff only bug.

 

5. When using act email: clicking on an email address in contact view activates act email. Clicking on the SAME address in LIST view opens whatever your default desktop email is.

 

6. DB login is MUCH, MUCH slower than v17.

 

7. List view, click a contact, schedule an appt in the future 1-2 days, return to list view, click a DIFFERENT contact, click their email address. Email composition is started, but with the 1st contact as the recipient as well as pre-populating the body with contact #1's meeting details.

 

8. Email setup via chrome does not appear when using ff/ie. However, email setup via ie DOES appear when using ff.

 

 

Several of these bugs were confirmed (with case #s) in v17. We are very unhappy that they have not been fixed (reported ~4 months ago).

 

Furthermore, it calls into question just what the heck is going on there if these things are not fixed in v18 either.

 

Some of what I found was uncovered in 15 mins of playing around. What, it any, beta testing goes on there?

 

These bugs are confirmed also on act's own demo site for v18.

 

 

 

 

 

 

 

 

Avid Listener
Posts: 52
Country: United States

Re: v18 for web bugs

We were experiencing the SLOW login in v17.  Anywhere from 30-90 seconds to login to APFW. We were really hoping v18 would help, but it is slower.

 

We now are evaluating all options, back to sync, VPN or another product.

Copper Contributor
Posts: 18
Country: USA

Re: v18 for web bugs

 

We are running xeon server with ssd raid with tons of ram and it still doesn't help on speed but just a tiny bit.

 

If you notice, there's an anti-copying process that runs (and takes forever) each time someone logs it. watch your processes...

 

 

 

Avid Listener
Posts: 52
Country: United States

Re: v18 for web bugs

We have plenty of horse power on the server and the 2 web servers. It is the Protexis license service that kills it. We can watch the process stall out waiting for confirmation we have a license. I was told by ACT support this would be addressed in v18...

Copper Contributor
Posts: 18
Country: USA

Re: v18 for web bugs

 

Good luck with the 'told it would be fixed' thing. Several of the bugs i listed were known and promised a fix.

 

It got so bad 2 years ago, I sat down and hand wrote a snail-mail letter to the CEO and COO, then sat back and waited...

Few weeks later, someone that was HIGHLY motivated to fix my problem called me.

 

Looks like it's time to do that again.

 

 

 

 

Employee
Posts: 434
Country: USA

Re: v18 for web bugs

Hi Jeff,

 

I'd first like to say I appreciate the work that went into your post. I've forwarded this list to the team and we'll start our research on these issues as soon as we can. I hope to provide you tracking numbers and, working with Andrew, the disposition of each item you've reported. 

 

Bob

Bob Breeding
Copper Contributor
Posts: 18
Country: USA

Re: v18 for web bugs

 

Thanks for chiming in.

 

I've worked mostly with Billy Clark lately. He was tracking some of these issues. I have sent him some videos that show how to recreate these errors.

 

Send me an email or something and I w/ send you some screenshots/etc.

 

Jeff

 

 

 

Avid Listener
Posts: 52
Country: United States

Re: v18 for web bugs

I know I am not the original poster of this tread. But I would like to hear any updates on the issues raised by Jeff, especially relating to the SLOW login.

Bronze Elite Contributor
Posts: 1,426
Country: United_Kingdom

Re: v18 for web bugs

This is an  old fix for slow log-ons but just in case you have not tried it always change your opening screen away from the welcome screen to Contact or Company layout.

Avid Listener
Posts: 52
Country: United States

Re: v18 for web bugs

Thanks for the suggestion. Unfortunately it didn't work.