Community
Showing results for 
Search instead for 
Do you mean 
Reply

path to layouts changed

Accepted Solution Solved
New Member
Posts: 5
Country: United States
Accepted Solution

path to layouts changed

We have ACT! Premium for Workgroups with 12 users. The database is located on a server and users access it through the network. We have 3 custom layouts that also reside on the server.

 

The problem is somehow the path to our custom layouts got changed from the server to a user's computer (who happens to be our ACT! admin). So that now whenever someone opens up ACT! their layouts folder points to this person's computer. I can't figure out how to change this layout path so that it permanently points back to the layout folder on the server.

 

In general we've had problems with custom settings not showing up reliably for certain users. For example, for a couple users the default word processor keeps changing back from Microsoft Word to the ACT! processor. Not sure if problem is related.

 

Any help would be appreciated.


Accepted Solutions
Solution
Accepted by topic author cbrehm
‎09-25-2015 03:20 AM
Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: path to layouts changed


All Replies
Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: path to layouts changed

The layouts should be read from a folder under the database. There is no setting to change this.

 

Are you sure they aren't accidently opening a local copy of the database?

Or just opening the default layout in the database supplemental file, which they might if losing their settings?

 

If not, what exact version of ACT! (the full build from Help | About)?

New Member
Posts: 5
Country: United States

Re: path to layouts changed

ACT! 2008 Premium for Workgroups ST Edition version 10.0.1.199

 

On the server, under preferences, the path to the main database is \\servername\ACTData\Database. The correct layouts are in a subfolder of Database: \\servername\ACTData\Database\Company_Name__Master-database files\Layouts. However, even from ACT! on the server, ACT! points for its layouts to \\usercomputer\Company_name_master-database files\Layouts, where "usercomputer" is an ACT! user's personal workstation. Only this folder (Company_Name_Master-Database Files) is on the user's workstation. The databases are only on the server. So, ACT! points to the server for its databases and to a user workstation for its Layouts folder. This follows for every ACT! user on our network, all 12 of them. Weird.

New Member
Posts: 5
Country: United States

Re: path to layouts changed

I should add that the user (who owns the admin account) thinks he may have caused this shift by clicking on Share Database when he meant to click on Lock/Unlock Database in the database maintenance utilities. Could that have caused this?
Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: path to layouts changed

Where do you see this location?

 

What is in - Help | about | Database Information | Supplemental files Location?

 

You might try updating to ACT! 10.03 (you'd need to do this on all systems)... which I haven't heard this issue, I does fix a lot of this.

Solution
Accepted by topic author cbrehm
‎09-25-2015 03:20 AM
Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: path to layouts changed

If the database is not shared, you'd get various errors when connecting... but worth checking
New Member
Posts: 5
Country: United States

Re: path to layouts changed

GLComputing,

 

I just checked the supplemental file location  and you are right, the path is incorrect.

 

it points to: \\userscomputername\Company_Name_Master-database Files. The question is how to change this so it points back to \\servname\ACTData\Database\Company_name_master-database Files.

 

What if I unshared the database from the database maintenance utilities on the server and then shared it again. You think that might reset the layout path back to the server?

New Member
Posts: 5
Country: United States

Re: path to layouts changed

Yep, that worked--unsharing the database for the admin user's computer and then resharing it from the server.

 

Thanks, GL, for pointing me in the right direction.