Community
Showing results for 
Search instead for 
Do you mean 
Reply

nothing is imported when I try to import Excel / CSV / TXT file...

New Member
Posts: 30
Country: Belgium

nothing is imported when I try to import Excel / CSV / TXT file...

[ Edited ]

Hello !

 

I've a Excel 2010 file which contains 563 lines with company names and informations. The first line of this file contains the titles of the columns : Name, Address, Email, and so on. Lines 2 - 563 contains companies datas.

I would like to import all of them into Sage Act 2012 Premium but it does not work.

 

First, I tried to use the "Import Wizard" to import my XLSX file. When reading the file, Sage does not seems to recognize the different fields : when the screen "Company Map" appears, Sage detects an unique field (althoug my Excel file contains 6 columns) and Sage wants to map this "unique" column into a unique field.

 

After, I tried to export my Excel file to CSV / TXT file. Thus I have a TXT file which contains one line by company, and for each company, the different informations are separated by TAB.

In the Import Wizard, Sage detects correctly the different fields of my file and I can make a correct mapping. At the end of the wizard, Sage tells me that : "All fields are compatible. The import may continue." and after importing, I can see in the Import Log : "Sage ACT! did not encounter any errors merging records.". But nothing is imported in my database. No company is created : Sage seems to read my file correctly but does not add anything in my database.

 

What am I doing wrong ??

 

Please, could someone tell me a detailed howto to import datas from Excel 2010 to Sage Act! 2012 Premium  ??

 

Many thanks in advance for your help !

 

And... Best wishes for 2012 ! :-)

 

Trucmuche

 

ps. I tried to import in a new database but the problem is the same.

I tried to disable the duplicate checking, but the problem is the same...

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: nothing is imported when I try to import Excel / CSV / TXT file...

[ Edited ]

Hello Trucmuche,
Some things to check:
- Make sure the column name that contains name of the company is labeled "Company" to match the field name in ACT!
- Make sure the column for the company name has no empty cells
- When running the import, click the Company button on the "Specify Merge Options" screen (8 of 10), and make sure that the option on the right-hand side says "Add" and the option on the left says "Merge".

 

Before importing, I would also advise running maintenance on your database (Tools > Database Maintenance > Check and Repair).

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

New Member
Posts: 30
Country: Belgium

Re: nothing is imported when I try to import Excel / CSV / TXT file...

[ Edited ]

Hello Greig !

 

Many thanks for your answer... but this doesn't really help... Sage is wrong when it reads an Excel file, even if this excel file comes from Sage... Let met detail the procedure I followed to make a try :

  • I go to my company list in Sage. I click on the list with right mouse button and I select "Export to Excel". Everything works fine : the list is exported in excel. In Excel, I see the field names in the first line : "Nom" in A1, "Type" in B1, "Addresse 1" in C1, "Code postal" in D1, ...
  • I add a line at the end of this file, with a new company name and "TESTS" words on the other columns. I save the file as "IMPORT_TEST.XLSX". I close Excel.
  • In Sage Act!, I go to File > Import, select Excel in the list and browse to "IMPORT_TEST.XLSX". I click "Next".
  • Import Wizard (step 2 of 9) : Sage selects "Contacts records" but since this is a company list, I select "company records".
  • Import Wizard (step 3 of 9) : I select "custom import".
  • Import Wizard (step 4 of 9) : I check or uncheck "Yes, import the first record". That doesn't matter...
  • Import Wizard (step 5 of 9) : in the "Map from this field" column, I see only one line with : "Nom;Type;Addresse 1;Code postal;..."

Sage doesn't understand the structure of the file it has written itselfs. Why ??

 

I'm using Sage ACT! Premium 2012 Version 14.0.572.0 and Excel 2010, Windows 7 64 bits.

 

Thank you very much for your help !

 

Trucmuche

 

ps. Oh... Before doing these operations, I checked all the things you mentioned, of course... :-)

New Member
Posts: 22
Country: USA

Re: nothing is imported when I try to import Excel / CSV / TXT file...

Mr. Greig, none of the steps you said solved the same issue we have in ACT 2012. we have tried csv, txt xls xlsx and we are using a cleaned up and short excel file, the duplicate settings are correct as well and no error from act other than finished successfully!!!  The importing contacts step of the process nver begins, it juts gets stuck for a few seconds and say completed.

Copper Contributor
Posts: 22
Country: USA

Re: nothing is imported when I try to import Excel / CSV / TXT file...

When you get to the Specify Merge options page of the import wizard, click on contact.

 

You will have 3 options if there is a match.

 

Merge will try to append the data to the end of the field but doesn't work for all fields.

 

Replace will insert your new data from data file you are importing.

 

Do not change will skip the update.

 

 

Hope that helps.