Community
Showing results for 
Search instead for 
Do you mean 
Reply

could not allocate space for object error when user logs in

New Member
Posts: 2
Country: United_Kingdom

could not allocate space for object error when user logs in

Hello,

 

when our users try to login to Act the get the following error:

 

Could not allocate space for object 'dbo.CTL_SYNCROW_ADD'.'CTL_SYNCROW_ADD_IE1' in database 'ourdatabasename' becuase the 'PRIMARY' file group is full. Create disk space by deleting unneeded files, dropping obects in the filegroup, adding additional files to the filegroup, or setting autogrowth on for exisiting files in the file group.

 

space is not an issue on the server (160GB+ free)

 

I have googled extensively but cannot find any references to this error in ACT (lots of references to SQL but nothing helpful)

 

Any help is much appreciated.

 

Thanks

 

Platinum Super Contributor
Posts: 5,275
Country: USA

Re: could not allocate space for object error when user logs in

Hello Act_User_0,

Welcome to the Act! Online Community!

 

- How large are the ADF and ALF files that are associated with your database?

- What version of SQL are you running (SQL Server 2005 Express or Standard)?

 

If you are able to open the database, try running the Tools > Database Maintenance > Check and Repair function (this also contains a step to re-index the database).

 

If you cannot open the database, you can run maintenance on the database through the 'Actdiag' utility.  To do this, on the server:

- close Act!

- click on Windows Start button > select 'Run' (on XP) or use 'Search' field (Vista/Win7) > enter 'actdiag' > hit enter

- on the actdiag screen > select Databases in left column > select Database List

- on database list > left click on gray box to left of your database, to highlight the line

- right click on database name and select options for > Check > Repair > Reindex.  You will have to wait for each one to run before starting the next.

 

And to double check the installation of Act! and SQL > open the Act Demo database (or create a new database) and see if the same error is issued.

 

Greg Martin
Sage
New Member
Posts: 2
Country: United_Kingdom

Re: could not allocate space for object error when user logs in

Hi Greg,

 

thanks for you reply,

 

The ADF is 4.1GB and the ALF is 1mb

 

we are running SQL 2005  standard (another app is also on this) however i m unable to connect to the ACT7 instance using SQL server management studio.

 

we also get the error below in the event logs:

 

CREATE DATABASE or ALTER DATABASE failed because the resulting cumulative database size would exceed your licensed limit of 4096 MB per database.

 

researching this error however seems to suggest that ACT is running off SQL express rather than the standard installation (4GB is a limitation of SQL express?).

 

I ran Check and repair but running reindex generates the following error:

 

could not allocate a new page for the database 'ourdatabase' because of insufficient disk space in filegroup 'PRIMARY'. Create teh neccesary disk space by dropping opbjects in the filegroup, adding additional files to the filegroup, or setting autogrowth on for existing files in the filegroup. The statement terminated

 

 

We dont get the same error on the Demo database

 

by the looks of things it might be running on SQL express and we need to migrate it to the SQL standard server?

 

thanks again for your help

 

Tom

Platinum Super Contributor
Posts: 5,275
Country: USA

Re: could not allocate space for object error when user logs in

Definitely looks like Act! is running off of SQL Express - yes, Express has a 4gb limit.

 

To help get through the immediate issue, you can try using the Tools > Database Maintenance > Remove Old Data option to free up some space.  I recommend that you create a backup of your database first (File > Backup > Database).  If the backup fails because of the db size, you can stop the SQL (Act7) service and then manually copy the db files to another location.  Then restart the SQL (Act7) service.  You will need to have your users out of the database to do this backup.

 

The Remove Old Data option can remove 'cleared activities', notes, histories, and documents - based on an older than 'x' days.  Cleared Activities can be a good one to choose because: although the activity is cleared and it creates a History item for the activity - the cleared activity will actually remain on the calendar.  Basically a duplication of information. If you use this option, I recommend starting with a large 'X' date (ex: 1500 days - for 4 years and older) and rerunning the step decreasing the number - because of the amount of data that can be affected.

 

Note: removing Documents won't affect the size of the database - they are not part of the ADF file.

 

Do you have any remote databases syncing with your main db?  If you do, you may have a remote or 2 that are no longer in use but are still listed as active on Tools > Synchronization Panel > Manage Database panel.  If you do, you can disable it/them and then delete it.  This will free up room because Act! continues tracking changes for any remote in an active status.

 

After doing any clean up of the data - retry the reindex.

 

To get Act! using the SQL Standard installation, you will need to uninstall Act! and remove the Act7 instance from SQL Express.  You can then manually create the Act7 instance within the SQL Standard installation and the reinstallation of Act! will recognize the manually created instance.  For instructions on manually creating the Act7 instance review this article:

KB Article 19231

 

 

 

Greg Martin
Sage
New Member
Posts: 4
Country: Hong_Kong

Re: could not allocate space for object error when user logs in

Greg, need your help or whoever see this...

 

I have the same problem with my client's DB.  It got up to 10Gb+.  I removed old data and cleaned up a lot, but the adf still the same size.  I believe I must reindex to shrink the database but it failed no matter how I do it in ACT or ACTdiag.  Try everything like detach, open with adf, save copy as, check and repair, etc.....none can reduce the database size....

 

I believe if I can reindex and clean up more the problem can resolve.  Anyone can help here ?

Bronze Super Contributor
Posts: 1,679
Country: Australia

Re: could not allocate space for object error when user logs in

Might be better to start your own thread Smiley Happy

That said, if your .ADF is just over the 10GB mark, I'd suspect that you are using SQL Server 2008 R2 Express for the ACT7 SQL instance, you'll likely need to upgrade to SQL Server 2008 R2 Standard.

I don't know, but perhaps ActDiag has a problem doing the reindex etc if the .ADF is 10+ GB, you might need to move it to a machine with SQL Std, do it there, then move it back?