Community
Showing results for 
Search instead for 
Do you mean 
Reply

Zapier Authorization Error

MJ
New Member
Posts: 1
Country: Canada

Zapier Authorization Error


- Version of Act! Act! Premium (Web) Version: 18.1.108.0

- Is your database on your local machine (private database) or is it being shared from a server (shared database)?  I don't know - my guess is server?

- Operating system you have Act! installed on (i.e., Windows 7, Windows 8) Windows 10

 

- As much detail regarding the question or issue as you can provide. This includes any error messages and the actions you took that lead to the error

 

We are trying to integrate ACT Premium with Zapier, on this pag zapier.com/app/editor/10505772/nodes/10505772/auth

 

When it comes to connecting them, there is this information to enter, and I get this error

 

Error:


We hit an error adding your new account

authorization failed: Javascript Exception: `2016-07-04T19:04:53.817Z 1eff75c9-421a-11e6-9f25-6759b34faf1e Task timed out after 30.00 seconds`.

What To Do Next

Make sure you click "Allow" or "Accept" on the permission popup  - I did not receive a pop up, and pop ups are allowed on the website
Double check your Account has the correct permissions - I have administrator permissions
Check out our help docs for more information - no help docs were specific and no help posts were the same.

 

 

 

Info required:

 

 

 

 

Allow Zapier access to your Act! Premium account?

Username (required)

The Act! user name you use to log into Act! for Web.

 
 
 
 
 
Password (required)

The password you use to log into Act! for Web. NOTE: you must set up Act! with non-blank password.

 
Database Name (required)

The case-sensitive name of the Act! database you can log into Act! for Web.

 
 
 
 
 
 
 
URL (required)

What is the .com url address where you access Act! Premium for web. We'll take care of the rest.

https://
 
 
 
 
 
Administrator
Posts: 4,024
Country: United_Kingdom

Re: Zapier Authorization Error

[ Edited ]

Hi MJ,

Just to double check, are you using your own hosted Act! Premium installation, or are you an Act! Premium Cloud customer?

This might be hard to troubleshoot over the community as we'd need some more of your individual database details to look into this further. I'd suggest giving us a call on 866 873 2006 and speaking with one of our technicians to help you out with this.

Bronze Contributor
Posts: 1,276
Country: USA

Re: Zapier Authorization Error

I know this is an older post, but I got this same error and when I changed the Act URL to act.web.api instead of apfw, it worked.  As an example, say the domain is act.somecompanyname.com  the url would be act.somecompanyname.com/act.web.api

 

Hope that helps someone who also gets this error

Patricia Egen
Certified ACT! Consultant, Trainer, Developer
www.egenconsulting.com
(423) 875-2652

Follow us on:


Visit our Popular ACT Wizards Page Wizards Here!

Copper Contributor
Posts: 44
Country: USA

Re: Zapier Authorization Error

hi poatricia, I want to set this up as well ,but I get same error,,, however I am not on  cloud at all i do have premium for web v19 installed ,  but i only use locally via  my local router,, local host?? 

do I have to have an account on a server hosting my data to use the zapier integration??? the  would be disappointing? :/

Moderator
Posts: 451
Country: United_Kingdom

Re: Zapier Authorization Error

[ Edited ]

Hi Aritos,

 

I have included an article below which goes into more detail on setting up the Act! Premium Web API.

 

38270 How do I set up the Act! Premium Web API?

Please ensure the database is accessible via a web browser on localhost and a SSL configuration has been setup.

 

We also have the Act! Connect link which maybe easier to use and set up, please follow this link for further information: https://www.act.com/products/act-connect-link