Community
Showing results for 
Search instead for 
Do you mean 
Reply

Web Site Administration, Add/Remove Database Fix

Accepted Solution Solved
Copper Contributor
Posts: 16
Country: USA
Accepted Solution

Web Site Administration, Add/Remove Database Fix

Hi,


I got ACT Premium in a server & SQL (Internal Network), and sharing the ACT Pad file to ACT Premium for Web in the IIS Server (DMZ network).

 

Firewall has been disabled. Running ACT V16, Windows Server 2008R2 64bit.

 

I can open the PAD file from ACT For Web but the problem is that I can't Add the database to use the Web component APFW.

 

In Web Site Administration, in the Add/Remove Database, databases. When I press the Test DB, I get the following error.

 

"Could not authenticate user. Verify the user name and password, and try again"

 

Its Only that part, the rest of the Web Site Administration tests Pass.

 

I added the Windows user account for ASP.Net impersonation per the ACT Premium Administrators Guide. Am I missing a step?

 

Any fix?

Thanks,

Rafael


Accepted Solutions
Solution
Accepted by topic author rafaelmagic
‎09-25-2015 03:20 AM
Copper Contributor
Posts: 16
Country: USA

Re: Web Site Administration, Add/Remove Database Fix

Fixed It. Have No idea how.

 

Just make sure when you SHARE the database and you get the dialogue to open the PAD location that you are able to open the location. If your blocked, its most likely an issue with Network Discovery settings, so follow the Microsoft suggestions. 

 

In my case (Windows Server 2008R2) I had to enable several services, automatic them and start. 

In order to enable the Network Discovery settings, you may make sure the following services are enabled and running.

 

To resolve the issue, follow these steps:

  1. Make sure that the following dependency services are started (Services):
    • DNS Client
    • Function Discovery Resource Publication
    • SSDP Discovery
    • UPnP Device Host
  2. Configure the Windows firewall to allow Network Discovery. To do this, follow these steps:
    1. Open Control Panel, click System and Security, and then click Windows Firewall.
    2. In the left pane, click Allow an app or feature through Windows Firewall if you are running Windows Server 2012. Or, click Allow a program or feature through Windows Firewall if you are running Windows Server 2008 or Windows Server 2008 R2.
    3. Click Change settings. If you are prompted for an administrator password or confirmation, type the password or provide confirmation.
    4. Select Network discovery, and then click OK.
  3. Configure other firewalls in the network to allow Network Discovery.
  4. Turn on Network Discovery in Network and Sharing Center.

 

Go to the Home Section and Turn On the sections you want. Also Turn OFF Password Protected Sharing. Then restart the computer. 

 

I also added the Users (impersonation Accounts) again to the IIS Server and the Other servers. Restart the computer.

 

Then created a New Database, shared it and it should work. 

View solution in original post


All Replies
Nickel Contributor
Posts: 249
Country: United_Kingdom

Re: Web Site Administration, Add/Remove Database Fix

In the add and remove database you need to add an ACT! user credentials that are an Administrator of the database.

Copper Contributor
Posts: 16
Country: USA

Re: Web Site Administration, Add/Remove Database Fix

Hi,
Thanks for the suggestion. In order to Test as described above you have to enter the credentials.
Copper Contributor
Posts: 16
Country: USA

Re: Web Site Administration, Add/Remove Database Fix

Been messing with the system. Now I see this error:

 

"The impersonation user account does not have acces to the database you selected. See ACT! Premium Administrators Guide..."

 

Which brings me to this Knowledgebase:

 

http://kb.swiftpage.com/app/answers/detail/a_id/16516

 

  • Be a standard domain user.
  • Be a local Windows Administrator to the Web server.
  • Have permission to access the database supplemental files for your ACT! database on the database server.
  • Have permission to access all ACT! Premium for Web files on the Web server.

 

Im lost, I modified and added Impersonation. Even modified PAD file with IP and Sql Security number. Anyone??

Solution
Accepted by topic author rafaelmagic
‎09-25-2015 03:20 AM
Copper Contributor
Posts: 16
Country: USA

Re: Web Site Administration, Add/Remove Database Fix

Fixed It. Have No idea how.

 

Just make sure when you SHARE the database and you get the dialogue to open the PAD location that you are able to open the location. If your blocked, its most likely an issue with Network Discovery settings, so follow the Microsoft suggestions. 

 

In my case (Windows Server 2008R2) I had to enable several services, automatic them and start. 

In order to enable the Network Discovery settings, you may make sure the following services are enabled and running.

 

To resolve the issue, follow these steps:

  1. Make sure that the following dependency services are started (Services):
    • DNS Client
    • Function Discovery Resource Publication
    • SSDP Discovery
    • UPnP Device Host
  2. Configure the Windows firewall to allow Network Discovery. To do this, follow these steps:
    1. Open Control Panel, click System and Security, and then click Windows Firewall.
    2. In the left pane, click Allow an app or feature through Windows Firewall if you are running Windows Server 2012. Or, click Allow a program or feature through Windows Firewall if you are running Windows Server 2008 or Windows Server 2008 R2.
    3. Click Change settings. If you are prompted for an administrator password or confirmation, type the password or provide confirmation.
    4. Select Network discovery, and then click OK.
  3. Configure other firewalls in the network to allow Network Discovery.
  4. Turn on Network Discovery in Network and Sharing Center.

 

Go to the Home Section and Turn On the sections you want. Also Turn OFF Password Protected Sharing. Then restart the computer. 

 

I also added the Users (impersonation Accounts) again to the IIS Server and the Other servers. Restart the computer.

 

Then created a New Database, shared it and it should work. 

New Member
Posts: 4
Country: USA

Re: Web Site Administration, Add/Remove Database Fix

I'm new to Sage Act Web Premium. I cannot find the PAD file where the database file is stored.

 

Do I *have* to share the database? I set the database up in a folder at the root of the C drive and gave all users read/write permissions to the folder and everything in it. Do I *still* have to set up impersonation?? Unsure why that is necessary. I am logged in with a Domain Admin at present because I just want to get this up and rtunning with a minimal of issues.

 

I have read up on setting up an impersonation account. None of it makes the least little bit of sense to me. Is this an Active Directory function, or is it something that only pertains to IIS? Is editing a configuration file the only way to do this?

 

One last thing, there IS no IIS web site for Sage Act. One was not created when I did the install. I just expected that the install would simple create a web site I could then log into with the default credentials.

 

Thanks for any help you can give.