Community
Showing results for 
Search instead for 
Do you mean 
Reply

Web Access Not Working Properly

New Member
Posts: 5
Country: USA

Web Access Not Working Properly

Our Web Access has stopped working.  When I try to log in it asks for my user name and password, when I input that it says that an error has occurred and has been logged on the server.  this is the error message from the server:

 

Log Name: Application
Source: AFW
Date: 2/6/2012 10:13:26 AM
Event ID: 0
Task Category: (98)
Level: Error
Keywords: Classic
User: N/A
Computer: server.fitness.local
Description:

SOURCE: Act.Framework
MESSAGE: Invalid recurrence pattern. Retrieval of named days expects day type of Named. Actual value was None.
FORM:
QUERYSTRING:
TARGETSITE: Act.Framework.Activities.ActivityRecurNamedDay[] GetNamedDays()
STACKTRACE: at Act.Framework.Activities.ActivityRecurSpec.GetNamedDays()
at Act.Framework.Activities.ActivityRecurUtility.DOWOccurs(ActivityRecurSpec recSpec)
at Act.Framework.Activities.ActivityRecurUtility.WeeklyOccurrences(ActivityRecurSpec recurSpec, DateTime activityStartTime, DateTime startRange, DateTime endRange)
at Act.Framework.Activities.ActivityRecurUtility.GetActivityOccurrenceDates(ActivityRecurSpec recurSpec, DateTime activityStartTime, DateTime activityEndTime, DateTime startRange, DateTime endRange)
at Act.Framework.Activities.ActivityManagerDB.GenerateActivitiesFromBaseData(ActivityBaseData[] baseDataItems, DateTime startRange, DateTime endRange, Boolean onlyFirstUnclearedInRange, Boolean onlyFirstInstance)
at Act.Framework.Activities.ActivityManager.GetActivities(IActivityFilterCriteria[] filterCriteria, IActivityFilterCriteria[] userFilterCriteria, ActivityAccessor[] accessors, Contact contact, Boolean includeEvents, Boolean firstUnclearedOnly, Boolean firstInstanceOnly, RetrievalMode retrievalMode, DateTime startRange, DateTime endRange)
at Act.Framework.Activities.ActivityManager.GetActivityList(ActivitySortCriteria sort, IActivityFilterCriteria[] filterCriteria, ActivityAccessor[] accessors, Contact contact, Boolean includeEvents, Boolean firstUnclearedOnly, RetrievalMode retrievalMode, DateTime startRange, DateTime endRange)
at Act.Framework.Activities.ActivityManager.GetAlarmedActivities()
at Act.Web.Framework.AlarmManager.RefreshAllAlarmedActivities()
at Act.Web.Framework.AlarmManager.GetOverdueAlarms(Boolean forceRefresh)
at Act.Web.Framework.AlarmManager.get_OverdueAlarmsExist()
at Act.Web.Global.CheckForDueAlarms()
at Act.Web.Global.Global_AcquireRequestState(Object sender, EventArgs e)
at System.Web.HttpApplication.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)
REFERER: http://192.168.2.5/apfw/default.aspx
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="AFW" />
<EventID Qualifiers="0">0</EventID>
<Level>2</Level>
<Task>98</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2012-02-06T18:13:26.000000000Z" />
<EventRecordID>15092</EventRecordID>
<Channel>Application</Channel>
<Computer>server.fitness.local</Computer>
<Security />
</System>
<EventData>
<Data>
SOURCE: Act.Framework
MESSAGE: Invalid recurrence pattern. Retrieval of named days expects day type of Named. Actual value was None.
FORM:
QUERYSTRING:
TARGETSITE: Act.Framework.Activities.ActivityRecurNamedDay[] GetNamedDays()
STACKTRACE: at Act.Framework.Activities.ActivityRecurSpec.GetNamedDays()
at Act.Framework.Activities.ActivityRecurUtility.DOWOccurs(ActivityRecurSpec recSpec)
at Act.Framework.Activities.ActivityRecurUtility.WeeklyOccurrences(ActivityRecurSpec recurSpec, DateTime activityStartTime, DateTime startRange, DateTime endRange)
at Act.Framework.Activities.ActivityRecurUtility.GetActivityOccurrenceDates(ActivityRecurSpec recurSpec, DateTime activityStartTime, DateTime activityEndTime, DateTime startRange, DateTime endRange)
at Act.Framework.Activities.ActivityManagerDB.GenerateActivitiesFromBaseData(ActivityBaseData[] baseDataItems, DateTime startRange, DateTime endRange, Boolean onlyFirstUnclearedInRange, Boolean onlyFirstInstance)
at Act.Framework.Activities.ActivityManager.GetActivities(IActivityFilterCriteria[] filterCriteria, IActivityFilterCriteria[] userFilterCriteria, ActivityAccessor[] accessors, Contact contact, Boolean includeEvents, Boolean firstUnclearedOnly, Boolean firstInstanceOnly, RetrievalMode retrievalMode, DateTime startRange, DateTime endRange)
at Act.Framework.Activities.ActivityManager.GetActivityList(ActivitySortCriteria sort, IActivityFilterCriteria[] filterCriteria, ActivityAccessor[] accessors, Contact contact, Boolean includeEvents, Boolean firstUnclearedOnly, RetrievalMode retrievalMode, DateTime startRange, DateTime endRange)
at Act.Framework.Activities.ActivityManager.GetAlarmedActivities()
at Act.Web.Framework.AlarmManager.RefreshAllAlarmedActivities()
at Act.Web.Framework.AlarmManager.GetOverdueAlarms(Boolean forceRefresh)
at Act.Web.Framework.AlarmManager.get_OverdueAlarmsExist()
at Act.Web.Global.CheckForDueAlarms()
at Act.Web.Global.Global_AcquireRequestState(Object sender, EventArgs e)
at System.Web.HttpApplication.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean&amp; completedSynchronously)
REFERER: http://192.168.2.5/apfw/default.aspx</Data>
</EventData>
</Event>

 

 

Does anyone know how to make sense of that???

 

Thanks!

New Member
Posts: 5
Country: USA

Re: Web Access Not Working Properly

Couple more pertinent (possibly) details:

 

Logging in through the local machine works fine

The database seems to be working fine.

 

Thanks

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Web Access Not Working Properly

Hello CommFitness,
Welcome to the Sage ACT! Community. Please provide some additional information:
- What version of ACT! for Web are you using?
- Does this affect all web users (multiple machines)?
- Have there been any recent Windows or ACT! updates applied on the web server?
- Can you log in locally via the web on the web server (through //localhost)?

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

New Member
Posts: 5
Country: USA

Re: Web Access Not Working Properly

We are running ACT Premium 2012.

Yes, this error occurs regardless of which computer you are trying to log in from.

I do not believe there have been updates to the server or ACT recently.

And, yes we get the same error when trying to connect locally through //localhost.

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Web Access Not Working Properly

A couple of things:
- First make sure the web server and the client machines have accounted for Daylight Savings Time (if that applies to your region), and make sure there are no significant differences in machine time between the server and the clients
- Do all your web users have Google integration installed and configured for the ACT! web client?

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

New Member
Posts: 5
Country: USA

Re: Web Access Not Working Properly

Yes both have accounted for DST.

 

No not all of our users have set up Google Integration, but I do have it set up on my account which is the one that I am trying to log in with, could that be an issue?

 

When I go to Web Site Administration, my database tests good, but I get the same error when I test the virtual directory...

New Member
Posts: 5
Country: USA

Re: Web Access Not Working Properly

anyone have any thoughts on what I should try to correct this situation?  I am wondering if it has anything to do with the IIS settings or some mis-directed database link???

Bronze Elite Contributor
Posts: 2,546
Country: New_Zealand

Re: Web Access Not Working Properly

Is it ACT! Premium for Web you have installed on the server or ACT! Premium?

What is the operating system on the server?  

Graeme Leo
Xact Software - consultants and developers
Follow us on Twitter and check out our Blog


Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Web Access Not Working Properly

This part of the error message: "MESSAGE: Invalid recurrence pattern. Retrieval of named days expects day type of Named. Actual value was None." is generally a sign of corrupt recurring activities added to the database through the Google sync.  Try removing recurring activities from Google calendar and synchronizing, it may remove the damaged activities from the ACT! calendar and allow access.

 

When signed into the database through an installed client, do you get any errors accessing your calendar/task list or creating activities?

Greg Martin
Sage