Community
Showing results for 
Search instead for 
Do you mean 
Reply

Upgrading from V17 Premium for Web to V18 Premium for Web Registration Fails

New Member
Posts: 7
Country: USA

Upgrading from V17 Premium for Web to V18 Premium for Web Registration Fails

We have Act! Premium V17 for Web on a Windows Server 2012R2 server VM. We cloned the machine to a new VM (naming it test) and verified V17 was working as expected. I downloaded V18 Premium for Web and installed as directed. During the install, V17 was Uninstalled and V18 appeared to install successfully (no errors noted). When I launch Act! V18, I'm requested to Register or Continue with the trial. I click the Register Now button, select "I have purchased Act! and am ready to register" radio button, then click Next. I enter my *Valid* Serial Number and click Next but the SN is rejected as invalid. Even though I knew it wouldn't help, I installed the Hotfixes (2, 3 and 4) and I was right. They didn't solve anything. I still can't register. I then upgraded my laptop (hoping maybe it was related to the test VM) and get the same result. Followed the same troubleshooting steps, no success.

 

This same thing happened when we upgraded from V16 to V17 and I ended up spending most of a day on the phone with Tech Support in order to resolve it. I've followed all the trouble shooting steps outlined in the KBs: Admin rights, UAC settings, Registry hacks, deleting and reinstalling licensing services and what ever else but still I'm stopped. I believe these were the same things Tech Support did during my last upgrade. I really don't have the time or patience to spend the better part of a day on the phone again. Along with the test machine, I've got about a dozen user workstations to upgrade too. I REALLY don't want to be going through a bunch of hoops to register each one of them! I certainly don't want to be spending my time on the phone with Tech Support for each workstation I have to upgrade either. Isn't there a better solution???

Bronze Elite Contributor
Posts: 1,430
Country: United_Kingdom

Re: Upgrading from V17 Premium for Web to V18 Premium for Web Registration Fails

Had this before on a site and it turned out to be a firewall problem - see below.

 

Please make sure that the relevant item is marked as an exception in your firewall.

 


Process Exceptions
A process is the executable file which allows a program or application to run. It is recommended that exceptions for the following processes be added to your anti-virus and/firewall:

 

PsiService_2.exe32-bit OS: C:\Program Files\Common Files\Protexis\License Service
64-bit OS: C:\Program Files (x86)\Common Files\Protexis\License Service
New Member
Posts: 7
Country: USA

Re: Upgrading from V17 Premium for Web to V18 Premium for Web Registration Fails

OK, I Opened the firewall to allow that process, but it still didn't register.

Silver Elite Contributor
Posts: 3,353
Country: United_Kingdom

Re: Upgrading from V17 Premium for Web to V18 Premium for Web Registration Fails

 

Bruce

 

Does this help?

 

http://kb.act.com/app/answers/detail/a_id/38254/kw/registrationdata.xml 

Jeff Granger
UK ACT! Specialist and Trainer

ACT Training Throughout The UK
www. bigbluemarketing.co.uk