Community
Showing results for 
Search instead for 
Do you mean 
Reply

Unable to share file across network - branching into other issues - urgent help needed.

Accepted Solution Solved
Tuned Listener
Posts: 15
Country: USA
Accepted Solution

Unable to share file across network - branching into other issues - urgent help needed.

hi all

 

I'm trying a simple lan share, and I keep coming up with this error:

 

'Cannot find database suppliemental files folder TestDB-database files in this location SERVER.  This could be a problem with the share, or the folder may not exist.  Please contact the administrator of your database.

 

I've followed every single step in KB 19876 to try to resolve this issue with no luck.  I'd like to actually just sync it (with two different users being able to enter their own records), but I can't even get it to properly connect.

 

What steps can I take to resolve this issue and then allow it to sync and then eventually allow for internet sync so I can use my laptop on the road?

 

Better yet, I've got a spare computer with Windows 7 and a static IP.  How can I just host this myself on this spare PC?  If there's a Act Rep in the Las Vegas area, I'd even be tempted to pay you so I don't have to deal with this hassle any longer.  I'm close to running over my deadline.

 

Thanks in advance.


Accepted Solutions
Solution
Accepted by topic author Kurt
‎09-25-2015 03:20 AM
Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Unable to share file across network - branching into other issues - urgent help needed.

Sounds like a lot going on, but should be able to resolve pretty easily... start with the basics of syncing over the network before moving on to the internet sync.

 

First: open the database on the host machine > go to Tools > Synchronize Database > uncheck 'Accept Incoming Syncs'.

  You won't need this enabled with Network Sync installed.

Second: On the host machine, double click on the Network Sync icon in the system tray (green and orange arrows)

  Add the database that you want to sync with the remotes.  Start the Sync Service.

Connect the laptop to the network and test the sync.

 

With Network sync in place, you can sync with the database closed and sync multiple databases.

 

Once that is successful, here is an article with instructions for synchronizing over the internet using the Network Sync Service: KB Article 17536  (it's easier than installing and setting up the Internet Sync Service).

Greg Martin
Sage

View solution in original post


All Replies
Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Unable to share file across network - branching into other issues - urgent help needed.

Just to verify - you did update the PAD with the IP and change the Datastore location - correct?

Have you tried disabling the firewall on the host computer?  Here is an article with exceptions to add to a firewall: KB Article 25125

 

What are the operating systems of the host computer and workstation?

 

Try creating a new database in a folder directly on the C: drive (ex: C:\ACTdb), share the database and add the permissions for 'Everyone', then attempt to access it from the workstation.  Successful or not?

 

Have you attempted a sync with a remote?  If yes, what error is it receiving when attempting to sync?

 

To locate a local certified consultant, visit this web page: Find an ACC

 

Greg Martin
Sage
Tuned Listener
Posts: 15
Country: USA

Re: Unable to share file across network - branching into other issues - urgent help needed.


gmartin wrote:

Just to verify - you did update the PAD with the IP and change the Datastore location - correct?

Have you tried disabling the firewall on the host computer?  Here is an article with exceptions to add to a firewall: KB Article 25125

 

What are the operating systems of the host computer and workstation?

 

Try creating a new database in a folder directly on the C: drive (ex: C:\ACTdb), share the database and add the permissions for 'Everyone', then attempt to access it from the workstation.  Successful or not?

 

Have you attempted a sync with a remote?  If yes, what error is it receiving when attempting to sync?

 

To locate a local certified consultant, visit this web page: Find an ACC

 


1) Updated the pad with the IP and directory

2) All the steps in KB 25125 had already been done.  I completely disabled the firewall and got the same error

3) Both host & workstation using Windows 7 Home Premium 64bit

4) Created new database called 'Test2', Shared the folder with permissions for Everyone being Full Controll Allow.  Received this error:

Cannot find database supplemental files folder test2-database files in this location x.x.x.x.  This could be problem with the share, or the folder may not exist.  Please contact the administrator of your database.

5)  I have not attempted a sync and not quite sure how to do this since it won't see the database to share.  Do I backup the DB on the host PC and restore it on the workstation?  Which KB should I follow for this step?

 

I'll look for a local certified consultant.

 

Thanks

Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Unable to share file across network - branching into other issues - urgent help needed.

A couple more things to try:

Try disabling the Windows UAC function on both computers - instructions: KB Article 25665

Then attempt to open the shared db.

 

Create a Windows username with admin level authorization on the host machine that matches the one used on the workstation.  Then attempt to open the shared db. 

Note: You don't have to sign on to the host machine with the new username when attempting to open the shared db.

 

 

And...

The instructions for creating a remote are in this article: KB Article 14116

I would try syncing a remote even though the database hasn't successfully shared yet - different process, so the sync may work.

 

Since you are using Premium, here is an article for setting up the Network Sync Service: KB Article 26792

Greg Martin
Sage
Tuned Listener
Posts: 15
Country: USA

Re: Unable to share file across network - branching into other issues - urgent help needed.


gmartin wrote:

A couple more things to try:

Try disabling the Windows UAC function on both computers - instructions: KB Article 25665

Then attempt to open the shared db.

 

Create a Windows username with admin level authorization on the host machine that matches the one used on the workstation.  Then attempt to open the shared db. 

Note: You don't have to sign on to the host machine with the new username when attempting to open the shared db.

 

 

And...

The instructions for creating a remote are in this article: KB Article 14116

I would try syncing a remote even though the database hasn't successfully shared yet - different process, so the sync may work.

 

Since you are using Premium, here is an article for setting up the Network Sync Service: KB Article 26792


The only thing that worked here was making a remote database.  I was able to get it to sync.  Minor setting to have to do now since for some reason it's not saving history of edits which is key for me to have.

 

As I was able to get the network sync, I thought to try the internet sync and followed the steps in KB 17536. I used my laptop with clear service to try to sync, and I got the following error:

 

ACT! is unable to connect to the sync server.  Check to be sure 'accept incoming sync' is enabled in the main database and that the Network sync service is running.  Also be sure you are connected to your network.  Contact your adminstrator for assistance.

 

Under manage connections, I set it to connection type 'Internet (outside a firewall) with my external IP and received the same error.  The only way I could sync with my laptop is to connect to internal wifi with it being Network (inside a firewall) with the server's internet IP.  I did make sure that the router was set up to TCP forward the port to the proper computer.

 

Do I need to set up the network sync service on each server?

 

Additionally I noticed something that seemed a bit odd.  The workstation would not sync unless I had Sage ACT running with the database open.  Is there another setting I could use?  I had planned to host two databases on the same server.  If I have to switch to another computer that's okay, it would just be more conveinent to run all the databases off of the single server.

 

Thank you for all your help Greg, I hope you can assist me with this as well.

 

Regards,

 

Kurt

Solution
Accepted by topic author Kurt
‎09-25-2015 03:20 AM
Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Unable to share file across network - branching into other issues - urgent help needed.

Sounds like a lot going on, but should be able to resolve pretty easily... start with the basics of syncing over the network before moving on to the internet sync.

 

First: open the database on the host machine > go to Tools > Synchronize Database > uncheck 'Accept Incoming Syncs'.

  You won't need this enabled with Network Sync installed.

Second: On the host machine, double click on the Network Sync icon in the system tray (green and orange arrows)

  Add the database that you want to sync with the remotes.  Start the Sync Service.

Connect the laptop to the network and test the sync.

 

With Network sync in place, you can sync with the database closed and sync multiple databases.

 

Once that is successful, here is an article with instructions for synchronizing over the internet using the Network Sync Service: KB Article 17536  (it's easier than installing and setting up the Internet Sync Service).

Greg Martin
Sage
Tuned Listener
Posts: 15
Country: USA

Re: Unable to share file across network - branching into other issues - urgent help needed.

Greg,

 

I rebooted the host computer and noticed the sync service was already running.  Here are the steps I took:

 

Stopped Act Network Sync Service.

Opened ACT, tested sync with 'Accept Incoming Syncs.'  Sync worked. 

Unchecked 'Accept Incoming Syncs.' Exited out of ACT.

Opened ACT Network Sync Service. Added DB, clicked 'Start Sync Service.' 

Received popup 'The Sage ACT! Network Sync Service is running.'

 

Attempted sync on workstation, received this message:

ACT! is unable to connect to the sync server.  Check to be sure "accept incoming sync" is enabled in the main database and that the Network sync service is running.  Also be sure you are connected to your network. Contact your administrator for assistance."

 

My sync only works when Sage ACT! is running and the database is opened and it's set to "Accept Yncoming Syncs", which makes me wonder:

 

Should I uninstall completely and reinstall to make sure all the proper services are installed and running?  The only thing I can think of is that something got corrupted. 

 

 

 

Tuned Listener
Posts: 30
Country: USA

Re: Unable to share file across network - branching into other issues - urgent help needed.

It sounds like the issue you are having has to do with your Network.  One thing you might try is to add Network Sync to the Firewall exception List.  Please let me know if you are still having the issue.

Tuned Listener
Posts: 15
Country: USA

Re: Unable to share file across network - branching into other issues - urgent help needed.

Problem solved - when my tech set the port forwarding on the router he entered the wrong port (and subsequently received an earful from me).

 

I had thought it was extremely odd that with the firewall completely disabled it still wouldn't work.

 

Now for my next question:

 

Is there an easy way (read, automated process) to make sure every Field Name has the 'Generate History' flag marked to enabled?  Or am I going to have to go through every field in the main database and then let the sync get the new flags on the field names?

 

Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Unable to share file across network - branching into other issues - urgent help needed.

Glad to hear its working now!

Unfortunately there isn't a way within the program to automatically set all fields to record history, nor am I aware of an add-on that will do it. Perhaps other Community members will know of an add-on.
Greg Martin
Sage