Community
Showing results for 
Search instead for 
Do you mean 
Reply

Unable to connect using ActReader from remote machine.

Accepted Solution Solved
New Member
Posts: 3
Country: USA
Accepted Solution

Unable to connect using ActReader from remote machine.

I'm testing the ability to connect to an ACT! database from a remote machine.  

I have ACT! Premium 2011 installed on a virtual machine which is in turn installed on my development machine.  On the VM I am able to create a DSN and connect to the ACT database instance (SERVER_NAME\ACT7) using the ActReader user, however, I am unable to do the same from the host machine.  I get an error saying the connection failed, could not open a connection to SQL Server.   I have SQL 2008 R2 installed on the VM also, and I can connect to that default instance of SQL from the host machine without any problems, so I don't believe it's a firewall issue.  I can use SSMS to connect to the ACT! instance if I'm logged in as the administrator on the VM and use Windows Authentication, and I can see that Allow Remote Connections is checked for that instance.  I can ping the VM from the host, and I used PortQry (portqry.exe -n server_name -p UDP -e 1434) to verify that the instance can be detected. 

 

I'm running out of ideas.

 

Jim


Accepted Solutions
Solution
Accepted by topic author jbmartin
‎09-25-2015 03:20 AM
New Member
Posts: 3
Country: USA

Re: Unable to connect using ActReader from remote machine.

[ Edited ]

Alright, I've got this working.  I had assumed the firewall was ok because I had opened up the ports (tcp/1433 and udp/1434) for SQL access, and because I was able to successfully access a different instance of SQL on the same machine.  I still couldn't access the ACT instance though.  When I turned off the firewall everything started to work.  A review of the firewall logs showed that connection attempts were being dropped from several different ports (2790, 2794, 2810, etc).  

 

I found this page describing how to open up SQL when using dynamic ports...

Configure windows firewall for database engine access

 

I set up a firewall program rule pointing to the ACT SQL instance..

(%ProgramFiles%\Microsoft SQL Server\MSSQL10_50.ACT7\MSSQL\Binn\sqlservr.exe)

and now it's working.  (I had to keep the inbound rule for UDP, port 1434 also).

 

Disclaimer: This is how I got it to work.  I'm not a firewall security expert so I don't completely understand the security impact of the rule I created.  I'm working in a dev environment and someone else will ultimately be responsible for the production environment firewall settings.  

 

Jim

 

 

 

View solution in original post


All Replies
Silver Contributor
Posts: 1,813
Country: USA

Re: Unable to connect using ActReader from remote machine.

you need to create a DSN on the machine you are connecting from and list the aCT machine as the target.

So on hte Client machine, create a system DSN and point to the servername/ACT7 sql instance with the username of Actreader and your actreader password.  that should work.

Test Drive Act! and Quickbooks over Citrix http://GoTryAct.com

Jon Klubnik| ActTrainer.com
(866)710 4228

ACT! Certified Consultant / ACT! Premier Trainer / ACT! Hosting Provider

New Member
Posts: 3
Country: USA

Re: Unable to connect using ActReader from remote machine.

Thanks for the reply.  I was making the DSN on the machine I wanted to connect from (the host) with no luck.  I just now after flailing most of the day turned the firewall completely off on the VM and was able to successfully connect from the host.  I'll need to go back and figure out where the issue is.  I had already opened up port 1433 for TCP and 1434 for UDP as was recommended by Sage.  

Solution
Accepted by topic author jbmartin
‎09-25-2015 03:20 AM
New Member
Posts: 3
Country: USA

Re: Unable to connect using ActReader from remote machine.

[ Edited ]

Alright, I've got this working.  I had assumed the firewall was ok because I had opened up the ports (tcp/1433 and udp/1434) for SQL access, and because I was able to successfully access a different instance of SQL on the same machine.  I still couldn't access the ACT instance though.  When I turned off the firewall everything started to work.  A review of the firewall logs showed that connection attempts were being dropped from several different ports (2790, 2794, 2810, etc).  

 

I found this page describing how to open up SQL when using dynamic ports...

Configure windows firewall for database engine access

 

I set up a firewall program rule pointing to the ACT SQL instance..

(%ProgramFiles%\Microsoft SQL Server\MSSQL10_50.ACT7\MSSQL\Binn\sqlservr.exe)

and now it's working.  (I had to keep the inbound rule for UDP, port 1434 also).

 

Disclaimer: This is how I got it to work.  I'm not a firewall security expert so I don't completely understand the security impact of the rule I created.  I'm working in a dev environment and someone else will ultimately be responsible for the production environment firewall settings.  

 

Jim