Showing results for 
Search instead for 
Do you mean 

Unable to backup Act!

Copper Super Contributor
Posts: 107
Country: Australia

Unable to backup Act!

Hi All,


Not able to backup Act! from the File menu or from Act! Scheduler.


When the scheduler runs we get this error

Errors: Failed to log into the database. A nonrecoverable I/O error occurred on file "\\<SERVERNAME>\<databasename>-database files\Backup\\<SERVERNAME>_<databasename>_D20181019T230007.BAK:" 112(failed to retrieve text for this error. Reason: 15105).
BACKUP DATABASE is terminating abnormally.


When we try from Act! we get this error



Environment Details

Act! Premium Version, Update 4
Microsoft SQL Server 2008 - Standard Edition (64-bit)
Windows Server 2008R2 SP1

ADF file size is 32GB in size


Steps tried

  • Checked and we have enough disk space
  • I get the same error in a demo database.  the demo database is in a different location from the production database.
  • tried the steps from this KB -
  • checked the permissions on the folder Act! is in.
  • added everyone as a permission on the Database folder.
  • tried to unshare the production database.

Any other ideas?  I am thinking it has to be something permission based but can't think what is causing this issue.





Silver Super Contributor
Posts: 2,206
Country: United_Kingdom

Re: Unable to backup Act!

Here is a link to another article that may help -


It all points to an SQL lack of permissions problems but is just occasionally a corruption problem in the SQL database so if the above does not help try running a schema repair from ACTDIAG!-data-diagnostic-tool-(actdiag)...


Copper Super Contributor
Posts: 107
Country: Australia

Re: Unable to backup Act!

Thanks @ch1p


I had a look at the link and it looked fine and I also ran the Act! Metadata and security repair and still the same error.  Also I can't seem to get to the database via Studio so thinking of doing a SQL reinstall now.