Community
Showing results for 
Search instead for 
Do you mean 
Reply

Synchronize menu disabled in remote database

Accepted Solution Solved
Copper Contributor
Posts: 23
Country: United States
Accepted Solution

Synchronize menu disabled in remote database

One of my clients uses ACT Premium 2008.  Her team has successfully been using internet sync for some time now.  One of the remote databases no longer has the synchronize option enabled as of about two weeks ago.  The user has not reported any other issues happening with ACT previous to this.  I've already tried repairing the databas and rebuilding the sync objects using ActDiag.  Any other thoughts on what I can do other than recreating the remote database entirely?

Accepted Solutions
Solution
Accepted by topic author holisticdeveloper
‎09-25-2015 03:20 AM
Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Synchronize menu disabled in remote database

There may be an issue with the user login for the remote. Try logging into the remote database as an Admin user (from the list in the Publisher database).

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

View solution in original post


All Replies
Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Synchronize menu disabled in remote database

In the remote database, go to Help/About ACT! and click the Database Information button. Scroll down in the Database Settings Information and see if Sync Enabled is True or False. If it is False, then this database will no longer be able to sync. You will need to export any unsynced data from this remote to the main database, then create a new remote database for the user.

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

Copper Contributor
Posts: 23
Country: United States

Re: Synchronize menu disabled in remote database

Sync Enabled is still set to True, and the Sync Role is properly set as subscriber.

 

I have noticed that the following menu items are also disabled:  File > Backup > Database, and everything under Tools > Database Maintenance.

 

I have also tried creating a brand new remote database, and it also exhibits the same problem.  I just tried today to uninstall and reinstall ACT, but the problem still persists.

 

Any other thoughts?

Solution
Accepted by topic author holisticdeveloper
‎09-25-2015 03:20 AM
Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Synchronize menu disabled in remote database

There may be an issue with the user login for the remote. Try logging into the remote database as an Admin user (from the list in the Publisher database).

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

Copper Contributor
Posts: 23
Country: United States

Re: Synchronize menu disabled in remote database

Thanks for the tip.  Unknowingly, the user in question had been changed to the "restricted" user role.  I changed the user back to the "standard" role in the master database, did a sync using an admin user, and then the user was able to log in and sync successfully.