Community
Showing results for 
Search instead for 
Do you mean 
Reply

Synchronization - Out of Memory Error Exception

New Member
Posts: 3
Country: United States

Synchronization - Out of Memory Error Exception

Hello,

 

I have one main database and one remote database which synchonize via a VPN connexion. They are both on Win 2003 servers. It used to work fine until I had this error: "Synchronization failed due to an out of memory error on the server. Exception of type 'System.OutOfMemoryException' was thrown."

 

I have tried many threads on the forum and the KB articles like this one:

http://kb.sagesoftwareonline.com/cgi-bin/sagesoftwareonline.cfg/php/enduser/std_adp.php?p_faqid=2352... 

 

... but nothing seem to work.

 

Could you please help me on that error ?

 

Many thanks

 

 

 

 

 

 

 

New Member
Posts: 3
Country: United States

Re: Synchronization - Out of Memory Error Exception

Anybody please ? I still have no solution to this issues.

 

Thanks 

Copper Contributor
Posts: 29
Country: United States

Re: Synchronization - Out of Memory Error Exception

What version of ACT do you have?

 

Did you try the referenced KB?  Did you reduce the buffer size and try and sync and if that did not work reduce it again and try and sync again? 

 

Rich Gehlbach
ACT! Certified Consultant
Redsaw Technology
richgehl@roadrunner.com
Rich Gehlbach
richgehl@roadrunner.com
New Member
Posts: 3
Country: United States

Re: Synchronization - Out of Memory Error Exception

Yes, I did reduce the buffer size on both servers to 4855. 

 

Here is the text I have in the file for the main database:

 

<?xml version="1.0" encoding="utf-8" ?>

<configuration>

<system.diagnostics>

<switches>

      <add name="ACTSyncSwitch" value="1" />

    </switches>

  </system.diagnostics>

<runtime>

<gcConcurrent enabled="false" />

<gcServer enabled="false" />

</runtime>

<appSettings>

<add key="DatabaseCommandTimeOut.Default" value="30"/>

<add key="DatabaseConnectionTimeOut.Default" value="30"/>

<add key="DatabaseCommandTimeOut.Long" value="3600"/>

<!-- End timout values. -->

<!-- Supplemental file system watcher for syncing files -->

<add key="Synchronization.MonitorDatastore" value="true"/>

<!-- A bi-directional outbound transport setting to avoid encryption of sync data.

Note: Must be set on both client and server -->

<add key="Synchronization.UseEncryption" value="true"/>

<!-- A uni-directional outbound file sync override to shut off any files from syncing.

Note: Can be set on either client or server -->

<add key="Synchronization.SyncFileData" value="true"/>

<!-- A uni-directional outbound file sync buffer size.

      Note: Default size is 5 Megabytes.  Change this value to regulate file sync performance. -->

<add key="Synchronization.FileBufferSize" value="4855"/>

<!-- A uni-directional outbound data list buffer size.

      Note: Default size is 100 records per sync packet.  Change this value to regulate data sync performance. -->

<add key="Synchronization.DataListBufferSize" value="100"/>

</appSettings>

</configuration> 

 

 

Besides, there are no large number of files on the report as shown in the example. We do not use file synchronization.

 

We use ACT! by Sage Premium 2008 (10.0) (ST Edition) Version 10.0.3.182 

 

Thanks