Community
Showing results for 
Search instead for 
Do you mean 
Reply

Synching Issue

Tuned Listener
Posts: 113
Country: USA

Synching Issue

I set up synchronization using ACT 2008 a few weeks ago,and everything worked fine.  Since then, I have created a new database and moved it to the server.  I created my remote db, etc.
 
Since I have moved the new db to the server, it seems it only syncs if ACT is open.  Previously, it didn't have to be open.  If it is not open now, I receive a message that the db is not accepting incoming syncs or I am not connected to the network.  I remote in to the server, incoming syncs is accepted.  I minimize ACT, and can now sync.  If I close ACT, I cannot sync. 
 
Any suggestions?
 
 
Copper Elite Contributor
Posts: 118
Country: india

Re: Synching Issue

Have you added the new database to the network sync service.
New Member
Posts: 26
Country: USA

Re: Synching Issue

For others experiencing issues with synchronization, I have found that when setting up remote users, you should open the publishing database first.  If you just unpack and restore the remote database and attempt to sync, it stops the sync service on the server.  After restarting the service, it took me three times of stopping and restarting the service to get it running again. 

 

I found that if you open the publishing database first, close it, and then open the remote db and sync, all is fine.

 

I have a new issue in that ACT needs to be open on the server or the sync service stops.  According to the documentation, ACT doesn't need to be running.  I have only had this issue when I tried to sync a user that had not opened up the publishing db first.  Could this have reset something in the sync service?  Any suggestions are welcome as I don't want to have ACT open and running on the server to be able to sync.

Copper Elite Contributor
Posts: 118
Country: india

Re: Synching Issue

open the publisher database on the server, goto tools synchronization, uncheck accept incoming sync ( if it is enabled )

close act

exit out of act network sync, reopen it again

stop the sync service. check the port no being monitored

check if the new publisher database is listed in the netwrok sync service

start the sync service, try to synchronize

New Member
Posts: 26
Country: USA

Re: Synching Issue

Thanks for your response.  When I launch the network synch service, nothing happens.  I can't get the app to launch.  The hour glass appears for a few seconds and it appears as if it is starting and stopping the service.  I'm guessing this could be part of the problem.

 

Would a reinsall of the ACT Synchronization Service fix this issue?  Are there any dangers in reinstalling this service (such as sync won't work at all)

 

Thanks.

Copper Elite Contributor
Posts: 118
Country: india

Re: Synching Issue

you dont have to reinstall the sync service

in the system tray, right click on the network sync service, select show/hide

stop the sync service

exit out of sync service

close act, close network sync service( right click on sync service exit)

reopen network sync service

start the sync service and then sync

this should work

Copper Elite Contributor
Posts: 118
Country: india

Re: Synching Issue

you can also try to use a different port no: 65100, 65110, 65200
New Member
Posts: 26
Country: USA

Re: Synching Issue

Thank you for your response.  Below are the steps I took.

 

1.  Stopped sync service in ACT.  Closed ACT.

2.  Open ACT Sync Network Service and add new db to list of dbs to be synced.  Received error message:  "ACT Networking Sync Service could not be started.  Time out has expired and has not been completed."

3.  Attempted to start sync service again by using different port.  Sync service started on port 65200.

4.  Opened ACT  -->  Tools   ----> Synchronize ----->  Accept Incoming Syncs

5.  Attempted to use port 65200 (the same as the sync service is running).  Received error message:  "Could not start sync server.  ACT!   has encountered an eror.   Please be sure that sync server port is able to listen to incoming connections."

6.  Attempted to use port 65300, and sync service started.

7.  The sync ports do not match in the sync service or the incoming sync selection.  I cannot get the two ports to be the same and get the sync service started.

 

 


Any help is appreciated.

 

Thank you.

 

Copper Elite Contributor
Posts: 118
Country: india

Re: Synching Issue

you will not be able to use the same port no for both network sync service and accept incoimg sync

use either network sync or enable accept incoming sync

Tuned Listener
Posts: 113
Country: USA

Re: Synching Issue

OK, I think I finally get it.  The sync service that is running continuously is listening on one port.   When you accept incoming syncs for a db inside ACT, it has to be a different port,  correct?

 

I'm still not understanding why ACT has to be open on the server in order for synchronization to occur.  If I close ACT on the server, users cannot sync and receive a message to check to be sure incoming syncs is enabled.  It is in fact enabled, but ACT is just not up and running on the server. 

 

Thanks for all of your help and patience so far.