Community
Showing results for 
Search instead for 
Do you mean 
Reply

Sync volume issues

Loyal Listener
Posts: 42
Country: United_Kingdom

Sync volume issues

My client has a 200,000 record database and regularly merges large amounts of data, using Premium 10.0.0.1 we used to have problems synching when these additions got beyond 7.000 records.

Network Sync failed on regular basis but Application Sync then worked until we have over 7k.

The network is a series of adsl linked machines on a hub and spoke layout, syncs tend to be one at a time.

With 10.0.0.2 hotfix 1 we have a much better Network Sync process but a lower limit on the changes, 3,500 records and some edits and it fails with a time out error, the sync log stops at the schema line.

Sage support say that the sync process is not designed for large scale imports of data.

Has anyone any ideas how we can manage this import and sync process, the client needs to bring in 5,000 records at a time merging with the existing data and checking that duplicates are not created. This then needs sharing with the other users.

He has a reluctance to use Premium for Web.


TIA

Paul M Tate
Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: Sync volume issues

Are these all new records are updates to current records? You might try using itImport. The Pro edition has a setting to reduce the amount of transactions for sync users

 

How big is the ADF file in GB (both Publisher and Subscriber)? Remember, when running on a non-server operating system, SQL Server 2005 is limited to 4GB

 

You could try increasing the TimeOutLong value in ACTDIAG as per this ACT! Knowledge Base article - http://tinyurl.com/4nsog5

Loyal Listener
Posts: 42
Country: United_Kingdom

Re: Sync volume issues

they are a mixture of new records and possible updates, the initial import works fine, not sure how a separate import program would help, but ill have a look, thanks

The adf file is 2.6mb, it shrank when updated to 10.0.0.2

I thought it was sql express that had the 4gb limit?

The timeouts are set to 1200, 1200, 3600 and when increased the time to timeout doesn't seem to change anyway.
TIA

Paul M Tate
Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: Sync volume issues

The Pro version of itImport has an option to only log fields that are changed... this reduces the amount of data to sync.

 

SQL 2005 Express is always used if the operating system is not Windows 2003

 

I'd bump the 3600 much bigger - both server and remote

 

The only other option would be to do the imports 2500 at a time, then a sync, then the next lot

Moderator
Posts: 4,395
Country: USA

Re: Sync volume issues

Hello,

 

Increasing timeout values for syncing in actdiag on the server will only affect application sync.  To increase timeout with network sync, you will need to modify the Act.Framework.Syncrhonization.Service.exe.config file located where you've installed the service (default: C:\Program Files\ACT\Act for Windows\ACT Network Sync).

 

First stop and close ACT! Network Sync Service. Open the config file in notepad and add these triggers between </runtime> and </configuration>

 

    <appSettings>
        <!-- Database Timout values are in seconds so a value of 30 will be 30 seconds -->
        <add key="DatabaseCommandTimeOut.Default" value="360"/>
        <add key="DatabaseConnectionTimeOut.Default" value="360"/>
        <add key="DatabaseCommandTimeOut.Long" value="3600"/>
    </appSettings>

 

As you can see, timeout values have already been increased from the default value 30. 

 

Thanks.

Loyal Listener
Posts: 42
Country: United_Kingdom

Re: Sync volume issues

thank you, nobody has ever mentioned that despite previous phone calls to support lines.....
TIA

Paul M Tate