Community
Showing results for 
Search instead for 
Do you mean 
Reply

Sync problem!!! Synchronization failed due to an out of memory error on the server

Accepted Solution Solved
Skilled Commentator
Posts: 98
Country: Australia
Accepted Solution

Sync problem!!! Synchronization failed due to an out of memory error on the server

Hi,

 

I have ACT premium 2012.  The remote sync normally works fine.  It has not started giving this error:

 

======== SYNC SESSION - 15/02/2012 6:03:57 AM ========

 

[ Info | 15/02/2012 6:03:58 AM ]Message: Sync remote client created.

[ Info | 15/02/2012 6:04:20 AM ]Message: Checking if schema changes are available for sync.

[ Info | 15/02/2012 6:04:21 AM ]Message: Client establishing synchronisation with server database: FEPTCURRENTACER

[ Info | 15/02/2012 6:04:29 AM ]Message: Initial Handshake completed.

[ Info | 15/02/2012 6:04:29 AM ]Message: Checking if data changes are available for sync.

[ Info | 15/02/2012 6:04:30 AM ]Message: Client initialized database send session: 915

[ Info | 15/02/2012 6:04:30 AM ]Message: Client initialized.

[ Info | 15/02/2012 6:04:31 AM ]Message: Client schema synchronised.

[ Info | 15/02/2012 6:04:36 AM ]Message: Server initialized.

[ Info | 15/02/2012 6:04:37 AM ]Message: Server schema synchronised.

[ Error | 15/02/2012 6:04:38 AM ]Message: File synchronisation failed.

[ Error | 15/02/2012 6:04:38 AM ]Message: Synchronisation has failed. Server Error Description: Synchronization failed due to an out of memory error on the server. Exception of type 'System.OutOfMemoryException' was thrown.

 

I have tried the advice in article ID 23416 and it didn't work.  I have started trying article ID 23526 but it is only a total of 28 adds and 12 updates so I'm sure the issue isn't this.  I also know it is only the usual siz e sync.  After trying these option I diable sync and then re enabled it to see if it would work. Now sync won't even start at all.  I can enable it in sync panel, but the sync option is grayed out so I don't think it is enabled?

 

How can I get the sync working again? Thanks


Accepted Solutions
Solution
Accepted by topic author scott hunt
‎09-25-2015 03:20 AM
New Member
Posts: 1
Country: USA

Re: Sync problem!!! Synchronization failed due to an out of memory error on the server

Hi,

This issue can be resolved by running the SYNC_USERCOLUMN_ERROR.bat file attached to this article. Please follow the steps below:

 

  1. Click the SYNC_USERCOLUMN_ERROR.bat file found in the "File Attachments" section near the bottom of this article.
  2. When prompted, save the file to your Desktop.
  3. Close Sage ACT!.
  4. Go to the batch file and double-click it to run.
  5. Type in the name of your database when prompted and press the Enter button on your keyboard.
  6. Once the procedure starts, do not close the command window until it completes as this will terminate the procedure. The procedure will take several minutes to run.
  7. When the procedure is complete, close the command window when prompted.
  8. Reopen Sage ACT! and test.

http://www.techyv.com/questions/synchronization-has-failed-sage-act-2012


View solution in original post


All Replies
Bronze Elite Contributor
Posts: 2,548
Country: New_Zealand

Re: Sync problem!!! Synchronization failed due to an out of memory error on the server

Is it just one user, or all?

How about creating async set and not including attachments and see if that works.

I would be looking for a recent  large attachment that sync can't swallow  Smiley Sad 

Graeme Leo
Xact Software - consultants and developers
Follow us on Twitter and check out our Blog


Skilled Commentator
Posts: 98
Country: Australia

Re: Sync problem!!! Synchronization failed due to an out of memory error on the server

Thanks Graeme, I'll try that.  We do put a lot of PDF's (although no more than 10 a day) in the documents tab so that may be it.  How do I find out if this is it?  

 

However I can't even try that until the sync option is no longer grayed out due to me stopping it and trying to restart it.  I've tried to fix it but manage connection information is also grayed out.  How to do I fix this?

Bronze Elite Contributor
Posts: 2,548
Country: New_Zealand

Re: Sync problem!!! Synchronization failed due to an out of memory error on the server

Scott,

As suggested you should setup a sync and not include attachments. You can go into the Attachments folder and see if there are some huge attachments in there. Need to look in Supplementary files assocoiated with the database i.e.  <database name> -database files. My advice is not to load up the Documents tab in ACT! better to assign a folder for each record and put them there. Access that directly as a URL field e.g. file://U:\ABC Corporation  so you would have a Windows folder for each record. The data isn't going to sync to remotes but that may not matter to you. 

 

You need to be logged into Windows as an Administrator could be the issue with the greyed out sync.   

Graeme Leo
Xact Software - consultants and developers
Follow us on Twitter and check out our Blog


Skilled Commentator
Posts: 98
Country: Australia

Re: Sync problem!!! Synchronization failed due to an out of memory error on the server

Thanks Graeme, yes I am logegd into Windows as administrator.  Nothing is different to usual when it works.  All I did was disable syncronization and then re enable it to see if that would fix it.  And it made this new problem immediately!  Any ideas? 

 

That's a good idea re windows folder for documents, i'll look into it.  However to start with i just need to get it syncing again in the first palce. 

Solution
Accepted by topic author scott hunt
‎09-25-2015 03:20 AM
New Member
Posts: 1
Country: USA

Re: Sync problem!!! Synchronization failed due to an out of memory error on the server

Hi,

This issue can be resolved by running the SYNC_USERCOLUMN_ERROR.bat file attached to this article. Please follow the steps below:

 

  1. Click the SYNC_USERCOLUMN_ERROR.bat file found in the "File Attachments" section near the bottom of this article.
  2. When prompted, save the file to your Desktop.
  3. Close Sage ACT!.
  4. Go to the batch file and double-click it to run.
  5. Type in the name of your database when prompted and press the Enter button on your keyboard.
  6. Once the procedure starts, do not close the command window until it completes as this will terminate the procedure. The procedure will take several minutes to run.
  7. When the procedure is complete, close the command window when prompted.
  8. Reopen Sage ACT! and test.

http://www.techyv.com/questions/synchronization-has-failed-sage-act-2012


Copper Elite Contributor
Posts: 336
Country: USA

Re: Sync problem!!! Synchronization failed due to an out of memory error on the server

If you disabled the sync for that particular database, I don't believe you can re-enable it.  You can suspend and re-enable, but not disable and re-enable.

Kris Lock
Inside Sales Manager/ACT! Certified Consultant
Technology Transfer Services
www.techtransfer.com
www.myodesie.com
Skilled Commentator
Posts: 98
Country: Australia

Re: Sync problem!!! Synchronization failed due to an out of memory error on the server

Thanks Andrewpaul that worked!  I had actually reset up the whole sync just prior to your reply but same issue happened a couple of weeks later, your solution fixed it though!

 

Scott

New Member
Posts: 2
Country: United States

Re: Sync problem!!! Synchronization failed due to an out of memory error on the server

AndrewPaul, I'm running into this issue as well. However, I am not seeing a "File Attachments" section at the bottom of the article you posted. Do you have a copy of the file, and could I get you to send me a copy if so?
Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Sync problem!!! Synchronization failed due to an out of memory error on the server

The attachments were actually in the response (not at the bottom of the page).  Here is an article from our knowledgebase with the same attachments: KB Article 28141

Greg Martin
Sage