Community
Showing results for 
Search instead for 
Do you mean 
Reply

Some users get kicked out when goign to pages in ACT V18 Premium for web with this

Copper Contributor
Posts: 31
Country: USA

Some users get kicked out when goign to pages in ACT V18 Premium for web with this

What does this string of error messages on my server mean and why does it happen sporadically with some of my users using the web version of ACT

 

 

 

 

SOURCE: mscorlib

MESSAGE: Value cannot be null.

Parameter name: accessToken

FORM:

QUERYSTRING:

TARGETSITE: Void HandleReturnMessage(System.Runtime.Remoting.Messaging.IMessage, System.Runtime.Remoting.Messaging.IMessage)

STACKTRACE:

Server stack trace:

at SwiftpageOAuth2Client.OAuth2Client.AuthorizeWithBearerToken(WebHeaderCollection requestHeaders, String accessToken)

at SwiftpageOAuth2Client.OAuth2Client.AuthorizeRequest(WebHeaderCollection requestHeaders, IOAuth2AuthorizationState authorization, IDictionary`2 extraAuthorizationRequestData)

at Act.Engage.OAuthCustomBehavior.BeforeSendRequest(Message& request, IClientChannel channel)

at System.ServiceModel.Dispatcher.ImmutableClientRuntime.BeforeSendRequest(ProxyRpc& rpc)

at System.ServiceModel.Channels.ServiceChannel.PrepareCall(ProxyOperationRuntime operation, Boolean oneway, ProxyRpc& rpc)

at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout)

at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation)

at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)

Exception rethrown at [0]:

at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)

at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)

at Act.Web.Sp2Services.UserServices.GetProfiles()

at Act.Web.Emarketing.EmarketingView.LoadSenderEmailAddress()

at Act.Web.Emarketing.EmarketingView.Page_Load(Object sender, EventArgs e)

at System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e)

at System.EventHandler.Invoke(Object sender, EventArgs e)

at System.Web.UI.Control.OnLoad(EventArgs e)

at System.Web.UI.Control.LoadRecursive()

at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

REFERER: http://162.213.40.83/APFW/Emarketing/EmarketingHome.aspx

 

 

 

 

 

1:Error occured on page: mscorlib Message:Value cannot be null.

Parameter name: accessToken

 

 

 

 

 

 

There was an exeption sending BusinessCare service level.

 

 

 

 

 

Value cannot be null.

Parameter name: accessToken

 

 

 

 

 

This does not happen all the time but it appears to happen randomly with some of my users.  When it happens they get kicked out of ACT to a login screen with a error message

 

Thanks in advanced

 

 

Nickel Super Contributor
Posts: 341
Country: USA

Re: Some users get kicked out when goign to pages in ACT V18 Premium for web with this

Possibly the following article will help...

 

http://kb.act.com/app/answers/detail/a_id/22038

 

Best regards,

 

Juan Carlos Otero
juancarlostero@icloud.com
Copper Contributor
Posts: 31
Country: USA

Re: Some users get kicked out when goign to pages in ACT V18 Premium for web with this

Thanks checked IIS.  unfortunately my maximum worker processes are already set to 1.

Administrator
Posts: 4,024
Country: United_Kingdom

Re: Some users get kicked out when goign to pages in ACT V18 Premium for web with this

[ Edited ]

It seems to be an issue with the Act emarketing authentication token.

Do the affected users have Act emarketing accounts?
What happens when they click on the Emarketing navigation button on the left hand side of Act for web?
Could you ask them to log off from the Emarketing menu at the top of Act for web, and then log back in again and see if that has any effect on the issue?

 

Deleting the WebPreferences.xml file for the users may also be worth a try as a last resort. More details on the location of this in the following Knowledgebase article: http://kb.act.com/app/answers/detail/a_id/19757

Copper Contributor
Posts: 31
Country: USA

Re: Some users get kicked out when goign to pages in ACT V18 Premium for web with this

You know what at this particular moment the user was clicking on the emarketing link at the left side.  I will definitely give this a try.  The users don't have an emarketing account.  The only one who logs into emarketing is me.  But it is possible I logged in at some point on the users computer to look at the calllist.  Thanks Gary.  I'll check it out.  And I'll check out the preferences file as well.  The APFW shoots out errors on our server all the time.  Is there a place I could send our server log to for your techs to see some of the problems we have.  I don't always know the steps that are being taken when most of the errors happen though.

 

 

Administrator
Posts: 4,024
Country: United_Kingdom

Re: Some users get kicked out when goign to pages in ACT V18 Premium for web with this

Hi deeaamon,

 

For any other issues that require further investigation, a support ticket would need to be opened for each case. This can be done over the phone or via the web. These will both require some form of support cover.

Copper Contributor
Posts: 318
Country: Canada

Re: Some users get kicked out when goign to pages in ACT V18 Premium for web with this

I have been having this very issue as well. Will try logging off and back into emarketing to see if it resolves the issue.

Thanks