Community
Showing results for 
Search instead for 
Do you mean 
Reply

Smart Task "Auto Run" not functioning properly

New Member
Posts: 6
Country: USA

Smart Task "Auto Run" not functioning properly

I have an Auto Task setup to run nightly on Opportunities where the stage is = Bid.  I have setup and re-setup this task several times, however, it only runs once then never again. It is setup only to run once per record.  Please  bear in mind that I am ACT administrator for my company, and have a decent knowledge of the software.  Also, this task is setup on my server to run for multiple users, and the software is running constantly using Administrator login.  The auto-tasks are also "private".  I am trying to avoid having to have the tasks setup on each PC, as the server environment is easier to manage.  Any suggestions?

Chuck Billmyer
Software Analyst
Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Smart Task "Auto Run" not functioning properly

Hello Chuck,

It sounds like there may be a couple of factors here:

- If you have the task set to "Private", then only the user who created it can access it

- The auto-run will only trigger if the user who enabled the auto-run option (not necessarily the user who created it) is logged into the database. So if you were the user who selected the auto-run option, then it will only trigger if you are logged into the database.

 

Also, make sure you applied the latest updates to Microsoft .NET, since the Smart Tasks feature is built on the Windows Presentation Foundation feature of .NET 3.5

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

New Member
Posts: 6
Country: USA

Re: Smart Task "Auto Run" not functioning properly

OK.   Well if that was the case then it should not have run succesfully at all..right?  The first night it ran fine, and none of the users were logged into the DB.  When they logged in the next day the event was in their calendar.

 

Also, can ACT be setup to run as a service? 

 

Thanks

Chuck Billmyer
Software Analyst
New Member
Posts: 3
Country: USA

Re: Smart Task "Auto Run" not functioning properly

I'm having the similar problem with smart tasks. I have a smart task set up to add contacts to a swiftpage drip  marketing list and it is not updating the list.

 

The smart task has the following settings:

  1. auto-run: enabled
  2. Access: Public
  3. Recort Type: Contact
  4. Trigger: Runs every day at 1:30 - desired contact show up when I hit preview
  5. Add to Drip Marketing - have active swiftpage account

The list updated only once....

 

Running

Pro 2011 Ver 13.1.111.0 Hot Fix 2

 

Any help is much appreciated!

 

New Member
Posts: 3
Country: USA

Re: Smart Task "Auto Run" not functioning properly

Anyone????
New Member
Posts: 3
Country: USA

Re: Smart Task "Auto Run" not functioning properly

I'm having the same problem. Have you ever figured this out?