Community
Showing results for 
Search instead for 
Do you mean 
Reply

Shown history does not change when switching contacts

New Member
Posts: 12
Country: United States

Shown history does not change when switching contacts

We are running about 15 users in a Sage ACT! Premium 2011 Version 13.0.401.0, Hot Fix 2 environment.

 

Most all of our users have a sporadic problem where the histories seem to get "stuck" on a given contact.  It often seems related to adding new contacts, but not always.

 

Basically a given contact's history will show in the History tab, but when switching to other users (scrolling with the navigtion buttons, going back to the List View and selecting another contact, even searching for new contacts) the history will not change.

 

Our users often think that their history disappeared, when they are actaully just looking at the wrong contact's history.

 

Basically people "click around" to fix the problem (searching for new contacts, tryign other tabs, etc) and it eventually goes away - but sometimes you have to restart ACT!.

 

Any idea what is going on?  Its happening to most of our users and is terribly time consuming.

 

Thanks - Dan

Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Shown history does not change when switching contacts

Generally speaking this is a 'refresh' issue, to update the screen try pressing the F5 key (refresh).  

Since you mention this is intermittent and usually resolved by closing/reopening ACT!, it may be a computer resources issue - when it occurs, try looking at the amount of memory used by ACT! and other programs (Windows Task Manager).  

Other things to look for: are there a lot of programs open when it occurs, how much memory is on the computer...

Try reducing the Hardware Acceleration for the monitor.  The following article contains instructions Hardware Acceleration: KB Article 17422

Greg Martin
Sage
New Member
Posts: 12
Country: United States

Re: Shown history does not change when switching contacts

My particular machine is blazing fast (newest i7, 8GB of memory, Gigabit ethernet to the server), and typically runs at a fraction of its resources Smiley Sad  Although we are seeing the problem on at least 5 workstations of varying abilities and usages.

 

I've tried F5 to no avail - ACT! is actually doing it right now.  The items in the history pane are for a different contact than I'm viewing, refreshines just refreshes the wrong contacts, and when I scroll through the contacts in the current lookup, the history shown does not change.

 

I just did some experiementing:  I performed a search that turned up 3 contacts, and clicked on the first.  The correct history was shown, but when I scrolled to the 2nd and 3rd contacts, the 1st contact's history remained in the history pane (refreshing had no effect).


I then redid the same search, and got the same result.  However, then if I do a search that turns up a different set of contacts, the history is correctly shown.

 

Think this coudl be a bug?  Something I should raise with Sage?

Platinum Elite Contributor
Posts: 6,668
Country: USA

Re: Shown history does not change when switching contacts

No bug just a lot of history entries for some contact records. By the way the processor speed is secondary to the I/O speed when working with the ACT! program. Try running the Notes/History report for all dates for one of the problem contacts and see how many pages you get.

Roy Laudenslager
ACT! Certified Consultant
ACT! Report Expert
Durkin Impact Report Designer
www.techbenders.com
royel@techbenders.com
541-343-8129
New Member
Posts: 12
Country: United States

Re: Shown history does not change when switching contacts

Ok - I just created a new contact:  Ellis C. - this guy is brand new and has no history.

 

As soon as I pressed Ctrl + S to save the contact, the screen refreshed, and it is showing all of the history for a totally different contact (Ray C.)  If I press to create new history for Ellis C. (who is showing in the contact pane), it tries to create a record for Ray C.

 

I've never actually viewed Ray C's contact record before.  Ray C. has a total of 14 history items dating back to 2002, and Ellic C. has zero history since I just created him.

 

Pressing F5 noticibly refreshes the history pane, but just presents Ray C's history again (Ellis C. still showing up top).  Waited 10 minutes, refreshed agian, same result.

 

Does this sound like IO lag, or "too much history"?   Same problem my other users are having.  The interesting part is that one of our remote users who uses a synced local database has observed the same thing.

 

I can't believe no one else is seeing this?  What could we be doing wrong?  According to my sales guys this has been going on for years and they just work around the issue.

 

-dan

Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Shown history does not change when switching contacts

Open the Demo database and test the behavior. This will help isolate the issue to program or data.

I see that the contact you mention has history going back to 2002 - so this database has been in use for at least 10 years. I would assume it has amassed a large amount of history (overall), which may be the root of the issue.

You can test if removing old history items (ex: anything older than 5 years) will help relieve the issue, by:
1. Create a copy of the database (File > Save Copy As)
2. Open the copy
3. Go to Tools > Database Maintenance > Remove Old Data
4. Remove History items older than 5 years
(accept prompt to reindex)
5. Close/Open database and test behavior.
6. If still occurs, repeat steps and remove old history items older than 4 years or 3 years... test

If the behavior improves, you can then implement it in the main database. You may want to make another copy of the database and call it 'ArchiveData' which would be accessible should you need to view the older history items.

Even if you don't create a copy of the main database for archive, always create a backup of the database before removing data (File > Backup > Database).
Greg Martin
Sage