Community
Showing results for 
Search instead for 
Do you mean 
Reply

Scheduling time off by one hour ACT! v16 for Web

New Member
Posts: 7
Country: USA

Scheduling time off by one hour ACT! v16 for Web

I thought I would start a different post, but with the same problem as another user.

 

We just purchased Premium v16 and are having the same issues with i07 devices...ipads and iphones.  We are in the US eastern time zone, have checked the time zone settings on our devices to make sure they match what is on the server...i.e.eastern time zone.  However, everything that is scheduled for, say 9 pm, shows up as scheduled for 8 pm on the iphones and ipads.  It shows up with the correct time, etc., if we look at it on the server itself or if we log in using Chrome or IE, it shows the activity at the correct time.  The time shows one hour off when using i07 only as best I can tell.

 

When accessing the server with Safari on a device that has iO7, on the logon screen, the time shows correctly at the top of the screen.  It is the appointment time that is one hour early.  If I create an appointment for 7 am, it will show in the calendar as being scheduled for 6 am.  If I log in with IE or Chrome, the appointment shows it is scheduled for 7 am...the correct time.

New Member
Posts: 7
Country: USA

Re: Scheduling time off by one hour ACT! v16 for Web

At a meeting this morning, a friend had an iphone with iOS6.  We used it to connect to our web server and all the scheduled events had the correct scheduled time.  Also, I installed Google Chrome on both an ipad and iphone with iOS7 and neither of them would work.  My only assumption is that is has to be something in the iOS7.

Platinum Elite Contributor
Posts: 6,652
Country: USA

Re: Scheduling time off by one hour ACT! v16 for Web

I have to suspect a bug in the IOS7 daylight saving time adjustment. The dates in ACT! are based on an offset from Greenwich. It would appear that IOS7 isn't applying the daylight saving time offset of one hour. This also explains why the ACT! people in Scottsdale aren't seeing the problem because Arizona doesn't switch to daylight saving time.

Roy Laudenslager
ACT! Certified Consultant
ACT! Report Expert
Durkin Impact Report Designer
www.techbenders.com
royel@techbenders.com
541-343-8129
New Member
Posts: 7
Country: USA

Re: Scheduling time off by one hour ACT! v16 for Web

Here is what I found that worked for me.  It appears to be an issue with the time zone in the new verison of Apple's operating system.  So, try this.  It worked for me.

 

On your iPad or iphone, go to settings, general, Date & Time.  Turn off "Set Automatically" and in the Time Zone, choose Happy Valley-Goose Bay.  This will move your clock up an hour on your device, so manually change your time back to current time.  Then, on your web server, change he time zone to Atlantic.  This will change your time, so manually adjust to the correct time.  This is in essence just changing your devices out of the daylight saving time zone.  After changing both the ipad or iphone and your server, log back iin using Safari and all should appear correctly.  It may not correct the previously scheduled activities (though it might) but it will correct the time issues with new appointments.

 

This seems to be an issue only with the daylight saving time zone.

 

Paul

New Member
Posts: 7
Country: USA

Re: Scheduling time off by one hour ACT! v16 for Web

I was continuing to work on this and had a thought.  If the problem is in iOS7 not having the correct setting for daylight saving time, then why not just leave the server in the correct time zone, but uncheck the option to use daylight saving time, etc.  Went back to the ipad and checked the scheduled time for appointments and all were correct.  I also logged into the database using IE and the scheduled time for appointments were also correct.  A simple fix.  Apple will eventually fix the daylight saving time issue, but untnil then, this works for me.

Copper Super Contributor
Posts: 85
Country: USA

Re: Scheduling time off by one hour ACT! v16 for Web

I still cannot get this to work. I'm in the Eastern time zone and all my appointments on ACT! for Web are one hour ahead.