Community
Showing results for 
Search instead for 
Do you mean 
Reply

Scheduled backup not writing to shared drive

Copper Contributor
Posts: 37
Country: United States

Scheduled backup not writing to shared drive

ACT! 2008 Premium.

 

ACT! scheduled daily backup errors.  "Cannot find (Shared) drive. (Drive path.)"

 

I have looked in setting up logon for Services.  Same issue either way.  Manual backups does write to shared folder.

 

Felix Trinh

Flexible Act Solutions, LLC

 

Felix Trinh
Flexible ACT Solutions, LLC
Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Scheduled backup not writing to shared drive

It sounds like there is an issue connecting to the shared drive at the time the backup is scheduled to run.  First, I would verify that the machine that the ACT!Scheduler is running on has full read/write access to that shared drive at the time the backup is scheduled.  Also, you may want to consider using a UNC path intead of a mapped drive path (if that is what you are using) when setting up the backup task in the ACT! Scheduler.

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

Copper Contributor
Posts: 37
Country: United States

Re: Scheduled backup not writing to shared drive

This does not work at all.  Path or via shared drive.  All permissions are there and available.  I do not think ACT! Scheduler can write to the shared drive.

 

Felix Trinh

Flexible Act Solutions, LLC

Felix Trinh
Flexible ACT Solutions, LLC
Nickel Contributor
Posts: 410
Country: Canada

Re: Scheduled backup not writing to shared drive

What happens when you back it up manually to the same destination?
Ken Quigley, BA, MCSE, ACC, APT
Toronto, Ontario
www.keystroke.ca
Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Scheduled backup not writing to shared drive

By default, the ACT! Scheduler service runs under a local system account on the machine it is installed on.  It may be that this account does not have access to the shared drive.  Try changing the account that Scheduler service runs under to an Admin account:

- Go Start/Run, type in services.msc

- When Local Services come, locate the ACT! Scheduler service

- Right-click on the service and choose Properties

- Go to the Log On tab and change the log in option to "This account" and put in an Admin login

- Stop and then restart the Scheduler service

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

Copper Contributor
Posts: 37
Country: United States

Re: Scheduled backup not writing to shared drive

I have done that going through services.msc.  It still does not work.

 

It only works manually to a shared drive.

 

I think the programmers need to test this out and take a look at the scenario of writing to the shared drive.  

 

Occurs the same was on ACT! 2008 and 2009.

Felix Trinh
Flexible ACT Solutions, LLC
Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: Scheduled backup not writing to shared drive

I do this all the time... the important thing to note is the account you use for the service must have full control to the database folder AND to the shared LAN folder.

 

Also, if the either drive is a mapped folder, it won't exist when not logged in... you need to use the UNC path (\\Server\Path) for both PAD and backup location