Community
Showing results for 
Search instead for 
Do you mean 
Reply

Schedule for Activities don't export from source database to new copy

JM
Nickel Contributor
Posts: 584
Country: USA

Schedule for Activities don't export from source database to new copy

Running Premium EX version 11.1 on Vista 32bit. First problem non of the schduled activities in contacts export from Old source into empty copy database. I came up with a lookup of tasks for all activities exported again those records after I changed Merge Options for History and Activities to Replcae with Source.

 

The problem with that is none of the activities with a Schedule For exported I had to change it to my user account.

JM

Moderator
Posts: 4,395
Country: USA

Re: Schedule for Activities don't export from source database to new copy

In order to retain record manager in a multi user database, identical users must exist in the databases.

 

How to Import a Multi-User Database and Retain the Record Manager in ACT!

JM
Nickel Contributor
Posts: 584
Country: USA

Re: Schedule for Activities don't export from source database to new copy

[ Edited ]

D.L.,

Thank you I should have used ID# 22050 for my multi-user DB not #14010, so I did not have to go through resetting the fields security access level for record manager to perform the export.

 

To expand on activity records in contacts not exporting into new DB. I think there is a bug with "On behalf of.." set in the activity.

I did have the record managers (users) imported into empty copy of DB and defined them in Manage Users.

I have 60 Contact records with a Scheduled Activities to a record manager (me), and 1 Contact record activity with "Scheduled For.." assigned "On Behalf of a record manager".

 

All 61 Contact records activities did not get imported the first time when I exported from Source DB all ACT records (contact, group, company, ect) into destination. It must have been I mixed up a step in removing the temp user record, or the fact that the Contact Merge Options suggested in ID# 14010 showing you don't need to change "Replace with newest" to "Replace with Source".  When I repeated the export of those 61 contacts in current lookup the Activities showed up in new DB with me as the record manager, but the 1 contact's activity with "On behalf of record manager.." still did not show up in the contact record activity tab or task list.

 

Reading ID 14010 again is it possible a third cause On Behalf of activity failed to export into a contact record because I did not login as that record manager to perform export of activities into new DB with them having behalf of activity? I hope not because that would be silly, and yet that is how I'm reading the below two comments (bullets). There should be an absolute Administrator that has rights to take care of all records even if private. You should make Admin's do it for each Record Manager because what if you have +6 record managers that's +6 exports.

  • ACT! Users with security level of less than Manager must be changed to Administrator or Manager in both the Source and Target databases to allow Private Contacts and Activities, for which they are the Record Manager, to be imported from (or exported to) the Target database.
  • Each User with Private Contacts or Activities must login to both the Source and Target databases to import or export their data.

 

 

 

It may help to update ID# 22050 adding the Contact Merge Options showing you should change Replace with newest to Replace with Source. If my findings are correct?

 

My last suggestion is make it more seemless for Multi-User with field having security access levels and teams setup in DB supported by ACT Admin's.  Since performing Save-As Empty Copy DB will come up again to resolve furture DB corruption which will continue to happen even if ACT! is rock solid.

 

JM

Message Edited by JM on 03-24-2009 11:13 AM