Community
Showing results for 
Search instead for 
Do you mean 
Reply

Sage doesn't recognize the structure of the Excel file it has exportted itselfs : all fields names become "glued" together by the import wizard

New Member
Posts: 30
Country: Belgium

Sage doesn't recognize the structure of the Excel file it has exportted itselfs : all fields names become "glued" together by the import wizard

Hello !

 

I've a problem to import an excel file into sage, although this excel file has been created by Sage itselfs with an excel export.
Sage does not recognize the different columns in the excel file.

 

Let met detail the procedure I followed :

  • I go to my company list in Sage. I click on the list with right mouse button and I select "Export to Excel". Everything works fine : the list is exported in excel and the field names appears correctly in Excel in the first line : "Nom" is in A1, "Type" in B1, "Addresse 1" in C1, "Code postal" in D1, ...
  • [optional] I add a line at the end of this file, with a new company name and "TESTS" words on the other columns.
  • I save the file as "IMPORT_TEST.XLSX". I close Excel.
  • In Sage Act!, I go to File > Import, select Excel in the list and browse to "IMPORT_TEST.XLSX". I click "Next".
  • Import Wizard (step 2 of 9) : Sage selects "Contacts records" but since this is a company list, I select "company records".
  • Import Wizard (step 3 of 9) : I select "custom import".
  • Import Wizard (step 4 of 9) : I check or uncheck "Yes, import the first record". That doesn't matter...
  • Import Wizard (step 5 of 9) : in the "Map from this field" column, I see only one line with : "Nom;Type;Addresse 1;Code postal;..."

Sage doesn't understand the structure of the file it has written itselfs. Why ??

 

I'm using Sage ACT! Premium 2012 Version 14.0.572.0 and Excel 2010, Windows 7 64 bits.

 

Thank you very much for your help !

 

Best regards,

 

Trucmuche

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Sage doesn't recognize the structure of the Excel file it has exportted itselfs : all fields names become "glued" together by the import

[ Edited ]

Hello Trucmuche,
I was not able to reproduce issue in the 14.0 or 14.1 versions of ACT! 2012 using Excel 2010. The issue may be with Excel or your Excel settings as it seems to be caused by an improper delimiter, possibly the colon. Try saving the file as. a csv and see if the issue happens. This may be a region-specific ACT! or Excel issue as well - I will see if I can find any information on this. I will also need to test this in additional environments.

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Sage doesn't recognize the structure of the Excel file it has exportted itselfs : all fields names become "glued" together by the import

[ Edited ]

I tested this issue in a Windows 7 64-bit environment and could not reproduce with ACT! 2012 versions 14.0 or 14.1.

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

New Member
Posts: 30
Country: Belgium

Re: Sage doesn't recognize the structure of the Excel file it has exportted itselfs : all fields names become "glued" together by the import

Hello Greig,

 

Thank you very much for your interest in my problem.

 

I have to beg you pardon... I tested these operations on a Win XP Pro XP3 operating system, and not on my other computer running Win7 64bits on which I'm writing my messages... I'm really sorry for the mistake...

 

I had problems to export from Excel 2010 to CSV to have a comma ' , ' as separator between fields. By default it was a semicolon ' ; ' and I had to search on the web to see how the delimiter could be changed. This was done in the control panel, regional and language options > Customize, List separator. But Excel still exports CSV with ' ; '. So I modified my CSV file by hand and replaced all ' ; ' by ',' and this time (I don't know why), Sage has imported my datas.

 

I don't know why it worked now because I tried this way 15 times before, with no success...

 

But the problem with Excel remains and importing directly from Excel would be really easier for me.

 

You mentioned regional parameters. My XP Pro is a french version, Excel too is french, and Sage is in English (Europe).

I tried of course to restore the default list separator ' ; ' in the control panel, but nothing seems to change...

 

Thank you very much for your valuable help... Please let me know if I could do something to help you track the problem...

 

Trucmuche