Community
Showing results for 
Search instead for 
Do you mean 
Reply

Sage Line 50 Integration Driver

New Member
Posts: 1
Country: United Kingdom

Sage Line 50 Integration Driver

[ Edited ]

Hi, I am running Sage ACT! Premium 2011 Version 13.0.401.0, Hot Fix 2 and Sage 50 Accounts Professional 2011 Version 17.0.15.208.

I am trying to link the two together by using the Sage Integration Driver, which is an extra download and *not* the link within the Tools menu called Accounting Integration Setup, as we are using a database that synchronizes with remote DB's.

When i log into Act i get the following two messages, every time.

1 - Sage Integration Driver - You have entered an invalid user name or password.
2 - An error occured while attempting to connect to home text/html. Please try again.

Then when i run the Sage Accounting Program Setup link, once Act has opened, i get another error message.

3 - Error HRESULT E_FAIL has been returned from a call to a COM component.

... and after putting in my sage details twice; as the first time, the Next and Finish buttons are greyed out until i do the exact same thing again I get...

4 - Object reference not set to an instance of an object.

...and it doesn't close the wizard. The only way to get out of the wizard is to click cancel which doesn't save any data. This has happened on every version of ACT we have had since 2008 and the only way we have got it to work in the past is to call support who fumbles around for anything up-to 2 hours deleting and adding users in sage and ACT only to accidentally stumble on a fix. Which doesn't work next time i reinstall ACT.

Does anyone have any clues as to how to get this working before i lose complete faith in this company and it's products, and advise my Directors to invest in something else?

 

Neil

Tuned Listener
Posts: 28
Country: UK

Re: Sage Line 50 Integration Driver

[ Edited ]

Hi Neil,

 

I've just had the same problem with Act 2012 and Instant Accounts and am amazed that there have been no replies to your question. I completely understand and share your frustration (that's putting it mildly) with Sage.

 

Following a 2.5 hour support call to Sage that mirrored your experiences, including adding new users, altering the UAC, rebuilding preferences etc, this is what solved the problem:

 

1. Go to the server that hosts the database and back it up from ACT

2. Run actdiag from the CLI

3. Check and repair the database

4. Run the database rebuild options in order (the last one removes the ACT integration links)

5. Open ACT and run the setup which should now work

6. Once linked choose the fourth option that scans the accounts program and rebuilds the links.

 

This is probably too late for you, but maybe it will help others.  I suggest you call Sage and double-check the above just in case there are differences for your installation.

 

What is really telling is that I asked the ACT support technician (who was very polite and patient) if they had a record of the error messages. I was told not, yet a quick Google of "Error HRESULT E_FAIL has been returned from a call to a COM component" and "Sage" brought up your post. Clearly ACT support do not read these forums, which I find inexcusable especially when we have to pay for a support contract on top of the software.

 

This follows three wasted days last week "upgrading" ACT 2011 to 2012 and moving to a new server.  The upgrade process didn't work and after much manual work I found that the new integration works in a completely different way and is useless for our purposes. Sage really need to sort this mess out.

 

HTH

 

Andrew