Community
Showing results for 
Search instead for 
Do you mean 
Reply

Sage ACT! 2012 SP1 update applied - sync still adds date/time to attachments

Copper Contributor
Posts: 133
Country: Canada

Sage ACT! 2012 SP1 update applied - sync still adds date/time to attachments

[ Edited ]

This didn't address the syncing of templates issue. In fact, I believe it is now worse than before, i.e.., duplicate, triplicate, quadruplicate, etc. files, appended file names (some have multiple appends), files that appear to be ACT system sync files.

 

It's also deleting files - some on the Publisher's end - some on the Subscriber's end...!

 

Now I have to keep a directory full of templates outside of ACT - not really ideal, is it?

 

What is going on with this Greg? I am so disappointed with my decision to upgrade from ACT 2010 at this point.

 

RDunlop

 

[Edit: Updated subject to match issue.]

Bronze Super Contributor
Posts: 1,170
Country: USA

Sage ACT! 2012 SP1 update applied - sync still adds date/time to attachments

[ Edited ]

Uh-oh.

 

 

 

[Edit: Subject updated to match issue.]

Copper Contributor
Posts: 133
Country: Canada

Sage ACT! 2012 SP1 update applied - sync still adds date/time to attachments

[ Edited ]

Greg, I'm willing to share my DB if you think that would help...rd

 

 

[Edit: Subject updated to match issue.]

Platinum Super Contributor
Posts: 5,275
Country: USA

Sage ACT! 2012 SP1 update applied - sync still adds date/time to attachments

[ Edited ]

RDunlop,

Can you provide a screen shot of the file names? 

 

Thanks

 

 

[Edit: Subject updated to match issue.]

Greg Martin
Sage
Copper Contributor
Posts: 133
Country: Canada

Sage ACT! 2012 SP1 update applied - sync still adds date/time to attachments

[ Edited ]

I cleared my template folders on both server and remote. I then added the exact same files to both directories, then ran a sync. The results are shown below:

 

After Sync (Remote).PNGBefore Sync (Server).PNGBefore Sync (Remote).PNGSync Results.PNGAfter Sync (Server).PNG

 

Thanks Greg,

Robert Dunlop

 

 

 

[Edit: Subject updated to match issue.]

Platinum Super Contributor
Posts: 5,275
Country: USA

Sage ACT! 2012 SP1 update applied - sync still adds date/time to attachments

[ Edited ]

Hey Robert,

I've been discussing this with some others and believe the issue is within the database itself.  What I'd like for you to do is the following:

 

1. Create a backup of both the main and remote databases.  We may have you send them in later.

 

2. Test the process with a new database:

 - Create a new database, enable sync.

 - Create a remote from the new database.

 - Unpack and restore it and sync (to ensure connection).

 - Update a template in the new remote.

 - Add a document to either of the new databases > sync > open the document in the remote and update/save it.

 - Sync. 

Does the template or document get renamed with the date/time stamp information?

 

 

 

[Edit: Subject updated to match issue.]

Greg Martin
Sage
Copper Contributor
Posts: 133
Country: Canada

Sage ACT! 2012 SP1 update applied - sync still adds date/time to attachments

[ Edited ]

I followed your steps below and everything worked beautifully - just as one would expect.

So how did my DB become corrupt? And more importantly, how would I diagnose and fix it?

 

Many Thanks...rd

 

 

[Edit: Subject updated to match issue.]

Platinum Super Contributor
Posts: 5,275
Country: USA

Sage ACT! 2012 SP1 update applied - sync still adds date/time to attachments

[ Edited ]

Robert - thanks for testing with the new database, that confirms that the issue is specific to the database.  The next phase is to attempt to correct your database. 

 

The next step is to test the synchronization with an 'Empty Copy' of your database.  The steps for this are:

- In your publisher/main database > go to File > Save Copy As > select 'Empty Copy' and provide a name. 

- Open the empty copy and create some test data/templates (doesn't have to be much).

- Enable sync in the Empty Copy and create a remote.

- Restore the remote > test sync to ensure connectivity

- Edit contacts/templates/attachments in publisher and remote databases

- Sync to test results

 

If the tests produce attachments with the date/time stamps, post back to let me know (do not perform the following steps).

 

If the tests are successful, the next steps are: 

- Perform a sync with the original main database and remote (to ensure all updates are in the main database).

- Create a new 'Empty Copy' of the original database

- Import all of the data from the original data into this empty copy. 

- Once the import is complete > create a new remote database and test syncing.

 

Depending on the amount of data in the original database, the import step could take several hours - that is why you want to test with the small empty copy before attempting the import.  It is also important to do the import before creating the remote (in the 2nd empty copy) because you don't want to try and sync all of the data to a basically empty remote.

 

For later use, these test databases can be deleted by: open the test database > go to Tools > Database Maintenance > Delete Database.  It will only delete the database that is currently open.  Having these test databases will not hurt the performance of ACT!, but certainly you want them cleaned up to reduce confusion later.

 

I know these steps can be annoying and time consuming; I appreciate your taking the time to go through them!

 

 

 

[Edit: Subject updated to match issue.]

 

Greg Martin
Sage
Copper Contributor
Posts: 133
Country: Canada

Sage ACT! 2012 SP1 update applied - sync still adds date/time to attachments

[ Edited ]

Okay - this will take some time so I'll get back to you ASAP...rd

 

 

 

[Edit: Subject updated to match issue.]

Copper Contributor
Posts: 133
Country: Canada

Sage ACT! 2012 SP1 update applied - sync still adds date/time to attachments

[ Edited ]
  1. I created a new empty copy of my original DB.
  2. I imported all contacts, companies, etc. from the original DBD to the new empty copy.
  3. After many hours ACT completed the import but with 5 errors similar to this example:.
  4.      Sage ACT! had difficulty merging the following records. For more information, click the  View article link below.
              An Activity failed to merge.
              Activity: Partners' Mtg
              Exception message: Object reference not set to an instance of an object.
     
  5. I opened the new DB and found right away that it has 14 less contacts, 1 extra group, i missing subgroup, 1 extra company, 1 missing division. My layouts are missing (but I assume I can copy these from the old DB). Also, I had to add the users again and after doing so, found that all of the imported calendar activities have been assigned to a single user. I assume this is because I added the users after the fact.
  6. I created the RDB and set it up on a laptop. First sync took a very long time but after it was done I compared the template folders on both server and laptop and found the files to be the same - no extra date/time stamps either.
  7. I cannot use this new DB. Is there a more detailed procedure for this?

Thanks...rd

 

 

 

 

[Edit: Subject updated to match issue.]