Community
Showing results for 
Search instead for 
Do you mean 
Reply

Sage ACT! 2011 PremReinstall SQL problems

Tuned Listener
Posts: 6
Country: United_Kingdom

Sage ACT! 2011 PremReinstall SQL problems

I have had the problem with SP1 breaking the link to Outlook and spent some time workking through the relevant knowledgebase article without success.  Talked to Support last week and after a while they suggested I remove every trace of ACT! and SQL completely and start again.  I removed using Add/remove programs (Windows XP Pro SP3) and attempted to remove SQL Server 2008 R2 but this failed.  Then manually removed (using the knowledgebase article) everything I could find.

 

I reloaded ACT! and it now falls over with the error message "SageACT! Pre-Requisite has encountered an error and needs to close".  I have assumed this is a SQL problem and tried to manually create the SQL instance.  In KB artilcle 26994 - it finishes Stage 8 (Setup Support Files) and then just stops.  I down loaded a new copy of  SQLEXPR32_x86.exe from the MS site and have tried this again.  I have also run the .NET 3.5 SP1 but no luck.  Before I hit the beer does anyone have a clue where I should look next?

 

Help!

Robin Gray
Small Business Software Solutions
Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Sage ACT! 2011 PremReinstall SQL problems

Hello Robin,

Welcome to the Sage ACT! Community. If the problem, is with the system checker the you can disable that for the installation. If installing from a disk, then copy the installation folder ACTWG from the disk to a location on your hard drive. If installing from a download then open the ACTWG folder. In this folder, open the Dependencies directory, then locate the PreReq folder and rename it to PreReqOLD. Then browse to the setup.exe file and double-click it to run the installation.

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

Tuned Listener
Posts: 6
Country: United_Kingdom

Re: Sage ACT! 2011 PremReinstall SQL problems

Thanks Greig for your quick reply.  Did what you said and ACT! appearred to load.  On trying to create a database I get "The SQL Instance is unavailable"  So tried to  manually set it up using KB26994.  Got as far as Satge 17 Installation prgress and for a while thought I was winning.  It didn't finish and returned "Database Engine Services - Failed".  Looked at the summary log and it just said "SQL Server installation failed. To continue, investigate the reason for the failure, correct the problem, uninstall SQL Server, and then rerun SQL Server Setup" but did give me the name of the log with the failure.   sql_engine_core_inst_Cpu32_1.log - as below - about half way down there is something about  MSIINSTANCE requires a new instance that is not installed - No idea what this means.

 

=== Verbose logging started: 03/01/2011  16:40:13  Build type: SHIP UNICODE 4.05.6001.00  Calling process: C:\Program Files\Microsoft SQL Server\100\Setup Bootstrap\SQLServer2008R2\x86\setup100.exe ===
MSI (c) (EC:F4) [16:40:13:906]: Resetting cached policy values
MSI (c) (EC:F4) [16:40:13:906]: Machine policy value 'Debug' is 0
MSI (c) (EC:F4) [16:40:13:906]: ******* RunEngine:
           ******* Product: C:\ACT_Premium_2011\Dependencies\SQL Express 2008 R2\x32\x86\setup\sql_engine_core_inst_msi\sql_engine_core_inst.msi
           ******* Action:
           ******* CommandLine: **********
MSI (c) (EC:F4) [16:40:13:906]: Client-side and UI is none or basic: Running entire install on the server.
MSI (c) (EC:F4) [16:40:13:906]: Grabbed execution mutex.
MSI (c) (EC:F4) [16:40:13:906]: Cloaking enabled.
MSI (c) (EC:F4) [16:40:13:906]: Attempting to enable all disabled privileges before calling Install on Server
MSI (c) (EC:F4) [16:40:13:906]: Incrementing counter to disable shutdown. Counter after increment: 0
MSI (s) (44:9C) [16:40:13:937]: Running installation inside multi-package transaction C:\ACT_Premium_2011\Dependencies\SQL Express 2008 R2\x32\x86\setup\sql_engine_core_inst_msi\sql_engine_core_inst.msi
MSI (s) (44:9C) [16:40:13:937]: Grabbed execution mutex.
MSI (s) (44:90) [16:40:13:953]: Resetting cached policy values
MSI (s) (44:90) [16:40:13:953]: Machine policy value 'Debug' is 0
MSI (s) (44:90) [16:40:13:953]: ******* RunEngine:
           ******* Product: C:\ACT_Premium_2011\Dependencies\SQL Express 2008 R2\x32\x86\setup\sql_engine_core_inst_msi\sql_engine_core_inst.msi
           ******* Action:
           ******* CommandLine: **********
MSI (s) (44:90) [16:40:13:953]: Machine policy value 'TransformsSecure' is 0
MSI (s) (44:90) [16:40:13:953]: User policy value 'TransformsAtSource' is 0
MSI (s) (44:90) [16:40:13:953]: Machine policy value 'DisableUserInstalls' is 0
MSI (s) (44:90) [16:40:13:953]: Specified instance {B5153233-9AEE-4CD4-9D2C-4FAAC870DBE2} via transform :InstID01.mst;:InstName02.mst is already installed. MSINEWINSTANCE requires a new instance that is not installed.
MSI (s) (44:90) [16:40:13:953]: MainEngineThread is returning 1639
MSI (s) (44:9C) [16:40:13:953]: User policy value 'DisableRollback' is 0
MSI (s) (44:9C) [16:40:13:953]: Machine policy value 'DisableRollback' is 0
MSI (s) (44:9C) [16:40:13:953]: Incrementing counter to disable shutdown. Counter after increment: 0
MSI (s) (44:9C) [16:40:13:953]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2
MSI (s) (44:9C) [16:40:13:953]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2
MSI (s) (44:9C) [16:40:13:953]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\InProgress 3: 2
MSI (s) (44:9C) [16:40:13:953]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\InProgress 3: 2
MSI (s) (44:9C) [16:40:13:953]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied.  Counter after decrement: -1
MSI (s) (44:9C) [16:40:13:953]: Restoring environment variables
MSI (c) (EC:F4) [16:40:13:953]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied.  Counter after decrement: -1
MSI (c) (EC:F4) [16:40:13:953]: MainEngineThread is returning 1639
=== Verbose logging stopped: 03/01/2011  16:40:13 ===

 

 

Thanks again

Robin  Gray

Robin Gray
Small Business Software Solutions
Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Sage ACT! 2011 PremReinstall SQL problems

[ Edited ]

Let's make sure the ACT instance of SQL is installed and running:

- Click your Windows Start button

- From the Start menu, either click Run (Windows XP) or go to the Search box (Windows Vista, Windows 7)

- Type in services.msc and press Enter

- When the services list comes up, locate the service SQL Server (ACT7)

- Right-click on the service and select Start or Restart (whichever is not grayed out)

 

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

Tuned Listener
Posts: 6
Country: United_Kingdom

Re: Sage ACT! 2011 PremReinstall SQL problems

No - not there - it never got created.  Only 3 SQL entries.  The ACT7 Instance is not there.

 

SQL Active Directory Helper service   Not started, Disabled

SQL Server Browser  Not Started, Automatic

SQL Server VSS Writer  Not Started, Automatic

 

 

Robin Gray
Small Business Software Solutions
Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Sage ACT! 2011 PremReinstall SQL problems

OK. First try starting the SQL Browser and SQL VSS Writer services (right-click on them and select Start). Then do a manual install of the ACT7 SQL instance. instructions for this are in KB Article 26994.

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Sage ACT! 2011 PremReinstall SQL problems