Community
Showing results for 
Search instead for 
Do you mean 
Reply

Restore failed and database status remains on 'restoring'

New Member
Posts: 2
Country: United Kingdom

Restore failed and database status remains on 'restoring'

ACT! Professional for Workgroups 8.0 Version 8.0.2.82

 

Hi,

I had to restore a database using yesterday's backup.

I locked act! and selected 'restore' as i wanted to replace the current db.

It failed saying that it is not restoring on the same computer! Which is strange as the backup being done on this computer and the zip file put in a folder next to the db.

Anyway i tried to 'restore as' but no luck. Several similar error messages: 'The application has encountered an error and has been shut down. Would you like to report the error?' and after several of these came a timeout error msg.

I then tried several other backups from November 23rd and same result.

So i suppose they are all somehow corrupt :-(

Unzipping the zip file was ok though.

 

And my questions would be:

- Is it possible to reset the status 'restoring' visible from act8diag? I tried an check and repair but both mentioned that it is not possible as being in the middle of a restore. I didn't try unlock as i don't know what will then happen to the db.

- Is there a way to force manually the restore using some files from the backup, say to use from the zip in the 'backup' folder 2 files to regenerate manually the adf and alf? 

- If the 'restore as' was to work, what will happen to the users: those who are using the sync and those who have local act! email?

 

Thanks for your help.

 

Nickel Super Contributor
Posts: 441
Country: UK

Re: Restore failed and database status remains on 'restoring'

1. I have never encountered this but I would try detaching the db from actdiag before running the restore if it has got stuck.  You may need to reattach it by opening the .adf with act before running the restore.

2. There is a way but you would need an ACC as this requires an extra utility.

3. A restore as will reset any sync info.  New remotes would have to be created.  Local act email should be stored on an email db on their machines.

 

Good Luck

 

Tom

New Member
Posts: 2
Country: United Kingdom

Re: Restore failed and database status remains on 'restoring'

Thanks Tom for your reply.

I contacted the day before yesterday act! support and they were helpful in the process of finding what has happened.

- The backup files were actually not corrupt as i was asked to restore from another computer than the server. It worked without any error

- Hence, the act! / sqlserver on the server were corrupted (no idea how)

- So i was told to uninstall act! / sqlserver

- The reinstallation was ok, then a restore with the day before backup was ok

- Had done some further cleaning repair because the ALF was 17GB (which after came to 3M)

- And indeed as you said, the sync users had to have their rdb redone and no email were lost. Few people had to reenter the data since the last update but luckily not much done

Today, i finalized it and everyone is back on track and act! too.

 

And now i have a better idea of how act! is working and almost ready for any crisis ;-)

 

Thanks again.

 

Status = solved.