Community
Showing results for 
Search instead for 
Do you mean 
Reply

Remove dashes from Number

Copper Contributor
Posts: 77
Country: USA

Remove dashes from Number

[ Edited ]

All,  I have several thousand county parcel numbers that contain dashes 123-456-789.    I need to remove these dashes, en mass.  

 

  1. Change Parcel Number to a Numeric field does now work.   Tried several times and it always comes back with “Failed to change the Specified Field”.
  2. Make a New field (Numeric) and Copy old parcel number to this new field, does not work either, gives me the same “Failed to change the Specified Field” each time.

Anyone have any suggestions?    Jim

 

Administrator
Posts: 4,024
Country: United_Kingdom

Re: Remove dashes from Number

Hi Jim,

Please could you let us know what version of Act! you're using?
Could you list the exact steps you're taking in your 2nd scenario, and when exactly the error occurs. If you could record a screen capture of this happening, this would be rather useful.

In regards to manipulating the data to remove the dashes, this would not be possible by just using Act. changing a Character field containing a value like this to a Number field would cause the field data to be deleted. You would need to export the data, manipulate it to remove the dashes using something like Excel, then re-import the data. Remember to export extra fields you can match the parcel numbers with the correct contacts.
Copper Contributor
Posts: 77
Country: USA

Re: Remove dashes from Number

Gary,

 

"Could you let us know what version of Act! you're using?"  Act! Ver 18 Premium


"Could you list the exact steps you're taking in your 2nd scenario, and when exactly the error occurs."     Gary, exactly that, I just created and new Parcel Number field and then used the copy feature trying to copy from the original Parcel Number field to the new field.

 

"In regards to manipulating the data to remove the dashes, this would not be possible by just using Act."       Appears to me that within ACT it just is not going to work. 

 

I dont think I want to use the Excel feature,  If the contacts/parcel numbers do not import exactly, then I'll have an even bigger mess on my hands.   Thanks Jim

Copper Contributor
Posts: 29
Country: USA

Re: Remove dashes from Number

My company, DesignR1, has a product called Swiss Army Knife which is meant for exactly this sort of thing.  I just tested it by copying phone numbers into the User1 field in the demo database and then removing the dashes from User1, and it worked great.  Here is the configuration I used:

 

SAK-ReplaceDashes

 

(Note that the last box is empty.  In this case, we're replacing the dashes with nothing.  You could replace them with spaces, or commas, or whatever else.)

 

The trial will only allow you to change up to 20 records at a time, so just be aware of that limitation.  You can download it from http://www.designr1.com/shop/swiss-army-knife-2/

Administrator
Posts: 4,024
Country: United_Kingdom

Re: Remove dashes from Number

Hi JIm,

Importing data into Act! and merging it with existing records isn't particularly complicated. The following Knowledgebase article walks you though the process: http://kb.act.com/app/answers/detail/a_id/26828 Look for the section titled "Choosing the Custom option".

Once you've got your parcel numbers without dashes into Act!, you can set the options of the character field in Tools > Define Fields to only accept numbers going forward. This is done by entering # characters (one for each number) in the Field format box.

If you need help with this, and have a support subscription, our support team can help you though the process.
Copper Contributor
Posts: 77
Country: USA

Re: Remove dashes from Number

Gary,

 

I've imported Excel files into Act dozens of times. This needs to be exact so that I don't add more contacts records on the re-mport.  Today I did export about 1900 act contacts into Excel.    In Excel I have the parcel number that contains the hyphens in one of the column.   I then created a duplicate column just to the right of this first column and copied all of the parcel numbers to that column, Parcel2.    Then I removed the hyphens from that second column.   I did not remove column containing the original parcel number with the hyphens, I wanted to use that as my duplicate checking field on the re-imported.    I re-imported the numbers into ACT using a newly created  Parcel2 field in Act.   So now I imported the original parcel number (containing the hyphens) and a second parcel field containing the corrected number (without the hyphens).    Then I simply copied the Parcel2 to to my original parcel number field, seemed to work perfect.   Thanks for helping.  Jim