Community
Showing results for 
Search instead for 
Do you mean 
Reply

Rebuild OLE/DB Reporting objects gives error

Loyal Listener
Posts: 42
Country: United_Kingdom

Rebuild OLE/DB Reporting objects gives error

I consistently get this error message, what does it mean please?

Incorrect syntax near 'MANAGER'.
PRC_REPORT_MAKE_TABLEFUNCTIONS:  ERROR OCCURRED TRYING TO CREATE/ALTER BASE FUNCTION
The number of orphaned users fixed by updating users was 0.
The number of orphaned users fixed by adding new logins and then updating users was 0.
The number of orphaned users fixed by updating users was 0.
The number of orphaned users fixed by adding new logins and then updating users was 0.
The number of orphaned users fixed by updating users was 0.
The number of orphaned users fixed by adding new logins and then updating users was 0.
The number of orphaned users fixed by updating users was 0.
The number of orphaned users fixed by adding new logins and then updating users was 0.
The number of orphaned users fixed by updating users was 0.
The number of orphaned users fixed by adding new logins and then updating users was 0.
The number of orphaned users fixed by updating users was 0.
The number of orphaned users fixed by adding new logins and then updating users was 0.
The number of orphaned users fixed by updating users was 0.
The number of orphaned users fixed by adding new logins and then updating users was 0.
The number of orphaned users fixed by updating users was 0.
The number of orphaned users fixed by adding new logins and then updating users was 0.
*** Setting rights on procedures...
*** Setting rights on tables and views...

 

Running Act 2010 sp1 hot fix 1

TIA

Paul M Tate
Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Rebuild OLE/DB Reporting objects gives error

This error is database specific and is a sign that the OLE/DB report objects are corrupted within the database.  With Act! 2010 the OLE/DB V2.0 reporting tool is provided and does everything the base OLE/DB tool does, and give access to additional database tables. 

If you would like to try and resolve the error you can create an Empty Copy (File > Save Copy As > Empty Copy) of your database and test the Rebuild OLE/DB option on the Empty Copy.  If it is successful, you would then import your original database into the new copy. 

Note: The import may bring the issue to the new database.

Greg Martin
Sage
Loyal Listener
Posts: 42
Country: United_Kingdom

Re: Rebuild OLE/DB Reporting objects gives error

This is ACT 2010 premium sp1 hf1

 

I created an empty db from the main one and it like the others, after running rebuild schema, passes OLE/DB V2.0 reporting tool rebuild but alas fails the basic one.

 

Does the fact that it passes the v2 one mean it is ok and that the basic one fails as the db is 2010?

 

Would creating an empty db manually and importing still have the risk of bringing the error across?

 

 

TIA

Paul M Tate
Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Rebuild OLE/DB Reporting objects gives error

Just having Act! 2010 installed isn't the culprit, but having 2010 installed gives you the 2 different methods of making an OLE/DB connection.  So, the failure of the regular OLE/DB rebuild won't prevent you from making a connection - you'll just need to use the OLE/DB V2 option. 

 

Since the Empty Copy failed the OLE/DB Rebuild also, it tells us the problem is in the structure of the database.  If you create a new database and import the original data, it may correct the issue but there is a chance of importing the problem.  Unfortunately the only way to know for sure is to go through the steps. 

Greg Martin
Sage