Community
Showing results for 
Search instead for 
Do you mean 
Reply

Problems upgrading to 10.0.2 from 10.0.0.237

Copper Contributor
Posts: 20
Country: Canada

Problems upgrading to 10.0.2 from 10.0.0.237

I am currently in the middle of upgrading to 10.0.2 but am having a few problems upgrading network sync on the main server. To start with I couldn't find the Network sync install files on the ACT website so support sent me a link to the full version of 10.0.2 which they said does contain the new 10.0.2 network sync file so I downloaded it and found the install files for the 10.0.2 NS and tried to install them but after starting the service the old version number still appeared in the about box for the NS. I first tried a repair, and then tried the uninstall and reinstall but for some reason the version remained at 10.0.0.237. Any ideas?
 
The other issue that was somewhat perplexing occured on a remote users machine, after upgrading and starting the database for the first time it came witha  message saying the Adminstrator had locked the database could not log in or something close to that. I tried to login using the Admin user and password but I received the same message.
 
Thanks,
Wayne
Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: Problems upgrading to 10.0.2 from 10.0.0.237

You might need to uninstall ACT! and reinstall this way and see if it helps:
Backup the databases first.
Uninstall any version of ACT! from Windows Control Panel | Add/Remove Programs
Use the Uninstaller.exe from the ACT! KB 19338 (the exe, not the manual uninstall)
Uninstall .Net Framework (all versions) - this does NOT apply to Vista users as .Net 2.0 is part of the OS and can't be uninstalled
Uninstall any MS SQL items from the Control Panel if istill there
Uninstall MSXML Services from Control Panel if it's still there
Perform a Selective restart with MSCONFIG as per ACT! KB 14499
Install .Net 2.0 Framework from MS web site (only for XP, not Vista)
http://www.microsoft.com/downloads/details.aspx?familyid=0856eacb-4362-4b0d-8edd-aab15c5e04f5&displaylang=en
Manually install MS SQL as per ACT! KB 19386
Install ACT! 10.02 from the download
Restore from Selective Startup Mode with MSCONFIG
Reboot
 
What's the "exact" error?
It might be because you're changing stuff on the server. You should finish that first
Copper Contributor
Posts: 20
Country: Canada

Re: Problems upgrading to 10.0.2 from 10.0.0.237

Would you still advise a complete uninstall and reinstall if everything else upgraded perfectly. The only thing left is the Network Sync and that one remote user. Once I opened the database on the server it upgraded the database without any issues so I'm really hesitating to remove everything and starting from scratch but if you think its the only way to get the Sync upgraded I'll go ahead.
 
 
Regarding point 2 I cant give you the exact message until Monday.
 
Best,
Wayne
 
Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: Problems upgrading to 10.0.2 from 10.0.0.237

From this ACT! Knowledge Base article - http://tinyurl.com/3ftw3e
 
Synchronization Services
If synchronization is employed, and any users are on version 10.0.2, the sync service must be upgraded.

Note: Updated Sync Services are included in the full ACT! 2008 (10.0.2) product download.
Copper Contributor
Posts: 20
Country: Canada

Re: Problems upgrading to 10.0.2 from 10.0.0.237

Thanks for your help.
 
Just a follow up on these 2 issues. Was able to solve both problems, the issue relating to network sync version was of my own doing (you dont want to know), the second issue regarding the locked remote user database was solved by by unlocking the databaes using the ActDiag utility. Start->Run->ActDiag
 
Regards,
Wayne
 
Copper Contributor
Posts: 156
Country: USA

Re: Problems upgrading to 10.0.2 from 10.0.0.237

Thanks for coming back and letting us know what worked for you. Smiley Happy