Community
Showing results for 
Search instead for 
Do you mean 
Reply

Problem with Act Premium website

Astute Commentator
Posts: 54
Country: USA

Problem with Act Premium website

We ran into a problem with our Act server yesterday.  It's almost as if IIS crashed on the server.  There was a period of 20 minutes of 100% cpu usage (normally it's about 6% under normal usage).  After that the Act Web API website was not showing (https://servername/act.web.api).  Also our custom app that talks to the api was no longer able to log in.  Throughout this time normal act client usage with the desktop client continued to work fine, except people reported sluggish performance in the time period where the server cpu was at 100%.  After business hours, I rebooted the Act server, and all web services continue to be normal so far.

 

Before the reboot last night, I opened the Website administration section of Act Premium, and got this error message:  The Asp.net process account does not exist or is not configured properly.  See the Troubleshooting appendix in the Act! Premium Administrator's Guide for assistance.

 

Here is what the guide says:

 

Causes:

- The ASP.NET service is not available.

- Non-default IIS settings, such as an assigned IP address or host headers, are configured.

- Read permissions are not set.

 

Since no configuration was changed on the server, I assume that the cause is the first one, but what could cause asp.net services to not be available?  Thanks!

 

 

- Version of Act! you are using:

On Windows 10 workstations:  Act Premium 21.1.187.0 , Update 4

On Windows 2016 Server:  Act Premium Web 21.1.187.0 , Update 4

 

- If the issue involves Microsoft Office (Outlook, Word , Excel), state the version of Office you are using

Office 2016

 

- Is your database on your local machine (private database) or is it being shared from a server (shared database)?

Shared from a server.

 

- Operating system you have Act! installed on (i.e., Windows 7, Windows 8)

Windows 10 on the workstations.  Windows Server 2016 on the Act server.

 

Silver Super Contributor
Posts: 2,206
Country: United_Kingdom

Re: Problem with Act Premium website

[ Edited ]

Before looking any further check your windows system updates to see if windows sent any critical updates that coincide with the problem.

 

If so the reboot will probably have resolved the issue.

Astute Commentator
Posts: 54
Country: USA

Re: Problem with Act Premium website

Thanks for your reply.  No Windows updates had been done recently.  They are done manually on a schedule.  So it continues to be a mystery.  Luckily after the reboot, everything is working normally.