Community
Showing results for 
Search instead for 
Do you mean 
Reply

Premium 2010 Hotfix 3, Still encountering bug(s)

New Member
Posts: 3
Country: United States

Premium 2010 Hotfix 3, Still encountering bug(s)

I am not sure these have been posted anywhere...

 

but I am finding several bugs persisting even after applying Hotfix 3 of 2010 Premium

 

1. Client install on 64-bit server Windows 2003 R2, Fails... never finishes it reaches the "Finalizing Installation" phase and hangs for hours, tried this many times. Have to arbitrarily cancel, which leaves ACT! "installed" but does not show in the installed programs list, and several other things left unfinished, like installing the ACT Scheduler service... (The scheduler service I tried to fix manually via the articles in the KB online here, but they are 32bit specific, not helpful for 64 bit.)

 

1b. 64 bit client related issues. I constantly receive random GDI Errors on the 64 bit client, even after Hotfix 3 is installed.

 

 

2. Lookup by example: Several issues.

For some users just refuses to work at all, errors out when you click on search after filling in criteria.

 

Another issue, for any user that has a read-only security level on a field in the form they are using, they are not allowed to use that field in a "Lookup By Example" at all... e.g. the field is locked in the Lookup by example form... which is not logical, if I have read-only access to the field, it means I can see the information, so I should be able to search on this information too, correct?

 

 

3. Pick-List problems:

For pick lists that are defined as "non-editable" by users, it is showing "Add List Values" at the bottom of every pick-list... and proceeds to bring up the pick-list editor if clicked. I have almost all my essential status fields driven from locked pick-lists, and this is causing great confusion for my users.

 

Other problems I have noticed, if I have changed the font type on a field that has a pick-list, e.g. made it bold or larger font than default, the pick-list that displays, truncates data because it does not seem to adjust for the non-standard font size... which makes the list unreadable.

 

4. Field name display too short in ACT forms... anywhere it is shown (Any place in ACT! where I can select a field) the width is not large enough to accomodate long field names as allowed by the "Create/Edit Fields Option". For instance in the Advanced Lookup, when I need to select a field, some of the field names are too long to fit in the pick list width that is defined here, so I can not see the fields...everywhere that I can select an ACT! field from a pick-list, this should accomodate the long field names, as this is a constant headache dealing with ACT! databases that have long field names. Or, limit the field name when creating or editing fields, so that it always fits in these pick-lists.

 

I understand that I could go back and rename all my fields to be shorter, but I have well over 200 custom fields and a naming scheme that was inherited from other databases, that I would prefer to adhere to. 

 

 

Is anyone else experiencing these issues? 

Have workarounds or known fixes for the issues here?

Moderator
Posts: 4,395
Country: USA

Re: Premium 2010 Hotfix 3, Still encountering bug(s)

None of these issues you listed are addressed by the hot fixes.  Please review the thread below for issues the hot fix addressed.

 

1. The the install halts at finalizing installation, is there any CPU activity in task manager?  If so, which processes?  If theres any antivirus/spyware programs installed, try temporarily displaying uninstall ACT! is installed.

 

2. Is the GDI issue specific to one computer or all 64bit clients?  What is the user doing in ACT! before the error appears?  Are there a lot of fields/labels added to the layout?

 

3. Based on the information provided, your issue appears to be associated with a previously reported issue.

 

4. I will report it as an issue for further research.

 

http://community.act.com/sage/board/message?board.id=Prem&thread.id=12569

 

 

New Member
Posts: 3
Country: United States

Re: Premium 2010 Hotfix 3, Still encountering bug(s)

David, thanks for the reply.

 

to answer your questions.

 

1. The install was on the 64 bit Windows 2003 R2 Server that hosts the database for the company... the only other process that runs here, is SQL Server 2005 and basic server functions... no Antivirus or Antispyware clients running on that machine. After the install froze... and finding no solutions in the KB... I uninstalled ACT! 2009 Premium completely, and tried again... same thing, froze in the "Finalizing Installation" step. At which point, it had now disabled my ACT7 instance, made it unusable... which left me in the position of having to uninstall the ACT7 Instance manually, via registry editing (long unpleasant process) and then setting up the ACT7 instance again manually. And then once again trying to install ACT! 2010 Premium (Client) on this machine. And once again it failed at the same place ("Finalizing Installation")  ... but I took a hunch that it was actually "mostly installed" and just killed the task, and now I am running that client on that machine, mostly without incident, except that now it GDI crashes a lot.

 

The other problem I have related to this, is that the ACT Scheduler service did not install correctly, and I followed the ACT KB article on manually getting it running, only to understand after the fact that all the manual registry keys provided in the KB article download assumed 32bit Program Files environment, not 64 bit.

 

GDI Error: Seems to happen just after an amount of time... a lot of the times, I will just let the machine sit, sometimes I am running manual backups (since the scheduler service is dead here) but yes, usually the form being displayed is heavy with custom fields for sure.

 

Pick-List issue(s), I was hopeful recent Hotfix addressed this, since I saw that it updated the Pick-List library during install. The non-standard font display issue had always been a bug at least since 2009, but version 2010 introduced the bug of always showing "Edit List Values" even on a non-editable pick-list.

 

I am usually very patient about waiting for these things to be addressed, but I thought after living with a few of these for over a year, and seeing new minor bugs introduced with the most recent version, I would speak up to make sure there was some awareness.

 

Thanks for your efforts!

 

-Jeff