Community
Showing results for 
Search instead for 
Do you mean 
Reply

Phone Number Format

Accepted Solution Solved
New Member
Posts: 27
Country: USA
Accepted Solution

Phone Number Format

[ Edited ]

 

Version: ACT! by Sage Premium for Workgroups 2007 (9.0) (ST Edition) Version 9.0.0.557

Windows XP Pro SP2

MS Office 2003 SP2

 

Configuration: One main database, 10-15 remote synchronizing databases, 40 users.

 

I recently posted regarding the phone number formatting and how you can attempt to standardize. The following shows you how to apply a format to a field for multiple records:  LINK

 

I followed the instructions (several times) but to no avail. For instance, I copy the phone number field to the user 9 field- works fine. I then replace the data in the phone field assigning the format United States [1], %%%-%%%-%%%% and replace with empty data. Still, when I click on the elipse to see the formatting after it completes it brings up USA[1] with the only option being Free Form.

 

I have also proceeded to replace the data in the phone field after applying the format but no different result.

 

I can even go in and change the format, exit Act and then go back in and the only option for formatting I'll see is USA[1] - Free Form.

 

Not really sure what is going on...any thoughts are appreciated.

 

{link embedded}

Message Edited by tashina on 06-25-2008 05:12 PM

Accepted Solutions
Solution
Accepted by topic author dalejackson
‎09-25-2015 03:20 AM
Platinum Elite Contributor
Posts: 14,387
Country: Australia

Re: Phone Number Format

It sounds like you have something odd in the Windows registry. ACT! takes the country list for the phone field from this reg key:

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Telephony\Country List]

 

Each sub-key concerns one specific country code. For example, if you have a look at
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Telephony\Country List\61], you'll see that this key has the data for Australia (there is a string value called "name" with the name of the country).

 

 So, you might have a look at:[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Telephony\Country List\1]

 

Make sure that the "Name" field says "United States" and not "USA"

 

Also, make sure the value in the pull-down list for the Country field says United States 

View solution in original post


All Replies
Platinum Elite Contributor
Posts: 14,387
Country: Australia

Re: Phone Number Format

Have you tried bringing up the phone format box, clicking Edit Formats.

 

Make your preferred format the default... and try deleting the others including Free Form from the list?

 

Then do the items in that list

New Member
Posts: 27
Country: USA

Re: Phone Number Format

Well, if I go into, for instance, the phone number field and go into the phone number format options, USA[1] is selected for Country, Free Form is select for Format and the number (if there is one) is xxx-xxx-xxxx. If I click Edit Formats, the only option I see is Free Form and it cannot be deleted. If I go back and choose United States[1], the format changes to %%%-%%%-%%%% (which is what I want) and the number still looks like xxx-xxx-xxxx if there is one. I click ok and all looks good.

 

If I go into Edit Formats again I see Free Form, %%%-%%%-%%%%, and (%%%)-%%%-%%%%. The second one is selected as expected. I can click on the third one (%%%)%%%-%%%% and delete it but none of the others allow delete (grayed out).

 

Now, if I exit Act and go back in, it is as if I did not do anything and USA[1] is selected again with only Free Form available.

 

Thanks for your help.

Solution
Accepted by topic author dalejackson
‎09-25-2015 03:20 AM
Platinum Elite Contributor
Posts: 14,387
Country: Australia

Re: Phone Number Format

It sounds like you have something odd in the Windows registry. ACT! takes the country list for the phone field from this reg key:

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Telephony\Country List]

 

Each sub-key concerns one specific country code. For example, if you have a look at
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Telephony\Country List\61], you'll see that this key has the data for Australia (there is a string value called "name" with the name of the country).

 

 So, you might have a look at:[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Telephony\Country List\1]

 

Make sure that the "Name" field says "United States" and not "USA"

 

Also, make sure the value in the pull-down list for the Country field says United States 

New Member
Posts: 27
Country: USA

Re: Phone Number Format

Setting the Country drop-down was it. Somehow, it had been changed to USA from United States. I changed it back in the drop-down and changed all the USA values to United States and it seems to be working as expected now.

 

Thank you!

Platinum Elite Contributor
Posts: 14,387
Country: Australia

Re: Phone Number Format

Yup, the list in Country Field needs to match the Name key in the Registry for it to work.
New Member
Posts: 4
Country: United States

Re: Phone Number Format

Dear Mike,

 

thanks for the hint to the country list in the Windows registry. However, I have one problem with the Netherlands: In ACT the country field is named "The Netherlands" but Windows puts it as "Netherlands, The" - so the country field is not mapped against the country list from Windows. This means that by default a new contact in the Netherlands always has the country code [1]. Only by manually changing each phone and fax number to "Netherlands, The" does the correct [31] show up.

 

Do you have any suggestion for how to best address this issue?

 

Thanks and best regards from Brussels

Uwe Trenkner

Platinum Elite Contributor
Posts: 14,387
Country: Australia

Re: Phone Number Format

Either change the entry in the Windows registry or change the pull-down in ACT! for Country - they need to match
New Member
Posts: 5
Country: United States

Re: Phone Number Format

Similar problem.

Act 10.0.3.182 installed on a Windows 2003.

Few users that run the application from the server (in a terminal server mode) get [1] (.) in the phone and fax number fields.

However when the user who enter the dats connects, she gets all the phone and fax numbers fields correct. Any idea?

 

Thanks,

 

Eyal USA 

Platinum Elite Contributor
Posts: 14,387
Country: Australia

Re: Phone Number Format

Check the registry settins as per the above posts... the name in the registry needs to match the name in the country field.