Community
Showing results for 
Search instead for 
Do you mean 
Reply

PRIMARY file group is full error

New Member
Posts: 1
Country: USA

PRIMARY file group is full error

Hello,

I'm running into a DB issue in ACT Premium, we're running Premium 2010 Version 12.0.409.0, Hotfix 3.  First we'd noticed that imports were failing without explanation, so I tried to repair and reindex the database, and get an error to the effect of:

 

Could not allocate space in database 'ourdatabasename' becuase the 'PRIMARY' file group is full. Create disk space by deleting unneeded files, dropping obects in the filegroup, adding additional files to the filegroup, or setting autogrowth on for exisiting files in the file group.

 

In researching the error I came across KB Article 19231 which seemed to confront what I am encountering, as our DB is at 4,193,152 KB.  So I attempted to remedy the issue as recommended in that article, I deleted a bunch of historic data, 50,000 out of the 170,000ish total entries, and the database size did not alter whatsoever, it is the exact same size, to the kilobyte as before I deleted the data.  The entries are gone, ACT now says we have a total of 120,000ish entries, but the size has not changed and I still get the same error when I attempt to reindex.  I tried to copy the database, but I get the same error of having no space available.


Any assistance would be greatly appreciated.

 

Thank you!

Mike Trevino