Community
Showing results for 
Search instead for 
Do you mean 
Reply

Outlook add-ins only load while running Outlook as an admin

Copper Contributor
Posts: 101
Country: Australia

Outlook add-ins only load while running Outlook as an admin

Hi All

 

Running act! v21.0 update 7, Windows 10.  Was running Outlook 2013 and now upgraded to Outlook 2016.  If you open Outlook normally the add-ins for act! don't start.  You can turn them on in the COM Add-ins in Outlook and will run fine.  Close Outlook and reopen and the add-ins are missing.

 

If I run as admin they load correctly.  this first showed up with Outlook 2013.  They upgraded to Outlook 2016, which broke the add-ins altogether, so I reinstalled act! and they are back, but still the same issue the add-ins will only run if you run Outlook as an admin.

 

I followed a few steps from this KB - http://kb.act.com/app/answers/detail/a_id/23022/

 

Checked load behaviour in the registry.

Ran a repair on Outlook.

disabled all of the other add-ins and tried to just load the act! add-ins

Turned off UAC rebooted.

replaced the add-ins dll files.

 

Any other ideas?  I suspect it is something permission based with windows

 

Thanks

Damon

 

Copper Super Contributor
Posts: 69
Country: Germany

Re: Outlook add-ins only load while running Outlook as an admin

I'd recommend changing the Addin's load behavior in the regisiry. That usually solves the issue.
Jan Teske
ACC
jbt consulting
Copper Contributor
Posts: 101
Country: Australia

Re: Outlook add-ins only load while running Outlook as an admin

Thanks Jan

 

I checked the load behaviour in the registry and it was already set to 3.  Which the KB suggests.  Is that what you are referring to?  Or do you change it to another value?


@Jan Teske wrote:
I'd recommend changing the Addin's load behavior in the regisiry. That usually solves the issue.

 

Cheers

Damon

Nickel Super Contributor
Posts: 423
Country: Germany

Re: Outlook add-ins only load while running Outlook as an admin

Sometimes the crucial Word addin key also exists under HKCU and has not the value 3. Worth checking that as well.
Andreas Schlesselmann
Melville-Schellmann GbR
Germany
www.melville-schellmann.de
Copper Contributor
Posts: 22
Country: United States

Re: Outlook add-ins only load while running Outlook as an admin

Care to share the applicable reg keys?

Nickel Super Contributor
Posts: 423
Country: Germany

Re: Outlook add-ins only load while running Outlook as an admin

Here are the 2 places where I (sometimes) find them besides the HKCU place:

Computer\HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Addins\ACT7.OfficeAddIn

Computer\HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Addins\ActOffice2007Addin.Connect

 

 

Andreas Schlesselmann
Melville-Schellmann GbR
Germany
www.melville-schellmann.de