Community
Showing results for 
Search instead for 
Do you mean 
Reply

No Results in Universal Search & Sage Connected Services Error ONLY in Existing DB

Tuned Listener
Posts: 23
Country: Canada

No Results in Universal Search & Sage Connected Services Error ONLY in Existing DB

Hi Guys,

 

We have a client who uses universal search mostly for APFW Mobile. It seems since upgrading to ACT 2012 they get an error message when logging in:
"We cannot access your Sage Connected Services account at this time – Please make sure your Internet connection is active and try again."

and Universal Search returns 0 results.

 

We have tried everything in KB 27857, 28201 and also tried deleting the index files (they do recreate themselves) but had no success.

 

The demo database as well as a newly created database work perfectly -  return results and have no error message about connected services at login. These issues are isolated with this one database.

 

We could export all data to a new database, but that takes a lot of time and can make a mess of things if there is data loss, not to mention would involve cutting 8 new remote databases. We are hoping there is a command or some way to repair the database without having to do this. None of the ACTDIAG repairs seem to fix anything.

 

Other Info:

Sage ACT! Premium (Web) 2012 Version 14.2.6.0

 ~9300 contacts

~1,2 GB attachments

ACT! Service Host: Running

KBs checked: 27857, 28201

 

If anyone has encountered this and either fixed it or not fixed it please let me know. Really want to get this fixed so they can start using APFW mobile.

 

Thanks in advance.

Mike

Platinum Super Contributor
Posts: 5,275
Country: USA

Re: No Results in Universal Search & Sage Connected Services Error ONLY in Existing DB

Mike,
- Does the user get the same error if signing into the database through the installed program (not Mobile)?
- Does Universal Search return results through the installed program?
- Are there other users of the database? Do they also have the same issues?
Greg Martin
Sage
Tuned Listener
Posts: 23
Country: Canada

Re: No Results in Universal Search & Sage Connected Services Error ONLY in Existing DB

Yes the errors I described are receieved on the installed program including the ACT server. No errors appear on the Mobile page - just search does not return results.

So yes, again with the installed program - even on the ACT server, universal search has no results to display unless you log into the demo database or create a new DB.

Yes all 8 other users recieve the same issues.

 

Thanks!

Platinum Super Contributor
Posts: 5,275
Country: USA

Re: No Results in Universal Search & Sage Connected Services Error ONLY in Existing DB

For error message:
- Do you have any remotes that synchronize with this database? If yes, did you also have them delete the preferences (kb 27857)?

- Do you use the Sage E-marketing interface? If not, the interface can be disabled - to prevent the message.

For Universal Search:
- Is there anything special about the physical location of the main database, different from the demo and new db's? Ex: different drive?

- Try: create a backup of the main database > then restore it using File > Restore > Database > RESTORE AS option. The Restore As option will enable you to give it a new name (not overwrite existing). Test Universal Search in the new copy of the database.
Greg Martin
Sage
Copper Super Contributor
Posts: 37
Country: Australia

Re: No Results in Universal Search & Sage Connected Services Error ONLY in Existing DB

I'm not sure of the physical location of the customer database above by I am having the same issue for a couple of my clients and for our own server. It seems to be an issue when the ACT! database is located on a different server to where ACT! and Microsoft IIS publishing the Website is located.

 

  1. I've added port exceptions on all servers for the universal search port 8112.
  2. I've tried reindexing the database through actdiag.
  3. I've tried restarting the host services.


Obviously if it cannot be done from a different location this will affect many clients who want the SQL databases on a different server to their Websites. Please, if there is a workaround, then we can utilise this great new feature for our large clients too.

Kind regards,

Matthew Wild
Act! Certified Consultant

Act Today Pty Ltd | 0755 712 344 | 0434048190 | matthew@acttoday.com.au | www.acttoday.com.au
Gold Coast
Copper Super Contributor
Posts: 37
Country: Australia

Re: No Results in Universal Search & Sage Connected Services Error ONLY in Existing DB

Just in case anyone else has this error on act! Premium for Web or Windows.

 

1. Check that there are search indices that match your database name under:

C:\ProgramData\Act\ACT Data\Indices\<Database Name> (newer windows operating systems)

2. If you have determined the 2 folders that match your database are missing, follow the steps below to force the database to be indexed (you can also remove the existing index folders, for the matching database, if they exist and you wish to force the indices to be recreated). You will need to stop the Act.Server.Host.exe process from the Processes tab in the Task manageer and then restart it after deleting these indices.

 

a) Run actdiag tool from run window (press start > type "actdiag" and hit enter) (from the host database PC/server)

b) once inside actdiag go to Databases menu and choose Database List

c) left click on the database you are having search problems with

d) Right click on it and select Refresh Search Indexes

Capture.PNG

d) Then login to your database on the windows host machine

e) Check the indices folder to see a folder matching your database appear - this might take a while

       C:\ProgramData\Act\ACT Data\Indices\<Database Name>

       another folder will appear in the format <Database Name>_Attachments in the same folder

f) Try searching now to verify it is working. Please note that for the database to become fully indexed it may take quite a bit of time depending on the size or your database and number of attachments.

 

As always, please use a Certified Act! consultant that knows what they are doing as doing the above incorrectly could cause issues.

Kind regards,

Matthew Wild
Act! Certified Consultant

Act Today Pty Ltd | 0755 712 344 | 0434048190 | matthew@acttoday.com.au | www.acttoday.com.au
Gold Coast