Community
Showing results for 
Search instead for 
Do you mean 
Reply

No ADT option when saving templates in Word

New Member
Posts: 14
Country: United States

No ADT option when saving templates in Word

On one PC, when I select new template in Act, I can make the template and then when I go to save, it defaults to the database directory and only allows me to save in ADT.

 

On another PC, it defaults to My Documents and allows me to save as anything but ADT. 

 

I followed the steps in this thread http://community.act.com/sage/board/message?board.id=Prem&message.id=6619&query.id=331127#M6619

 Specifically:

 [quote]

To see if it is enabled in Word, you can check this registry entry:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Word\Addins\ActOffice2007Addin.Connect | LoadBehavior

 

This value should be 3

If it is 2, try changing it to 3.

 

If when you start Word, Word changes it to 2, then the DLL is not working properly.

 

If this is the case, please check the following registry entry:

HKEY_CLASSES_ROOT\CLSID\{CCFA3D3B-C317-455C-9292-960F81287088}\InprocServer32 | CodeBase

 

This value should be set to the full path to this DLL in your ACT! install directory.

 

If it is not set or does not exist, you cannot just set it, you have to register the DLL properly.

[/quote]

 

I was missing the CLSID entry entirely, so I followed the directions in another thread. http://community.act.com/sage/board/message?board.id=ACT&message.id=19563

[quote]

Close ACT! and any Office applications

Run the following cmds from CMD prompt (Start | Run | cmd)

  1. c:
  2. copy "c:\program files\act\act for windows\REGASM.EXE" "c:\program files\act\act for windows\office2007\regasm.exe"
  3. cd\program files\act\act for windows\office2007
  4. regasm ActOffice2007Addin.dll
  5. cd..
  6. regasm Act.Office.Addin.dll
[/quote]

 That created the CLSID entry, but did not fix my problem.

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: No ADT option when saving templates in Word

It may be that ACT! and Word did not properly connect when installed on that PC. You want to try uninstalling ACT!, then to be sure run Detect & Repair (Office 2002-2003) or Office Diagnostics (Office 2007) from the Help menu in Word, reboot the machine and then reinstall ACT!

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

Astute Commentator
Posts: 5
Country: USA

Re: No ADT option when saving templates in Word

We have a Win7 PC with Sage ACT! Premium (Web) 2011 Version 13.0.401.0, Hot Fix 2 & Word 2010 - have tried all of the above and still can't get adt templates to work - Do you have any other suggestions?

Avid Listener
Posts: 44
Country: USA

No ACT! menu in Word 2003

Ok, there is a lot of discussion on this, I hope my travels help others shorten the distance from frustration to solution.

 

Here is what finally worked for me. It is an amalgimation of 3 KB articles and great community support. Thanks a million.

 

First, I am using ACT! 2010 12.0.409.0 with Office 2003 Pro

1) If your computer came with the Office 2007 teaser and then you installed ACT! followed by Office 2003, you will need to take the following steps.

 

a) Uninstall Office 2007

b) Install Office 2003

c) reboot

 

If you have Office 2003 I assume you did these steps - but Office 2007 should be uninstalled.

 

a) uinistall ACT!

b) reboot

c) install ACT!

 

 

 

2)go into the registry and remove the following key:

 

HKEY_Current_User\Software\Microsoft\Office\Word\Addins\ACT7.OfficeAddin

 

At least the 2010 version does not use this key and will only get you confused by this article in support: In my case it actully prevented the proper DLL frm loading within Word.


http://kb.sagesoftwareonline.com/cgi-bin/sagesoftwareonline.cfg/php/enduser/std_adp.php?p_faqid=2168...

 

You can also go to support.act.com and click on 'Knowledge Base' then search for

' Unable to Access the ACT! Menu Option on the Microsoft® Word or Excel® Tool Bar' (without single quotes)

to find the article above

 

This is for a previous version of ACT! addin and has not been updated. Thus a small Easter Egg Hunt will follow if you rely on this article.

 

The key you want for this version is:

 

HKEY_Current_User\Software\Microsoft\Office\Word\Addins\ActOffice2007Addin.connect -this is for all versions of office despite the title.

 

3) repairing Office is just a generally good idea. If you are on a stand alone workstation this can be done from the 'Help' 'Detect and repair' with Word.

 

For a terminal server instance, you must go to the Add/remove (or 2008 equivalent) and repair from there.

 

4) I applied this fix from Microsoft as just a good step: Update for Office 2003 (KB907417)

It did not fix the problem outright, but I'm unclear if it help - read #5 below

 

5) This is necessary and what ultimately fixed my situation along with #2 (I believe)

 

Close ACT! and any Office applications

Run the following cmds from CMD prompt (Start | Run | cmd)

  1. c:
  2. copy "c:\program files\act\act for windows\REGASM.EXE" "c:\program files\act\act for windows\office2007\regasm.exe"
  3. cd\program files\act\act for windows\office2007
  4. regasm ActOffice2007Addin.dll

Single line version: you can cut and paste the line below - including quotes - and then at the command prompt - right click and click on 'paste'

 

"c:\program files\act\act for windows\REGASM.EXE" "c:\program files\act\act for windows\office2007\ActOffice2007Addin.dll"


As an aside, there is limited discussion as to what the 'ACT!' menu item really is.  The blind assumption is that there is only one answer. Well, the ACT! menu could be on the Tools menu, on the Merge menu, on the Insert Fields menu, etc. Thus the assumption can again lead you on a goose chase if you don't see ACT! right on the main Word page. In my case I assumed it was a sub-menu and I just could not find it - aka. I was the problem. Since it is not a sub-menu, and there is no definitive statement where the ACT! menu item is suppose to be in any help, community or guide (I did not study all of them), thus a goose chase ensued.

 

The proper place for it is to the left of the 'Help' on the MAIN word menu.

 

My Word menu now reads from left to right: File Edit View Insert Format Tools Table Window ACT! Help

 

 

 

 

 

DBS
Astute Commentator
Posts: 5
Country: USA

Re: No ACT! menu in Word 2003

With Office 2010 & ACT Premium - the issue is the addin that is installed with downloadable or preloaded Office.

 

What I ended up doing for all our machines is unloading ACT, all of the Microsoft Software, reboot, install from a CD MS Office, reboot, then reinstall ACT.

 

Encumbersome & tricky but that ended up being the solution - even though I had tried all of the registry edits etc prior to installing Office from the CD.