Community
Showing results for 
Search instead for 
Do you mean 
Reply

Network synchronisation issues

Accepted Solution Solved
New Member
Posts: 4
Country: United Kingdom
Accepted Solution

Network synchronisation issues

The company I support installed Act! 2009 premium about 3 months ago. To begin with, all seemed to be working perfectly. The only exception being that the network sync service was not installed, or even mentioned as required, so Act! had to be open on the server for users to sync.

 

As the program was occasionally closed on the server and not reopened, users were unable to sync. Solution: Login, and open Act!

Then users began complaining that it still wouldn't synchronise, even with the program open on the server. Initially this only happened when they were in the office, and connected wirelessly. They were still able to sync off site over the VPN. While that issue was being investigated, there was no serious hurry as the users were rarely in the office.

 

This problem has now seriously escalated, as users are unable to synchronise at all. The synchronisation seems to take a very long time to do nothing. It will pass the first two stages of synchronisation, although a little slower than expected. At the third stage, sending and receiving of files, the progress seems to halt. It can stay in this state for well over an hour before eventually giving the error:

 

"Synchronisation has failed. Server Error Description: Agent Facade failed to apply changes. Status Manager failed to apply statuses. Not enough status sent Contact your administrator for assistance."

 

I have tried creating a new remote database to test, this also failed to synchronise, but this time there was no error message. It simply had no progress even after 3 hours.

 

To make matters even more confusing. While typing this message, I tested the synchronisation on both remote databases, and it seems to have been successful. As far as I'm aware, there have been no changes from yesterday. Only possible reason being that it's a Saturday? The office has 4 desktops, there are 4 remote laptop users. The server is running SBS 2003 R2 on a quad core with 4GB ram. It is used for the Act! database (approximately 100MB,) exchange for the 8 users, and Blackberry Enterprise.

 

Can anyone think of what is causing this problem? Also, while I'm working at the weekend remotely, is there anywhere I can download the install for the Network synchronisation service? I'd rather do that this weekend if possible instead of waiting till next week.


Accepted Solutions
Solution
Accepted by topic author OurSouls
‎09-25-2015 03:20 AM
Nickel Contributor
Posts: 410
Country: Canada

Re: Network synchronisation issues

The Network Sync setup is on your ACT CD.

I also don't like Exchange and ACT! being hosted on the same computer. It works, but with Exchange often consuming 600MB of memory or more, and SQL Server frequently consuming the same, intermittant problems like the one you're describing do come up.

Your work week troubles combined with your Saturday success seems to suggest this is likely, as well.

 

Also, try loading the Sample database and cutting an RDB from it to see how it synchs. Despite what I said, you need to rule out the database as the cuprit, as well.

The one other idea I suggest for now is punching a whole in the router for the synch port and bypassing the VPN. It's a secure channel, so this measure does not compromise the security of your network. 

 

Ken Quigley, BA, MCSE, ACC, APT
Toronto, Ontario
www.keystroke.ca

View solution in original post


All Replies
New Member
Posts: 4
Country: United Kingdom

Re: Network synchronisation issues

[ Edited ]
Forgot to add one more thing. At one stage there was a complaint that the synchronisation was claiming to be a success, but on checking the contents of the database, it hadn't updated. To follow that up, users have also been getting messages like "You have not synchronised for 20 days..." when they apparently successfully synchronised just a day or two prior.
Message Edited by oursouls on 02-21-2009 07:02 AM
Solution
Accepted by topic author OurSouls
‎09-25-2015 03:20 AM
Nickel Contributor
Posts: 410
Country: Canada

Re: Network synchronisation issues

The Network Sync setup is on your ACT CD.

I also don't like Exchange and ACT! being hosted on the same computer. It works, but with Exchange often consuming 600MB of memory or more, and SQL Server frequently consuming the same, intermittant problems like the one you're describing do come up.

Your work week troubles combined with your Saturday success seems to suggest this is likely, as well.

 

Also, try loading the Sample database and cutting an RDB from it to see how it synchs. Despite what I said, you need to rule out the database as the cuprit, as well.

The one other idea I suggest for now is punching a whole in the router for the synch port and bypassing the VPN. It's a secure channel, so this measure does not compromise the security of your network. 

 

Ken Quigley, BA, MCSE, ACC, APT
Toronto, Ontario
www.keystroke.ca
New Member
Posts: 4
Country: United Kingdom

Re: Network synchronisation issues

Well, it seems that running the service helped to lighten the load. There are still a few times when there are delays when synchronising, but it happens a lot less now. I'd love to have the database being on a different server, but unfortunately with just 8 users it's not really appropriate to have 2 servers.

 

So far, problem solved. Touch wood.