Community
Showing results for 
Search instead for 
Do you mean 
Reply

Network Sync Service will not start

Tuned Listener
Posts: 74
Country: United States

Network Sync Service will not start

Preparing a new server that is replacing a failing computer (not act, but computer). This is APFW, we use the web server,an inside network, and 2 outside users that sync. I use network sync via a fqdn. (I have never gotten internet sync to work, but that is a different story).

 

Got it mostly working, but couldn't get remote sync to work. The task tray double arrow said network sync is running. But kept getting an error saying "Unable to find Sync Server Object \\Servername...." But i knew my settings were correct. By hunting around, I saw that tools/database sync/accept incoming sync was not checked. So I clicked on it. It said 'network sync started', and wouldn't put a check mark there. So I closed act, then ran the act network sync program. Clicking on that brought up a dialog box asking to continue, which i said yes, but did nothing.

 

Then I stopped network sync in the task tray. I re opened act, clicked on accept incoming sync, and voila, i got it to work. 

 

Then rebooted the computer. Figured it should work without me doing this and without act running.. Task tray had double arrow network sync service running. Without opening act, tried syncing. No go. Stopped sync services. Opened act, clicked accept incoming syncs. Works again. Task tray has network sync service NOT running, but I can sync!

 

However, I should not have to do all this, it should just start sync service automatically when I start the ccomputer. Any suggestions would be greatly appreciated. 

Tuned Listener
Posts: 74
Country: United States

Re: Network Sync Service will not start

Here are the exact steps re created. Can't figure this out. Works great on old serve wiwthout opening act, but can't get new server to perform identical. I have port 65100 being forward from router to new machine (old machine is turned off).

 

I can sync. But not automatically when the computer starts. When it starts, it comes up the dialog box “allow acy.sync.services to start”. I click yes. (This is the same as the current server). In the task tray, the double arrows show “act network sync services running”

 

If I try to do a sync, I get “Unable to acquire sync server object, failed to find main server \\ACTServer...

 

If I then go to the task try, rt click, and stop network sync server, then go and open ACT, (making sure to look to see if Tools\sync database\accept incoming syncs are checked), it syncs fine!

 

If I then close ACT and try to sync, I get the “ACT is unable to connect to the sync server, check to be sure accept incoming sync and the network sync server is running…” Which makes sense since sync server is NOT running.

 

If I then re enable sync services in the task tray, I get the “Unable to acquire sync server object, failed to find…”

 

It works when sync server is NOT running, with ACT open,

 

But I don’t want to keep act open and running!

Tuned Listener
Posts: 74
Country: United States

Re: Network Sync Service will not start

Fixed it! When I looked for .PAD files, I found a few. I am sharing the file actdemo2018 under users\public\public documents\act\actdata\.... This pad file has the host="server name" and location=" directory structure. "

 

There is also a pad file under \users\documents\act\actdata\... that has host={local} and location = ""

 

Not sure why multiple pad files.

 

So when I went into the Network sync program, I saw that the database being attached was {local}\database

 

I deleted that, and added the database with "users\public\public documents\act\actdata\." which showed up.

 

Rebooted, asked me if I wanted to start network sync services, click yes, did a sync, and voila, it worked!

 

Now just need a way for network sync services to start without asking.

 

Hope my trials and tribulations will help others !

Administrator
Posts: 1,143
Country: United_Kingdom

Re: Network Sync Service will not start

Thanks for the info, jbinbi - like you say, hopefully this will help someone struggling with the same issue.