Community
Showing results for 
Search instead for 
Do you mean 
Reply

Network Sync Problem

Accepted Solution Solved
Highlighted
Tuned Listener
Posts: 26
Country: United States
Accepted Solution

Network Sync Problem

I have been successfully running Internet sync with my ACT! 21.0 system with my remote in the same office syncing through my local wi-fi. It's running fine.

 

I want to change to using Network sync outside of my wi-fi. I installed the Network Sync Service from the v21 installation folder. I shut down the Act Internet Sync service and started the Act Network Sync service. I used the Services app and verified the Network Sync Service was running.

 

I clicked on "Accept Incoming Sync" on the Synchronize Database option. I then got the error "Could not start sync server. Act! has encountered an error, please check that the sync server port is able to listen for incoming connections. "

 

The message says it couldn't start sync server. But the Act! Network Sync Service is running when checked via the Services app and it's window is open.

 

I am using port 65100 for the Network Sync which is the same port I am using for the Internet Sync successfully. 

 

I also tried when having my security software disabled with no change.

 

Thoughts or suggestions? Thanks.

 


Accepted Solutions
Solution
Accepted by topic author dennyp
‎02-02-2019 06:30 PM
Silver Contributor
Posts: 1,792
Country: United_Kingdom

Re: Network Sync Problem

[ Edited ]

Network Sync works where remote users are able to connect to the network, often by VPN, to then sync thier remote database back to the server (Publishing) database.  There are 2 ways of allowing the incoming sync on network syncing to sync, one is simply by clicking the Accept Incoming Syncs under Tools - Synchronise database on the Publishing database. This means the publishing database has to be running so is not the best option but can be useful in fault finding sync problems. BUT if this option is enabled you will not be able to run the 2nd option ACT Internet Sync which is a separate app as it will not be able to open the port as the first option will already have It open.

 

Act Network Sync is a separate app that does not need ACT to be running and also gives the option for syncing more that one database where you have multiple publishing databases on your server. Again, as its name implies, you must be connected to a network to use this option to sync, either directly or by VPN or similar.

 

ACT Internet Sync uses the IIS WEB service (normally on the on the server that the ACT database is on) so that remote users can sync via the internet and not need to be connected to the LAN network. This is now my preferred way of syncing as a VPN connection is not needed to sync, just a reasonable internet connection.

 

So back to your error, if ACT Internet Sync will not run make sure you have not blocked the port by clicking Accept Incoming Syncs within the ACT program.

 

View solution in original post


All Replies
Nickel Elite Contributor
Posts: 619
Country: USA

Re: Network Sync Problem

Hello...

 

Accept incoming Syncs Must be enable (Tools - Synchronize Database - Accept incoming Syncs) even if the service is installed

 

Synchronization through the Internet is from outside the office

 

The synchronization service via internet can keep it with port 65100, and if you want you can change the port of synchronization through the local network to 65200 ... then in the remote database the same port 65200 is configured for achieve synchronization

 

Tip ... if the synchronization through the internet works properly inside and outside the office ... you can leave that single service to synchronize from anywhere

 

Good luck and do not forget to make a daily backup of your database (File - Backup - Database - click on Browse to place this backup in your documents folder), and place a copy of that ZIP file in a USB memory or external disk for better security... In case the Hard Drive is damaged or  receive a virus attack

 

Best regards... Praxi Solutions Inc

Juan Carlos Otero Garcia
juancarlosotero@protonmail.com
Tuned Listener
Posts: 26
Country: United States

Re: Network Sync Problem

You said "Accept incoming Syncs Must be enable (Tools - Synchronize Database - Accept incoming Syncs) even if the service is installed". As I mentioned in my original post, when I do that, I get the error message that I posted earlier.

Silver Contributor
Posts: 1,792
Country: United_Kingdom

Re: Network Sync Problem

There are 2 ways to activate networks sync. One is by clicking Accept Incoming Syncs form the Tools - Sync - inside a running Publishing database. The other is to run the Network sync service application. You cannot run both as they will try to use the same port. (Unless you change the port number in one of the programs.)

 

Start by going to Services in windows and stopping Internet sync, run the sync service within ACT under tools and try syncing.

 

If that works now untick the Accept incoming syncs in Tools and start the Internet sync program, now try syncing. If that does not work look at how the service has been set up.

Tuned Listener
Posts: 26
Country: United States

Re: Network Sync Problem

Thanks for your reply. You mention both Network Sync and Internet Sync in your reply. I thought Network Sync is what I need to use when the 2 systems are not on the same local network. And Internet Sync is used when both systems are on the same local network. Am I mistaken?

 

Additionally, Act Internet Sync when running, does not appear in the Services app window.

 

Thanks.

Solution
Accepted by topic author dennyp
‎02-02-2019 06:30 PM
Silver Contributor
Posts: 1,792
Country: United_Kingdom

Re: Network Sync Problem

[ Edited ]

Network Sync works where remote users are able to connect to the network, often by VPN, to then sync thier remote database back to the server (Publishing) database.  There are 2 ways of allowing the incoming sync on network syncing to sync, one is simply by clicking the Accept Incoming Syncs under Tools - Synchronise database on the Publishing database. This means the publishing database has to be running so is not the best option but can be useful in fault finding sync problems. BUT if this option is enabled you will not be able to run the 2nd option ACT Internet Sync which is a separate app as it will not be able to open the port as the first option will already have It open.

 

Act Network Sync is a separate app that does not need ACT to be running and also gives the option for syncing more that one database where you have multiple publishing databases on your server. Again, as its name implies, you must be connected to a network to use this option to sync, either directly or by VPN or similar.

 

ACT Internet Sync uses the IIS WEB service (normally on the on the server that the ACT database is on) so that remote users can sync via the internet and not need to be connected to the LAN network. This is now my preferred way of syncing as a VPN connection is not needed to sync, just a reasonable internet connection.

 

So back to your error, if ACT Internet Sync will not run make sure you have not blocked the port by clicking Accept Incoming Syncs within the ACT program.

 

Tuned Listener
Posts: 26
Country: United States

Re: Network Sync Problem

Thanks to the help received here, I have the remote Network Sync working from Jamaica back to Phoenix. At least it appears to be working. When I get back next week, I will check that everything synched up correctly.

 

Thank you all.