Community
Showing results for 
Search instead for 
Do you mean 
Reply

Manual backup problem

New Member
Posts: 16
Country: United States

Manual backup problem

Hi,

I'm using ACT! Premium 2008 (10) ST Ver on a Windows 2003 server via Terminal Services, and have the automatic scheduler on for nightly backups and maintenance.  I have done manual backups before, but I believe they were done before I set up the scheduler a few weeks ago.  The scheduler backups seem to run fine - no errors according to log.

 

Here's my problem: when I try to do a manual backup (occasionally I like to do a separate backup to another location), it starts normally, but never finishes.  When I cancel it, I get the following error message: The process cannot access the file "(path and file name' because it is being used by another process."  I've tried new file names, and different locations, but still get the same error message.  I've also tried turning off the scheduler and "un-sharing" the database.

 

Any help would be greatly appreciated!

 

Thanks,

Kathy

Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: Manual backup problem

New Member
Posts: 16
Country: United States

Re: Manual backup problem

Hi Mike,

 

Thanks so much for the article link.  I had a question about it: if there's a problem with the supplemental files as the article suggests, would I be able to get a good backup through the scheduler?  The scheduler log reports no errors on the backups, so I'm wondering how those could go through OK, but the manual ones (albeit to different locations) won't.  

 

Thanks again!

-Kathy

Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: Manual backup problem

Not sure if they are done differently...are you doing both on same local machine?

 

Maybe try a restore (restore_as) from a backup to a different name and compare the files in each of the supplemental files folders. I always recommend doing this every now and again to make sure he backup is working ok. Don't want to find out when you need it.

New Member
Posts: 16
Country: United States

Re: Manual backup problem

Hi Mike,

 

For the nightly backup using scheduler, it's backing up to the server (Windows Server 2003).  All the work I do with ACT! is via Terminal Services from a remote location, so that's how I access ACT! for everything, including running backups.    For the manual backups, I like to save it to my local C: drive (again via Terminal Services).  I've done this several times in the past, and it seemed to work fine.  When I started having problems, though, even trying a manual backup to the server didn't work.

 

Good idea on the"restore as".  I'll try that to make sure the scheduler backups are working fine.

 

Thanks!

Kathy

Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: Manual backup problem

It's likely one of the supplemental files has a permission change that's preventing the backup... odd that the scheduler seems to skip it ok.

 

But try the suggestions in that KB I posted to be sure.

New Member
Posts: 16
Country: United States

Re: Manual backup problem

Hi Mike,

I'll give it a try.

Thanks,

Kathy