Community
Showing results for 
Search instead for 
Do you mean 
Reply

Login takes 3+ minutes when run from DMZ

Accepted Solution Solved
Copper Contributor
Posts: 25
Country: United_Kingdom
Accepted Solution

Login takes 3+ minutes when run from DMZ

Hi,

 

I am experiencing extremely slow login issue when authenticating against the web interface of Act when the host is in the DMZ. Logins are taking 3-4 minutes and shows "preparing your database, please wait" during this time. Eventually the web application opens and appears to work fine.

 

Detail

Act version: 17.2.217.0

No Outlook/Office integration

Installed on: Windows Server 2008 R2

 

Background
I built a fresh Windows Server 2008 R2 machine (virtual) and put it in the DMZ. It is not part of the domain, but exists in it's own workgroup. The only ports open to this externally are 80 and 443. I followed the Admin Guide to get Act Premium for Web installed. I created a new, fresh database and added it using "Web Site Administration" utility. I tested this and got the 3-4 minute login times. I notice the following error logged to the Application Event Log which coincides with the web page eventually loading

 

"There was an exception om (sic) downloadMarketingNotificationBucket: A WebException with status ConnectFailure was thrown." (source: AFW, Event ID: 0)

 

Locally, the application works fine and opens in good time.

 

I called tech support and they suggested I build another server - so I did that. I built another fresh server, installed Act as before but this time I left it connected to our corporate network. I can login to the web interface in about 8 seconds and the above error is not logged. If I move the same computer back into the DMZ and test again, the login takes 3-4 minutes again. If I move it back to the network, the login is quick.

 

What is going on? 


Accepted Solutions
Solution
Accepted by Gary W (Administrator)
‎10-21-2015 08:36 AM
Copper Contributor
Posts: 25
Country: United_Kingdom

Re: Login takes 3+ minutes when run from DMZ

Hi,

 

I have been looking at this all day and just managed to get it sorted. I contacted our ISP, who also manage our firewall, and unknown to me the DMZ zone they setup only allowed outbound port 80 from the web server. They added port 443 as well and this appears to have fixed the issue.

 

Apologies for wasting your time, I just assumed the error was application related. 

 

Best regards,

Mike.

View solution in original post


All Replies
Administrator
Posts: 4,024
Country: United_Kingdom

Re: Login takes 3+ minutes when run from DMZ

Hi Mike,

I haven't seen this issue before. I've escalated it to the Product Specialists to investigate. I'll update this thread when I have further info.
Copper Contributor
Posts: 25
Country: United_Kingdom

Re: Login takes 3+ minutes when run from DMZ

Thanks. I look forward to their suggestions. 

 

I should add that I'm using a local SQL Express database - not connecting to a remote database. Everything is on this single server, on it's own in a workgroup.

 

Thanks.

Administrator
Posts: 4,024
Country: United_Kingdom

Re: Login takes 3+ minutes when run from DMZ

Suggestion:

 

One thing to check for in this environment is a proxy server. You can ask the administrator to check the logs to see if the computer is reaching out to protexis (our DRM service). You’d be looking for hits to the protexis website.

A good test to see if protexis is holding the user from logging-in in a timely manner is stopping the protexis service and trying to log in. You should be able to log in faster with protexis disabled. This will show that protexis is the problem.

 

 

Copper Contributor
Posts: 25
Country: United_Kingdom

Re: Login takes 3+ minutes when run from DMZ

Hi Gary,

 

Thanks for the suggestion. I had time to test this today but unfortuantely it did not help.

 

I stopped the Protexis service, launced my browser and attempted to login but still had a very long delay before the page loaded. The same error was logged to the Event Viewer at the time the page eventually loaded.

 

Can you suggest anything else to try? I have a full dump from ProcMon (~60MB) if that's useful?

 

Best regards

 

 

 

Administrator
Posts: 4,024
Country: United_Kingdom

Re: Login takes 3+ minutes when run from DMZ

Hi Mike,

We'd have to take a closer look at this. Give us a call on 0845 268 0220. When you speak to a technician, please give them the ticket number I have created for you, that you'll find in your PM inbox.
Solution
Accepted by Gary W (Administrator)
‎10-21-2015 08:36 AM
Copper Contributor
Posts: 25
Country: United_Kingdom

Re: Login takes 3+ minutes when run from DMZ

Hi,

 

I have been looking at this all day and just managed to get it sorted. I contacted our ISP, who also manage our firewall, and unknown to me the DMZ zone they setup only allowed outbound port 80 from the web server. They added port 443 as well and this appears to have fixed the issue.

 

Apologies for wasting your time, I just assumed the error was application related. 

 

Best regards,

Mike.

Administrator
Posts: 4,024
Country: United_Kingdom

Re: Login takes 3+ minutes when run from DMZ

No problem, thanks for letting us know.